<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3291456012722699",
    enable_page_level_ads: true
  });
</script>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.stlucianewsonline.com/xmlrpc.php" />

<meta property="og:description" content="(BBC) -- Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November's presidential election. He said on Twitter that he had secured the 1,991 delegates needed and would fight to 'win the battle for the soul of the nation'. He had been the effective nominee since Bernie Sanders withdrew in April. Coronavirus - and its effect on the economy - and the recent civil unrest are sure to dominate the election. Mr Biden, who served as Barack Obama's vice-president, began the primary campaign in faltering style in Iowa and New Hampshire, but then built">
<meta property="og:title" content="Joe Biden formally wins Democratic nomination to take on Trump">
<meta property="article_author" content="Admin">
<meta property="article_publisher" content="Admin">
<meta property='og:image' name='image' content='https://www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg'>
<meta property="fb:app_id" content="529576650555031">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/">
<meta property="og:site_name" content="St. Lucia News Online">
<meta property="article:published_time" content="2020-06-06T13:14:01-04:00">
<meta property="article:modified_time" content="2020-06-06T13:14:01-04:00">
<meta property="og:updated_time" content="2020-06-06T13:14:01-04:00">
<meta name="twitter:title" content="Joe Biden formally wins Democratic nomination to take on Trump">
<meta name="twitter:description" content="(BBC) -- Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November's presidential election. He said on Twitter that he had secured the 1,991 delegates needed and would fight to 'win the battle for the soul of the nation'. He had been the effective nominee since Bernie Sanders withdrew in April. Coronavirus - and its effect on the economy - and the recent civil unrest are sure to dominate the election. Mr Biden, who served as Barack Obama's vice-president, began the primary campaign in faltering style in Iowa and New Hampshire, but then built">
<meta name="twitter:image" content="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg">
<meta name="twitter:card" content="summary_large_image">
<style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.0.1");
		src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.0.1#iefix") format("embedded-opentype"),
		url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.0.1") format("woff"),
		url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.0.1") format("truetype"),
		url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.0.1#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>


<title>Joe Biden formally wins Democratic nomination to take on Trump</title>
<meta name="description" content="Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November&#039;s presidential election. He said on Twitter that he had secured the 1,991 delegates needed and would fight to &quot;win the battle for the soul of the nation&quot;. He had been the effective nominee since Bernie Sanders withdrew in April." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Joe Biden formally wins Democratic nomination to take on Trump" />
<meta property="og:description" content="Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November&#039;s presidential election. He said on Twitter that he had secured the 1,991 delegates needed and would fight to &quot;win the battle for the soul of the nation&quot;. He had been the effective nominee since Bernie Sanders withdrew in April." />
<meta property="og:url" content="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" />
<meta property="og:site_name" content="St. Lucia News Online" />
<meta property="article:publisher" content="https://www.facebook.com/stlucianewsonline/" />
<meta property="article:published_time" content="2020-06-06T17:14:01+00:00" />
<meta property="og:image" content="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?fit=660%2C371&#038;ssl=1" />
<meta property="og:image:width" content="660" />
<meta property="og:image:height" content="371" />
<meta property="fb:app_id" content="249337255435947" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@slunewsonline" />
<meta name="twitter:site" content="@slunewsonline" />

<link rel="amphtml" href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/amp/" /><meta name="generator" content="AMP for WP 1.0.52" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Feed" href="https://www.stlucianewsonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Comments Feed" href="https://www.stlucianewsonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Joe Biden formally wins Democratic nomination to take on Trump Comments Feed" href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.stlucianewsonline.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='resads-main-css' href='https://www.stlucianewsonline.com/wp-content/plugins/resads/css/main.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.stlucianewsonline.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ditty-news-ticker-font-css' href='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/libs/fontastic/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css' href='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='same-category-posts-css' href='https://www.stlucianewsonline.com/wp-content/plugins/same-category-posts/same-category-posts.css' type='text/css' media='all' />
<link rel='stylesheet' id='stcr-font-awesome-css' href='https://www.stlucianewsonline.com/wp-content/plugins/subscribe-to-comments-reloaded/includes/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://www.stlucianewsonline.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css' href='https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://www.stlucianewsonline.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css' href='https://www.stlucianewsonline.com/wp-content/themes/jarida/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='Oswald-css' href='https://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.stlucianewsonline.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='like-dislike-css' href='https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/css/ldc-lite.css' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.stlucianewsonline.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"262103","token":"e22bccdde6","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tieViewsCacheL10n = {"admin_ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","post_id":"262103"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/themes/jarida/js/postviews-cache.js'></script>
<link rel='https://api.w.org/' href='https://www.stlucianewsonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.stlucianewsonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.stlucianewsonline.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://www.stlucianewsonline.com/?p=262103' />
<link rel="alternate" type="application/json+oembed" href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F&#038;format=xml" />
<style></style> <style type="text/css">.pcs-content,.pcs-excerpt{text-align:justify}.gws .pcs-sub,.igws .pcs-sub,.iws .pcs-sub,.ws .pcs-sub{border-bottom:1px solid #777}.pcs-body,.pcs-main,.pcs-pagination,.pcs-sub{overflow:hidden}.pcs-body,.pcs-img,.pcs-meta,.pcs-pagination ul li,.pcsmeta{float:left}.pcs-reset{line-height:1.7em;margin-bottom:3px}.pcs-main{padding:10px!important}.pcs-sub:first-child{margin-top:0}.pcs-sub{margin-top:15px;padding-right:10px;clear:both;display:block}.pcs-body,.pcs-img{display:block;vertical-align:top;box-sizing:border-box}.pcs-body{width:60%}.pcs-img{width:30%;margin:0 10px 10px 0!important}.pcs-title{font-size:15px;display:block;padding:0;margin:0 0 5px}.pcs-excerpt{font-size:13px;display:block}.pcs-content,.pcs-meta{display:block;font-size:12px}.pcs-rm,.pcsmeta{display:inline-block}.pcs-meta a{font-size:12px!important}.pcs-rm{font-size:15px;clear:both;text-align:left}.pcs-img img{max-width:100%;max-height:100%;margin:0 auto}.pcsmeta{padding-right:10px}.pcs-cust-field,.pcs-pagination{display:block;clear:both}.pcs-meta .glyphicon{margin-right:3px}.gws .pcs-title a,.ws .pcs-title a{color:#222}.gws .pcs-excerpt,.ws .pcs-excerpt{color:#333}.gws .pcs-content,.ws .pcs-content{color:#444}.gws .pcs-meta,.gws .pcs-meta a,.ws .pcs-meta,.ws .pcs-meta a{color:#555}.gws .pcs-rm,.ws .pcs-rm{color:#666}.gws a:hover,.ws a:hover{color:#000!important}.igws.pcs-main,.iws.pcs-main{background-color:#333}.igws .pcs-title a,.iws .pcs-title a{color:#eee}.igws .pcs-content,.igws .pcs-excerpt,.iws .pcs-content,.iws .pcs-excerpt{color:#ddd}.igws .pcs-meta,.igws .pcs-meta a,.iws .pcs-meta,.iws .pcs-meta a{color:#ccc}.igws .pcs-rm,.iws .pcs-rm{color:#eee!important}.igws a:hover,.iws a:hover{color:#fff!important}.gcore .pcs-body,.gcore .pcs-img,.gws .pcs-body,.gws .pcs-img,.igws .pcs-body,.igws .pcs-img{width:100%}.pcs-pagination ul{display:inline-block;padding:0;margin:10px 1px;border-radius:50%;list-style-type:none}.pcs-pagination ul li a,.pcs-pagination ul li span{float:left;padding:10px 15px;line-height:1.5;color:#0275d8;text-decoration:none;background-color:#fff;border:1px solid #ddd;display:block;margin-left:-1px}.pcs-pagination ul li a:hover,.pcs-pagination ul li span.current{background-color:#0275d8;color:#fff}</style>
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://www.stlucianewsonline.com/wp-content/themes/jarida/favicon.ico" title="Favicon" /><meta property="og:title" content="Joe Biden formally wins Democratic nomination to take on Trump" />
<meta property="og:type" content="article" />
<meta property="og:description" content="

(BBC) -- Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in N..." />
<meta property="og:url" content="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" />
<meta property="og:site_name" content="St. Lucia News Online" />
<meta property="og:image" content="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?resize=620%2C330&ssl=1" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://www.stlucianewsonline.com/wp-content/themes/jarida/js/html5.js"></script>
<script src="https://www.stlucianewsonline.com/wp-content/themes/jarida/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.stlucianewsonline.com/wp-content/themes/jarida/css/ie8.css" />
<![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />
<style type="text/css" media="screen">




</style>

<script type="application/ld+json" class="saswp-schema-markup-output">
[{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","@id":"https:\/\/www.stlucianewsonline.com\/joe-biden-formally-wins-democratic-nomination-to-take-on-trump\/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.stlucianewsonline.com","name":"St. Lucia News Online"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.stlucianewsonline.com\/category\/all-news\/international-news\/","name":"International News"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/www.stlucianewsonline.com\/joe-biden-formally-wins-democratic-nomination-to-take-on-trump\/","name":"Joe Biden formally wins Democratic nomination to take on Trump"}}]}]
</script>
<style type="text/css" id="wp-custom-css">
			div.horizantal-ad.mid{
	text-align:center;
}

#rpwe_widget-7, #rpwe_widget-8, #rpwe_widget-9,
#rpwe_widget-11,
#wp_related_posts_widget,.article-page-right-ads{
	padding-top:15px!important;
}

.sidebar #rpwe_widget-11{
	margin-bottom: 0px;
}

#rpbt-related-gallery-1 img {
    border: 2px solid #cfcfcf;
    border: 1px solid #EEE!important;
    box-shadow: none!important;
    margin: 2px 10px 2px 0;
    padding: 3px!important;
    max-width: 45px;
    display: inline-block;
    float: left;
}

#rpbt-related-gallery-1 .gallery-caption {
    margin-left: 0;
    text-align: left;
}

#related-posts-by-taxonomy-2{
	margin-top: 20px;
    display: block;
    float: left;
}

#rpbt-related-gallery-1 .gallery-item{
	display:list-item;
	list-style-type: disc;
}
/*4571154*/
@media screen and (min-width: 1200px){
.logo {
    float: left;
    margin-top: 0;
}
body .header-ad {
    width: 100% !important;
    margin: 0;
}
.logo {
    margin-top: 3px;
    margin-left: 3px;
    margin-bottom: -7px;
}
nav#main-nav ul#menu-main-menu ul.sub-menu li, nav#main-nav ul#menu-main-menu ul.sub-menu li a {
    height: auto !important;
    line-height: 1 !important;
}
	nav#main-nav ul li a, nav#main-nav ul li, #main-nav ul li.current-menu-parent a ,#main-nav ul li.current-menu-parent a:hover,#main-nav ul li.current-menu-item a{
    height: 100% !important;
    line-height: 6 !important;
}
	
	#menu-main-menu > .parent-list > .sub-menu{
		top:90px !important;
	}
	
	
body.admin-bar .fixed-nav-appear {
    top: 60px;
}
}

.home .sidebar #wpp-7, .home #rpwe_widget-7{
	display:none !important;
}

#home-more-news a{
	    background: #009acd;
    color: #fff;
    padding: 10px 14px;
    display: block;
    width:fit-content;
	margin:auto;
	font-size:1rem;
}
@media screen and (min-width: 1100px){
.home .resads-adspot-78{
	margin-bottom:1.5rem;
}

	.home .sidebar .adsbygoogle{
			margin-bottom:1.5rem;
	}
	
	.single-post .resads-adspot-78 {
		margin-bottom:2rem;
	}
	.single-post #taboola-below-article-thumbnails{
		margin-top:2rem;
	}
}


@media(min-width:1100px){
#theme-header .header-content .logo{
	display:none !important;
}}

.home .content .home-ads ins {
    width: 100%;
}
.home .resads-adspot.resads-adspot-79 {
    margin-top: -15px;
}

.home section.cat-box.list-box.tie-cat-57 {
    margin-top: 20px !important;
}
.home aside.sidebar {
    margin-top: 20px;
}

.fixed-nav {
    position: relative;
}

.single-post .entry .single_page_after_conttent ul li a.post-title{
	font-family: Tahoma,Arial,Verdana,sans-serif;
    line-height: 18px;
}
button#show_comments_section {
    background: #016796;
    color: #fff;
    padding: 8px 13px;
    width: 100%;
    text-align: center;
    margin-bottom: 15px;
    cursor: pointer;
    border: none;
    transition: all;
}
.akismet_comment_form_privacy_notice{
	  font-size: 12px !important;
    color: #999;
}

.comment-awaiting-moderation::before { 
  content: "Please note: ";}

.comment-awaiting-moderation::after { 
  content: "  Your comment is awaiting moderation. This is a preview, your comment will be visible after it has been approved.";}

#show_comments_section {line-height:1.5em}
 .comment-form-url {display:none}

/*related posts by category*/
.single-post .entry .single_page_after_conttent ul li {
	margin-bottom: 25px !important;
}
.same-category-post-item {
	border-bottom: none !important;
}



		</style>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/stlucianewsonline-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<script type="text/javascript">
	jQuery('document').ready(function(){
		if(jQuery(window).width() >=1024){
			jQuery('.logo').insertBefore('nav#main-nav .main-menu');
		}
	});
</script>
<script type="application/ld+json">
{
    "@context":"https://schema.org",
    "@type":"NewsArticle",
    "mainEntityOfPage":{
        "@type":"WebPage",
        "@id":"https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/"
    },
    "url":"https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/",
    "headline":"Joe Biden formally wins Democratic nomination to take on Trump",
    "description":"(BBC) &#8212; Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November&#8217;s presidential election. He said on Twitter that he had secured the 1,991 delegates needed and would fight to &#8220;win the battle for the soul of the nation&#8221;. He had been the effective nominee since Bernie Sanders withdrew ...",
    "inLanguage":"en-US",
    "datePublished":"2020-06-06T13:14:01-04:00",
    "dateModified":"2020-06-06T13:14:01-04:00",
    "articleSection":"International News",
    "publisher": { 
        "@type":"Organization",
        "name":"St. Lucia News Online",
        "@id":"https://www.stlucianewsonline.com/",
        "sameAs":[
             "https://www.facebook.com/stlucianewsonline",
            "https://www.instagram.com/stlucianewsonline",
            "https://twitter.com/slunewsonline"
        ],
        "logo":{
            "@type":"ImageObject",
            "url":"https://www.stlucianewsonline.com/wp-content/uploads/2019/10/logo.jpg",
            "width":160,
            "height":50
        }
    },
    "author": {
        "@type":"Person",
        "name":"Merrick Andrews" 
    },
    "image": {
        "@type":"ImageObject",
        "url":"https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?fit=660%2C371&ssl=1",
        "width":660,
        "height":371
    },
    "thumbnailUrl":"https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?fit=300%2C169&ssl=1"
}
</script>
<script type="text/javascript">  var _gaq = _gaq || [];  _gaq.push(['_setAccount', 'UA-34917107-1']);  _gaq.push(['_trackPageview']);  (function() {    var ga = document.createElement('script'); ga.type ='text/javascript'; ga.async = true;    ga.src = ('https:' == document.location.protocol ? 'https://ssl' :'http://www') + '.google-analytics.com/ga.js';    var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga, s);  })();</script>
</head>
<body data-rsssl=1 id="top" class="post-template-default single single-post postid-262103 single-format-standard">
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=1381483658763791";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div align="" class="top-site-advert2">
<div style="width:1040px;margin:0 auto;max-width: 100%;text-align:center;">
</div>
</div>
<div class="wrapper full-site layout-2c animated">
<div style="width:100%;text-align:center;margin:0px auto 15px;">



</div>
<div class="top-nav fade-in animated1 head_brnews container">
<div class="container">
<div class="search-block">
<form method="get" id="searchform" action="https://www.stlucianewsonline.com/">
<button class="search-button" type="submit" value="Search"></button>
<input type="text" id="s" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" />
</form>
</div>
<div class="social-icons icon_flat">
<a class="tooldown" title="Rss" href="https://www.stlucianewsonline.com/feed/" target="_blank"><i class="tieicon-rss"></i></a> </div>
<div class="breaking-news">
<span>Don't Miss</span>
<ul>
<li><a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" title="Chinese nationals killed and burned in Zambia">Chinese nationals killed and burned in Zambia</a></li>
<li><a href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" title="Joe Biden formally wins Democratic nomination to take on Trump">Joe Biden formally wins Democratic nomination to take on Trump</a></li>
<li><a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" title="More St. Lucians return home Saturday">More St. Lucians return home Saturday</a></li>
<li><a href="https://www.stlucianewsonline.com/12-noon-june-6-2020-saint-lucia-weather-update/" title="12 noon June 6, 2020 Saint Lucia weather update">12 noon June 6, 2020 Saint Lucia weather update</a></li>
<li><a href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" title="Two males shot and chopped by gang in Soufriere">Two males shot and chopped by gang in Soufriere</a></li>
<li><a href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" title="United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)">United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)</a></li>
<li><a href="https://www.stlucianewsonline.com/opposition-wins-suriname-elections/" title="Opposition wins Suriname elections">Opposition wins Suriname elections</a></li>
<li><a href="https://www.stlucianewsonline.com/st-kitts-nevis-elections-dr-harris-hails-historic-victory-as-vote-count-continues/" title="St. Kitts-Nevis elections: Dr. Harris hails historic victory as vote count continues">St. Kitts-Nevis elections: Dr. Harris hails historic victory as vote count continues</a></li>
<li><a href="https://www.stlucianewsonline.com/trinidad-mom-56-son-29-shot-to-death-in-home-invasion/" title="Trinidad: Mom, 56, son, 29, shot to death in home invasion">Trinidad: Mom, 56, son, 29, shot to death in home invasion</a></li>
<li><a href="https://www.stlucianewsonline.com/trinidad-man-in-suriname-begs-to-come-home/" title="Trinidad man in Suriname begs to come home">Trinidad man in Suriname begs to come home</a></li>
</ul>
<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('.breaking-news ul').innerfade({animationtype: 'fade', speed: 750 , timeout: 3500});
							});
		</script>
</div> 
</div>
</div>
<div class="container">
<header id="theme-header">
<div class="header-content fade-in animated1">
<div class="logo">
<h2> <a title="St. Lucia News Online" href="https://www.stlucianewsonline.com/">
<img src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/SNO_LARGERLOGO-1024x466.jpg" alt="St. Lucia News Online" /><strong>St. Lucia News Online St. Lucia News Online brings daily breaking news, photos, and videos to St. Lucia</strong>
</a>
</h2>
</div>
<div class="grid8 headerAd">
<div style="" class="header-ad">

<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-3291456012722699" data-ad-slot="5075024987" data-ad-format="auto"></ins>
<script>
            		(adsbygoogle = window.adsbygoogle || []).push({});
            		</script>
</div>
</div>
<div class="clear"></div>

</div>
<div class="horizantal-ad mid" style="margin-bottom:10px;">
</div>
<nav id="main-nav" class="fade-in animated2">
<div class="container">
<div class="main-menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-125444" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="https://stlucianewsonline.com/">Home</a></li>
<li id="menu-item-2748" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://www.stlucianewsonline.com/about/">About</a></li>
<li id="menu-item-184" class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a>
<ul class="sub-menu">
<li id="menu-item-92491" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/accidenttragedy/">Accident/Tragedy</a></li>
<li id="menu-item-164608" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/">Caribbean</a>
<ul class="sub-menu">
<li id="menu-item-202324" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/antigua-and-barbuda-news/">Antigua and Barbuda News</a></li>
<li id="menu-item-202325" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/barbados-news/">Barbados News</a></li>
<li id="menu-item-202326" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/dominica-news/">Dominica News</a></li>
<li id="menu-item-202327" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/grenada-news/">Grenada News</a></li>
<li id="menu-item-202328" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/">Guyana News</a></li>
<li id="menu-item-202329" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/jamaica-news/">Jamaica News</a></li>
<li id="menu-item-202330" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/martinique-news/">Martinique News</a></li>
<li id="menu-item-202331" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/st-vincent-and-the-grenadines-news/">St. Vincent and the Grenadines News</a></li>
<li id="menu-item-204221" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/trinidad-and-tobago-news/">Trinidad and Tobago News</a></li>
</ul> 
</li>
<li id="menu-item-92485" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/crimepolice/">Crime/Police</a></li>
<li id="menu-item-92489" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/entertainment/">Entertainment</a></li>
<li id="menu-item-92487" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/financebusiness/">Finance/Business</a></li>
<li id="menu-item-92494" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/general/">General</a></li>
<li id="menu-item-92493" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/gis-news/">GIS News</a></li>
<li id="menu-item-92495" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/health/">Health</a></li>
<li id="menu-item-92496" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href="https://www.stlucianewsonline.com/category/all-news/international-news/">International News</a></li>
<li id="menu-item-38108" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/obituary/">Obituaries</a></li>
<li id="menu-item-92490" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/politics/">Politics</a></li>
<li id="menu-item-92486" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/sports/">Sports</a></li>
<li id="menu-item-92498" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/tourism/">Tourism</a></li>
<li id="menu-item-92499" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a></li>
<li id="menu-item-92492" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/all-news/youtheducation/">Youth/Education</a></li>
</ul> 
</li>
<li id="menu-item-164036" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/headlines/">Headlines</a></li>
<li id="menu-item-185" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://www.stlucianewsonline.com/category/columns/">Features</a>
<ul class="sub-menu">
<li id="menu-item-164609" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/beauty-of-the-day/">Beauty of the Day</a></li>
<li id="menu-item-164610" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/photo-of-the-day/">Photo of the Day</a></li>
</ul> 
</li>
<li id="menu-item-189" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="https://www.stlucianewsonline.com/category/interactive/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-191" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/interactive/commentary/">Commentary</a></li>
<li id="menu-item-193" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="https://www.stlucianewsonline.com/category/interactive/letters/">Letters</a></li>
</ul> 
</li>
<li id="menu-item-45047" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://www.stlucianewsonline.com/weather/">Live Weather</a></li>
<li id="menu-item-2747" class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href="https://www.stlucianewsonline.com/contact/">Contact</a></li>
</ul></div> </div>
</nav>
</header>
<div id="main-content" class="container fade-in animated3">
<div id="adAboveContentSideBar">
<style> #adAboveContentSideBar{text-align:center;} #execphp-15{margin-top: 6px} </style>
</div>
<div id="floating" class="floating">
</div>
<div class="content-wrap">
<div class="content">
<div class="top-site-show" style="width:100%; display: none;">
<center>



</center>
</div>
<div class="atop-site-show">
</div>
<div xmlns:v="http://rdf.data-vocabulary.org/#" id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.stlucianewsonline.com"><i class="tieicon-home"></i>Home</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.stlucianewsonline.com/category/all-news/">All News</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.stlucianewsonline.com/category/all-news/international-news/">International News</a></span> / <span class="current">Joe Biden formally wins Democratic nomination to take on Trump</span></div>
<article id="the-post" class="post-listing post-262103 post type-post status-publish format-standard has-post-thumbnail category-international-news">
<div class="post-inner" style="padding-top: 0px !important;">
<h1 class="name post-title entry-title"><span>Joe Biden formally wins Democratic nomination to take on Trump</span></h1>
By BBC 
<div class="story-date">June 6, 2020</div>
<p class="post-meta">
<span class="post-meta-author">Posted by: <a href="https://www.stlucianewsonline.com/author/merrick/" title="">Admin </a></span>
<span class="post-cats">in <a href="https://www.stlucianewsonline.com/category/all-news/international-news/" rel="category tag">International News</a></span>
<span class="tie-date">2 hours ago</span>
<span class="post-comments"><a href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/#respond">0</a></span>
<span class="post-views">91 Views</span> </p>
<div class="clear"></div>
<div class="entry">
<h4>&nbsp;Share This On:</h4>
<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="262103"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span><span class="swp_count">28</span></a></div><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_email" data-network="email"><a class="nc_tweet noPop swp_share_link" rel="nofollow noreferrer noopener" href="/cdn-cgi/l/email-protection#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" target="_blank"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_email_icon"></i><span class="swp_share">Email</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Joe+Biden+formally+wins+Democratic+nomination+to+take+on+Trump&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://twitter.com/intent/tweet?text=Joe+Biden+formally+wins+Democratic+nomination+to+take+on+Trump&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt"><span class="swp_count ">28 <span class="swp_label">Shares</span></span></div></div>
<div class="">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-3291456012722699" data-ad-slot="3462366895" data-ad-format="auto"></ins>
<script>
				(adsbygoogle = window.adsbygoogle || []).push({});
				</script>
</div>
<div id="attachment_262105" style="width: 670px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-262105" class="size-full wp-image-262105" src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?resize=620%2C349" alt="" width="620" height="349" srcset="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?w=660&amp;ssl=1 660w, https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?resize=300%2C169&amp;ssl=1 300w" sizes="(max-width: 620px) 100vw, 620px" data-recalc-dims="1" /><p id="caption-attachment-262105" class="wp-caption-text">This is Joe Biden&#8217;s third attempt to win the presidency</p></div>
<p><strong>(BBC)</strong> &#8212; Joe Biden has formally won the Democratic Party nomination to take on Donald Trump in November&#8217;s presidential election.</p>
<p>He said on Twitter that he had secured the 1,991 delegates needed and would fight to &#8220;win the battle for the soul of the nation&#8221;.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<p>He had been the effective nominee since Bernie Sanders withdrew in April.</p>
<p>Coronavirus &#8211; and its effect on the economy &#8211; and the recent civil unrest are sure to dominate the election.</p>
<p>Mr Biden, who served as Barack Obama&#8217;s vice-president, began the primary campaign in faltering style in Iowa and New Hampshire, but then built momentum with a convincing victory in South Carolina.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<p>He then dominated the so-called Super Tuesday contests, taking 10 of the 14 states.</p>
<p>Mr Biden said: &#8220;It was an honour to compete alongside one of the most talented groups of candidates the Democratic party has ever fielded and I am proud to say that we are going into this general election a united party.&#8221;</p>
<p>Mr Biden, 77, secured the nomination officially after seven states and the District of Columbia held presidential primaries on Tuesday.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<p>It is his third bid for the presidency.</p>
<p>Associated Press puts his tally at 1,995 delegates, with eight states and three US territories still to vote.</p>
<p>Mr Obama endorsed Mr Biden in April, saying in a video that Mr Biden had &#8220;all the qualities we need in a president right now&#8221;.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<p>&#8220;This is a difficult time in America&#8217;s history,&#8221; Mr Biden said. &#8220;And Donald Trump&#8217;s angry, divisive politics is no answer. The country is crying out for leadership. Leadership that can unite us. Leadership that can bring us together.&#8221;</p>
<p>Mr Trump has indicated he is eager to take the fight to Mr Biden who he derides as &#8220;Sleepy Joe&#8221;, and the Democrat has faced a number of difficulties.</p>
<p>He was forced into damage limitation mode after saying African Americans &#8220;ain&#8217;t black&#8221; if they even considered voting for President Trump, later apologising for the &#8220;cavalier&#8221; comment.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<p>Mr Biden has also faced accusations of inappropriate contact with women. He has described himself as a &#8220;tactile politician&#8221; and apologised for how people might react. Former staff assistant Tara Reade has accused him of sexually assaulting her in 1993, which he denies.</p>
<p>The US is facing major civil unrest over the death of an unarmed African American man, George Floyd, in police custody, at the same time as unemployment has reached levels unseen since the Great Depression amid the coronavirus outbreak.</p>
<p>Mr Trump and Mr Biden have already clashed on these issues, which look set to dominate the polls in November.<div class="in-article" style="text-align:center;">
<div class="in-article-wrapper" style="margin:0em auto 1em;clear:both;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4487444460"></ins>
<script>
                (adsbygoogle = window.adsbygoogle || []).push({});
                </script>
</div>
</div></p>
<div class="clearfix"><span class='ldc-ul_cont' onclick="alter_ul_post_values(this,'262103','like')"><img src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/up.png?w=620&#038;ssl=1" data-recalc-dims="1" />(<span>0</span>)</span><span class='ldc-ul_cont' onclick="alter_ul_post_values(this,'262103','dislike')"><img src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/down.png?w=620&#038;ssl=1" data-recalc-dims="1" />(<span>0</span>)</span></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="262103"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span><span class="swp_count">28</span></a></div><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_email" data-network="email"><a class="nc_tweet noPop swp_share_link" rel="nofollow noreferrer noopener" href="/cdn-cgi/l/email-protection#c8f7bbbdaaa2adabbcf582a7adedfaf88aa1acada6edfaf8aea7baa5a9a4a4b1edfaf8bfa1a6bbedfaf88cada5a7abbaa9bca1abedfaf8a6a7a5a1a6a9bca1a7a6edfaf8bca7edfaf8bca9a3adedfaf8a7a6edfaf89cbabda5b8eeaaa7acb1f5edfaf08a8a8bedfaf1edfaf8e5e5edfaf882a7adedfaf88aa1acada6edfaf8a0a9bbedfaf8aea7baa5a9a4a4b1edfaf8bfa7a6edfaf8bca0adedfaf88cada5a7abbaa9bca1abedfaf898a9babcb1edfaf8a6a7a5a1a6a9bca1a7a6edfaf8bca7edfaf8bca9a3adedfaf8a7a6edfaf88ca7a6a9a4acedfaf89cbabda5b8edfaf8a1a6edfaf886a7beada5aaadbaedfaffbbedfaf8b8baadbba1acada6bca1a9a4edfaf8ada4adabbca1a7a6e6edfaf880adedfaf8bba9a1acedfaf8a7a6edfaf89cbfa1bcbcadbaedfaf8bca0a9bcedfaf8a0adedfaf8a0a9acedfaf8bbadabbdbaadacedfaf8bca0adedfaf8f9edfa8bf1f1f9edfaf8acada4adafa9bcadbbedfaf8a6adadacadacedfaf8a9a6acedfaf8bfa7bda4acedfaf8aea1afa0bcedfaf8bca7edfaf8edfafabfa1a6edfaf8bca0adedfaf8aaa9bcbca4adedfaf8aea7baedfaf8bca0adedfaf8bba7bda4edfaf8a7aeedfaf8bca0adedfaf8a6a9bca1a7a6edfafae6edfaf880adedfaf8a0a9acedfaf8aaadada6edfaf8bca0adedfaf8adaeaeadabbca1beadedfaf8a6a7a5a1a6adadedfaf8bba1a6abadedfaf88aadbaa6a1adedfaf89ba9a6acadbabbedfaf8bfa1bca0acbaadbfedfaf8a1a6edfaf889b8baa1a4e6edfaf88ba7baa7a6a9bea1babdbbedfaf8e5edfaf8a9a6acedfaf8a1bcbbedfaf8adaeaeadabbcedfaf8a7a6edfaf8bca0adedfaf8adaba7a6a7a5b1edfaf8e5edfaf8a9a6acedfaf8bca0adedfaf8baadabada6bcedfaf8aba1bea1a4edfaf8bda6baadbbbcedfaf8a9baadedfaf8bbbdbaadedfaf8bca7edfaf8aca7a5a1a6a9bcadedfaf8bca0adedfaf8ada4adabbca1a7a6e6edfaf885baedfaf88aa1acada6edfa8bedfaf8bfa0a7edfaf8bbadbabeadacedfaf8a9bbedfaf88aa9baa9aba3edfaf887aaa9a5a9edfaffbbedfaf8bea1abade5b8baadbba1acada6bcedfa8bedfaf8aaadafa9a6edfaf8bca0adedfaf8b8baa1a5a9bab1edfaf8aba9a5b8a9a1afa6edfaf8a1a6edfaf8aea9a4bcadbaa1a6afedfaf8bbbcb1a4adedfaf8a1a6edfaf881a7bfa9edfaf8a9a6acedfaf886adbfedfaf880a9a5b8bba0a1baadedfa8bedfaf8aabdbcedfaf8bca0ada6edfaf8aabda1a4bcedf88cedf889edf88cedf8899aada9ace885a7baade880adbaadf2e8edfaf8a0bcbcb8bbedfb89edfa8eedfa8ebfbfbfe6bbbca4bdaba1a9a6adbfbba7a6a4a1a6ade6aba7a5edfa8ea2a7ade5aaa1acada6e5aea7baa5a9a4a4b1e5bfa1a6bbe5acada5a7abbaa9bca1abe5a6a7a5a1a6a9bca1a7a6e5bca7e5bca9a3ade5a7a6e5bcbabda5b8edfa8e" target="_blank"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_email_icon"></i><span class="swp_share">Email</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Joe+Biden+formally+wins+Democratic+nomination+to+take+on+Trump&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F" data-link="https://twitter.com/intent/tweet?text=Joe+Biden+formally+wins+Democratic+nomination+to+take+on+Trump&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fjoe-biden-formally-wins-democratic-nomination-to-take-on-trump%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt"><span class="swp_count ">28 <span class="swp_label">Shares</span></span></div></div><div class="swp-content-locator"></div>
<p class="commentnotice" style="font-size: 12px; color: #999;">St. Lucia News Online firmly discourages any commentary or statements that are libelous, disruptive in nature or incites others to violate our <a target="_blank" href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/">Terms of Use</a>. Any submissions made on our comment section, are solely the views of the individual and not from St. Lucia News Online.</p>
<div id="comment_form_wrapper">
<div id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.stlucianewsonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p><label for='subscribe-reloaded'><input style='width:30px' type='checkbox' name='subscribe-reloaded' id='subscribe-reloaded' value='yes' /> Notify me of followup comments via e-mail. You can also <a href='https://www.stlucianewsonline.com/?page_id=99999&amp;srp=262103&amp;srk=95f3c54b0004b43a54977283c670e3be&amp;sra=s&amp;srsrc=f'>subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='262103' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e417ab9460" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="192" /></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/" target="_blank">Learn how your comment data is processed</a>.</p>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">				
				jQuery(document).ready(function() {
				    jQuery("#subscribe-reloaded").closest("p").hide();
					jQuery('#show_comments_section').click(function() {
						jQuery('#respond').show();	
						jQuery(this).hide();		
					});			
				});			
			</script>
<style>
			#respond{
				display:none;
			}
			</style>
<div class="col-sm-12">
<button id="show_comments_section">
<strong>Leave a Comment</strong> <br> Start the discussion.</button>
</div>
<div class="single_page_after_conttent"><h2 class="rounded"><a href="https://www.stlucianewsonline.com/category/all-news/international-news/">International News</a></h2><ul>
<li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" title="Chinese nationals killed and burned in Zambia"><img width="150" height="84" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?fit=150%2C84&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?w=780&amp;ssl=1 780w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?resize=768%2C431&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" rel="bookmark" title="Permanent Link to Chinese nationals killed and burned in Zambia">Chinese nationals killed and burned in Zambia</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/minneapolis-mayor-jacob-frey-cries-in-front-of-george-floyds-casket/" title="Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket"><img width="150" height="84" src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?fit=150%2C84&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?w=1280&amp;ssl=1 1280w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/minneapolis-mayor-jacob-frey-cries-in-front-of-george-floyds-casket/" rel="bookmark" title="Permanent Link to Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket">Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/cop-comforts-5-y-o-black-girl-after-she-asks-if-shes-going-to-be-shot/" title="Cop comforts 5-y-o black girl after she asks if she’s going to be shot"><img width="150" height="100" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?fit=150%2C100&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?w=1124&amp;ssl=1 1124w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=1024%2C683&amp;ssl=1 1024w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=768%2C512&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/cop-comforts-5-y-o-black-girl-after-she-asks-if-shes-going-to-be-shot/" rel="bookmark" title="Permanent Link to Cop comforts 5-y-o black girl after she asks if she’s going to be shot">Cop comforts 5-y-o black girl after she asks if she’s going to be shot</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/update-george-floyd-tested-positive-for-coronavirus-in-april-full-autopsy-reveals/" title="UPDATE: George Floyd tested positive for coronavirus in April, full autopsy reveals"><img width="150" height="100" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?fit=150%2C100&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?w=915&amp;ssl=1 915w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?resize=768%2C512&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/update-george-floyd-tested-positive-for-coronavirus-in-april-full-autopsy-reveals/" rel="bookmark" title="Permanent Link to UPDATE: George Floyd tested positive for coronavirus in April, full autopsy reveals">UPDATE: George Floyd tested positive for coronavirus in April, full autopsy reveals</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/snapchat-stops-promoting-donald-trumps-account/" title="Snapchat stops promoting Donald Trump&#8217;s account"><img width="150" height="84" src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2018/06/dtrump.jpg?fit=150%2C84&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2018/06/dtrump.jpg?w=660&amp;ssl=1 660w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2018/06/dtrump.jpg?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2018/06/dtrump.jpg?resize=600%2C337&amp;ssl=1 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/snapchat-stops-promoting-donald-trumps-account/" rel="bookmark" title="Permanent Link to Snapchat stops promoting Donald Trump&#8217;s account">Snapchat stops promoting Donald Trump&#8217;s account</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/police-plea-for-help-as-german-suspect-revealed-in-madeleine-mccann-disappearance/" title="Police plea for help as German suspect revealed in Madeleine McCann disappearance"><img width="150" height="84" src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/mccann.jpg?fit=150%2C84&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/mccann.jpg?w=660&amp;ssl=1 660w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/mccann.jpg?resize=300%2C169&amp;ssl=1 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/police-plea-for-help-as-german-suspect-revealed-in-madeleine-mccann-disappearance/" rel="bookmark" title="Permanent Link to Police plea for help as German suspect revealed in Madeleine McCann disappearance">Police plea for help as German suspect revealed in Madeleine McCann disappearance</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/russia-president-putin-declares-state-of-emergency-after-arctic-circle-oil-spill/" title="Russia: President Putin declares state of emergency after Arctic Circle oil spill"><img width="150" height="139" src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/oil-spill-russia.jpg?fit=150%2C139&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/oil-spill-russia.jpg?w=1200&amp;ssl=1 1200w, https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/oil-spill-russia.jpg?resize=300%2C278&amp;ssl=1 300w, https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/oil-spill-russia.jpg?resize=1024%2C950&amp;ssl=1 1024w, https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/oil-spill-russia.jpg?resize=768%2C712&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/russia-president-putin-declares-state-of-emergency-after-arctic-circle-oil-spill/" rel="bookmark" title="Permanent Link to Russia: President Putin declares state of emergency after Arctic Circle oil spill">Russia: President Putin declares state of emergency after Arctic Circle oil spill</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/brazil-looks-to-reopen-despite-record-coronavirus-deaths/" title="Brazil looks to reopen despite record coronavirus deaths"><img width="150" height="84" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/01/Brazil-President-Jair-Bolsonaro.jpg?fit=150%2C84&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/01/Brazil-President-Jair-Bolsonaro.jpg?w=700&amp;ssl=1 700w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/01/Brazil-President-Jair-Bolsonaro.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/01/Brazil-President-Jair-Bolsonaro.jpg?resize=600%2C338&amp;ssl=1 600w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/brazil-looks-to-reopen-despite-record-coronavirus-deaths/" rel="bookmark" title="Permanent Link to Brazil looks to reopen despite record coronavirus deaths">Brazil looks to reopen despite record coronavirus deaths</a></li><li class="same-category-post-item "><a class="same-category-post-thumbnail same-category-post-css-cropping" href="https://www.stlucianewsonline.com/gambia-demands-probe-after-us-police-shoot-dead-diplomats-son/" title="Gambia demands probe after US police shoot dead diplomat&#8217;s son"><img width="150" height="85" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Momodou-Lamin-Sisay.jpg?fit=150%2C85&amp;ssl=1" class="attachment-150x150 size-150x150 wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Momodou-Lamin-Sisay.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Momodou-Lamin-Sisay.jpg?resize=300%2C170&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Momodou-Lamin-Sisay.jpg?resize=1024%2C580&amp;ssl=1 1024w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Momodou-Lamin-Sisay.jpg?resize=768%2C435&amp;ssl=1 768w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="post-title" href="https://www.stlucianewsonline.com/gambia-demands-probe-after-us-police-shoot-dead-diplomats-son/" rel="bookmark" title="Permanent Link to Gambia demands probe after US police shoot dead diplomat&#8217;s son">Gambia demands probe after US police shoot dead diplomat&#8217;s son</a></li></ul>
</div>
<div style="text-align: center;">
<div class="resads-adspot resads-adspot-78" adspot="78" ad="277"><a href="https://www.rubis-caribbean.com/rubis-st-lucia-pay-for-rubigas-online/" target="_blank"><img src="https://www.stlucianewsonline.com/wp-content/uploads/2020/03/large-RUBIS-St.-Lucia-Rubigas-Payment-Methods-St-Lucia-News-Online-web-banner-300-x-300-pixels_2403_2020FINAL.jpg" width="300" height="250" /></a></div> </div>
<div style="text-align: center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-3291456012722699" data-ad-slot="6595796691" data-ad-format="auto"></ins>
<script>
						(adsbygoogle = window.adsbygoogle || []).push({});
						</script>
</div>
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
          window._taboola = window._taboola || [];
          _taboola.push({
            mode: 'thumbnails-a',
            container: 'taboola-below-article-thumbnails',
            placement: 'Below Article Thumbnails',
            target_type: 'mix'
          });
        </script>

<div class="clear"></div>
<div class="ads-bottom">
</div>
</div>
<div class="disclaimer-ad">This article was posted in its entirety as received by stlucianewsonline.com.
This media house does not correct any spelling or grammatical error within press releases and commentaries.
The views expressed therein are not necessarily those of stlucianewsonline.com, its sponsors or advertisers.</div>




<span style="display:none" class="updated">2020-06-06</span>
<div style="display:none" class="author"><strong class="fn"><a href="https://www.stlucianewsonline.com/author/merrick/" title="Posts by Admin" rel="author">Admin</a></strong></div>
<div class="share-post">
<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 'fbjssdk');
		load('https://apis.google.com/js/plusone.js', 'gplus1js');
		load('//platform.twitter.com/widgets.js', 'tweetjs');
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
<ul>
<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" data-text="Joe Biden formally wins Democratic nomination to take on Trump" data-via="" data-lang="en">tweet</a></li>
<li>
<div class="fb-like" data-href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
</li>
<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/"></div>
</li>
<li><su:badge layout="2" location="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/"></su:badge>
<script type="text/javascript">
				(function() {
					var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
					li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
				})();
			</script>
</li>
<li><script src="https://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/" data-counter="right"></script></li>
<li style="width:80px;"><script type="text/javascript" src="https://assets.pinterest.com/js/pinit.js"></script><a href="https://pinterest.com/pin/create/button/?url=https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/&amp;media=https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/biden.jpg?resize=620%2C330&ssl=1" class="pin-it-button" count-layout="horizontal"><img border="0" src="https://assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></li>
</ul>
<div class="clear"></div>
</div> 
</div>
</article>
<div class="post-navigation">
<div class="post-previous"><a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" rel="prev"><span>Previous:</span> More St. Lucians return home Saturday</a></div>
<div class="post-next"><a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" rel="next"><span>Next:</span> Chinese nationals killed and burned in Zambia</a></div>
</div>
<section id="author-box">
<div class="block-head">
<h3>About Admin </h3>
</div>
<div class="post-listing">
<div class="author-avatar">
<img alt='' src='https://secure.gravatar.com/avatar/00a90281981a31a7a648fb987aaea560?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/00a90281981a31a7a648fb987aaea560?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /> </div>
<div class="author-description">
</div>
<div class="author-social">
</div>
<div class="clear"></div>
</div>
</section>
<section id="related_posts">
<div class="block-head">
<h3>Related Articles</h3><div class="stripe-line"></div>
</div>
<div class="post-listing">
<div class="related-item">
<div class="post-thumbnail">
<a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" title="Permalink to Chinese nationals killed and burned in Zambia" rel="bookmark">
<img width="300" height="160" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?resize=300%2C160&amp;ssl=1" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?resize=300%2C160&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169.png?resize=620%2C330&amp;ssl=1 620w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" title="Permalink to Chinese nationals killed and burned in Zambia" rel="bookmark">Chinese nationals killed and burned in Zambia</a></h3>
<p class="post-meta"><span class="tie-date">1 hour ago</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://www.stlucianewsonline.com/minneapolis-mayor-jacob-frey-cries-in-front-of-george-floyds-casket/" title="Permalink to Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket" rel="bookmark">
<img width="300" height="160" src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=300%2C160&amp;ssl=1" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=300%2C160&amp;ssl=1 300w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?resize=620%2C330&amp;ssl=1 620w, https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/jacob-frey.jpg?zoom=3&amp;resize=300%2C160 900w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://www.stlucianewsonline.com/minneapolis-mayor-jacob-frey-cries-in-front-of-george-floyds-casket/" title="Permalink to Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket" rel="bookmark">Minneapolis Mayor Jacob Frey cries in front of George Floyd’s casket</a></h3>
<p class="post-meta"><span class="tie-date">2 days ago</span></p>
</div>
<div class="related-item">
<div class="post-thumbnail">
<a href="https://www.stlucianewsonline.com/cop-comforts-5-y-o-black-girl-after-she-asks-if-shes-going-to-be-shot/" title="Permalink to Cop comforts 5-y-o black girl after she asks if she’s going to be shot" rel="bookmark">
<img width="300" height="160" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=300%2C160&amp;ssl=1" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=300%2C160&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?resize=620%2C330&amp;ssl=1 620w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/houston1.jpg?zoom=3&amp;resize=300%2C160 900w" sizes="(max-width: 300px) 100vw, 300px" /> </a>
</div>
<h3><a href="https://www.stlucianewsonline.com/cop-comforts-5-y-o-black-girl-after-she-asks-if-shes-going-to-be-shot/" title="Permalink to Cop comforts 5-y-o black girl after she asks if she’s going to be shot" rel="bookmark">Cop comforts 5-y-o black girl after she asks if she’s going to be shot</a></h3>
<p class="post-meta"><span class="tie-date">2 days ago</span></p>
</div>
<div class="clear"></div>
</div>
</section>
</div>
</div> 
<aside class="sidebar">
<div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="widget-top"><h4> </h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3291456012722699" data-ad-slot="7884827633" data-ad-format="auto"></ins></div></div></div>
<div id="wpp-8" class="widget popular-posts">
<div class="widget-top"><h4>Popular Stories</h4><div class="stripe-line"></div></div>
<div class="widget-container">

<ul class="wpp-list wpp-list-with-thumbnails">
<li>
<a href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262092-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" class="wpp-post-title" target="_self">Two males shot and chopped by gang in Soufriere</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262040-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" class="wpp-post-title" target="_self">St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/breaking-news-saint-lucia-records-19th-covid-19-case/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/261970-featured-75x75.png" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/breaking-news-saint-lucia-records-19th-covid-19-case/" class="wpp-post-title" target="_self">Saint Lucia records 19th COVID-19 case</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/west-indies-name-test-squad-for-proposed-tour-of-england/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/261753-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/west-indies-name-test-squad-for-proposed-tour-of-england/" class="wpp-post-title" target="_self">West Indies name Test squad for proposed tour of England</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/st-lucia-after-four-terrible-years-under-chastanet-and-the-uwp-commentary-by-stephen-marcellin-red-alert/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/261953-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/st-lucia-after-four-terrible-years-under-chastanet-and-the-uwp-commentary-by-stephen-marcellin-red-alert/" class="wpp-post-title" target="_self">St. Lucia: After four terrible years under Chastanet and the UWP (commentary by Stephen Marcellin/Red Alert)</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/choc-housing-development-underway/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262011-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/choc-housing-development-underway/" class="wpp-post-title" target="_self">Choc Housing Development underway</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/vieux-fort-couple-caught-with-firearm-and-ammunition/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/261943-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/vieux-fort-couple-caught-with-firearm-and-ammunition/" class="wpp-post-title" target="_self">Vieux Fort couple caught with firearm and ammunition</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262088-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" class="wpp-post-title" target="_self">United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262107-featured-75x75.png" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" class="wpp-post-title" target="_self">Chinese nationals killed and burned in Zambia</a>
</li>
<li>
<a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" target="_self"><img data-img-src="https://www.stlucianewsonline.com/wp-content/uploads/wordpress-popular-posts/262101-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a>
<a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" class="wpp-post-title" target="_self">More St. Lucians return home Saturday</a>
</li>
</ul>
</div></div>
<div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget-top"><h4>Latest Headlines</h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="textwidget custom-html-widget"><style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
<div class="art_foot"><h2 class="rounded">Latest Headlines</h2><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/04/st-lucians-from-cruise-ship3-45x45.jpg" alt="More St. Lucians return home Saturday"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" title="Permalink to More St. Lucians return home Saturday" rel="bookmark">More St. Lucians return home Saturday</a></h3><time class="rpwe-time published" datetime="2020-06-06T12:57:48-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/police-45x45.jpg" alt="Two males shot and chopped by gang in Soufriere"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" title="Permalink to Two males shot and chopped by gang in Soufriere" rel="bookmark">Two males shot and chopped by gang in Soufriere</a></h3><time class="rpwe-time published" datetime="2020-06-06T09:48:34-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2014/06/uwp-45x45.jpg" alt="United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" title="Permalink to United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)" rel="bookmark">United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)</a></h3><time class="rpwe-time published" datetime="2020-06-06T09:04:15-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/no-legs-no-problem-jamaican-andrew-nelson-making-light-work-of-lifes-challenges/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/andrew-nelson-jamaica-45x45.jpg" alt="No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/no-legs-no-problem-jamaican-andrew-nelson-making-light-work-of-lifes-challenges/" title="Permalink to No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges" rel="bookmark">No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:00:01-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/neuro-4-45x45.jpg" alt="St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" title="Permalink to St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital" rel="bookmark">St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital</a></h3><time class="rpwe-time published" datetime="2020-06-05T10:26:06-04:00">June 5, 2020</time></li></ul></div></div>
<style>
	#custom_html-2 .art_foot h2.rounded{
		display:none;
	}
</style></div></div></div><style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
<div id="rpwe_widget-8" class="widget rpwe_widget recent-posts-extended"><div class="widget-top"><h4>Latest News</h4><div class="stripe-line"></div></div>
<div class="widget-container"><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/200605112718-fire-zambia-murder-china-exlarge-169-45x45.png" alt="Chinese nationals killed and burned in Zambia"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/chinese-nationals-killed-and-burned-in-zambia/" title="Permalink to Chinese nationals killed and burned in Zambia" rel="bookmark">Chinese nationals killed and burned in Zambia</a></h3><time class="rpwe-time published" datetime="2020-06-06T13:23:27-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/04/st-lucians-from-cruise-ship3-45x45.jpg" alt="More St. Lucians return home Saturday"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/more-st-lucians-return-home-saturday/" title="Permalink to More St. Lucians return home Saturday" rel="bookmark">More St. Lucians return home Saturday</a></h3><time class="rpwe-time published" datetime="2020-06-06T12:57:48-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/12-noon-june-6-2020-saint-lucia-weather-update/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2017/06/weather-update-45x45.jpg" alt="12 noon June 6, 2020 Saint Lucia weather update"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/12-noon-june-6-2020-saint-lucia-weather-update/" title="Permalink to 12 noon June 6, 2020 Saint Lucia weather update" rel="bookmark">12 noon June 6, 2020 Saint Lucia weather update</a></h3><time class="rpwe-time published" datetime="2020-06-06T12:49:05-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/police-45x45.jpg" alt="Two males shot and chopped by gang in Soufriere"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/two-males-shot-and-chopped-by-gang-in-soufriere/" title="Permalink to Two males shot and chopped by gang in Soufriere" rel="bookmark">Two males shot and chopped by gang in Soufriere</a></h3><time class="rpwe-time published" datetime="2020-06-06T09:48:34-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2014/06/uwp-45x45.jpg" alt="United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/united-workers-party-marks-fourth-year-in-office-as-they-talk-we-work-video/" title="Permalink to United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)" rel="bookmark">United Workers Party marks fourth year in office: &#8220;As they talk, we work&#8221; (+video)</a></h3><time class="rpwe-time published" datetime="2020-06-06T09:04:15-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/opposition-wins-suriname-elections/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Chandrikapersad-Chan-Santokhi-suriname-45x45.jpg" alt="Opposition wins Suriname elections"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/opposition-wins-suriname-elections/" title="Permalink to Opposition wins Suriname elections" rel="bookmark">Opposition wins Suriname elections</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:41:19-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/st-kitts-nevis-elections-dr-harris-hails-historic-victory-as-vote-count-continues/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/03/dr-timothy-harris-45x45.jpg" alt="St. Kitts-Nevis elections: Dr. Harris hails historic victory as vote count continues"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/st-kitts-nevis-elections-dr-harris-hails-historic-victory-as-vote-count-continues/" title="Permalink to St. Kitts-Nevis elections: Dr. Harris hails historic victory as vote count continues" rel="bookmark">St. Kitts-Nevis elections: Dr. Harris hails historic victory as vote count continues</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:30:44-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/trinidad-mom-56-son-29-shot-to-death-in-home-invasion/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Keron-Theroulde-killed-trinidad-45x45.jpg" alt="Trinidad: Mom, 56, son, 29, shot to death in home invasion"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/trinidad-mom-56-son-29-shot-to-death-in-home-invasion/" title="Permalink to Trinidad: Mom, 56, son, 29, shot to death in home invasion" rel="bookmark">Trinidad: Mom, 56, son, 29, shot to death in home invasion</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:17:32-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/trinidad-man-in-suriname-begs-to-come-home/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/trinidad-man-wants-to-come-home-45x45.jpg" alt="Trinidad man in Suriname begs to come home"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/trinidad-man-in-suriname-begs-to-come-home/" title="Permalink to Trinidad man in Suriname begs to come home" rel="bookmark">Trinidad man in Suriname begs to come home</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:12:20-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/no-legs-no-problem-jamaican-andrew-nelson-making-light-work-of-lifes-challenges/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/andrew-nelson-jamaica-45x45.jpg" alt="No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/no-legs-no-problem-jamaican-andrew-nelson-making-light-work-of-lifes-challenges/" title="Permalink to No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges" rel="bookmark">No legs? No problem! – Jamaican Andrew Nelson making light work of life’s challenges</a></h3><time class="rpwe-time published" datetime="2020-06-06T08:00:01-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/jamaica-cockburn-gardens-residents-protest-police-killing/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/protest-police-killing-45x45.jpg" alt="Jamaica: Cockburn Gardens residents protest police killing"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/jamaica-cockburn-gardens-residents-protest-police-killing/" title="Permalink to Jamaica: Cockburn Gardens residents protest police killing" rel="bookmark">Jamaica: Cockburn Gardens residents protest police killing</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:54:54-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/jamaica-montego-bay-airport-prepares-to-welcome-visitors/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Sangster-International-45x45.jpg" alt="Jamaica: Montego Bay airport prepares to welcome visitors"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/jamaica-montego-bay-airport-prepares-to-welcome-visitors/" title="Permalink to Jamaica: Montego Bay airport prepares to welcome visitors" rel="bookmark">Jamaica: Montego Bay airport prepares to welcome visitors</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:49:24-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/cocaine-from-trinidad-found-in-soya-nuggets-in-the-us/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/cocaine-in-soya-nuggets-45x45.jpg" alt="Cocaine from Trinidad found in soya nuggets in the US"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/cocaine-from-trinidad-found-in-soya-nuggets-in-the-us/" title="Permalink to Cocaine from Trinidad found in soya nuggets in the US" rel="bookmark">Cocaine from Trinidad found in soya nuggets in the US</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:43:23-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/jamaica-man-who-raped-eight-women-had-his-sentenced-cut-in-half/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2019/11/law-gavel-45x45.jpg" alt="Jamaica: Man who raped eight women had his sentence cut in half"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/jamaica-man-who-raped-eight-women-had-his-sentenced-cut-in-half/" title="Permalink to Jamaica: Man who raped eight women had his sentence cut in half" rel="bookmark">Jamaica: Man who raped eight women had his sentence cut in half</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:28:05-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/president-bolsonaro-threatens-to-leave-who-as-covid-19-kills-a-brazilian-per-minute/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/03/BRAZILIAN-PRESIDENT-45x45.jpg" alt="President Bolsonaro threatens to leave WHO as COVID-19 kills ‘a Brazilian per minute’"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/president-bolsonaro-threatens-to-leave-who-as-covid-19-kills-a-brazilian-per-minute/" title="Permalink to President Bolsonaro threatens to leave WHO as COVID-19 kills ‘a Brazilian per minute’" rel="bookmark">President Bolsonaro threatens to leave WHO as COVID-19 kills ‘a Brazilian per minute’</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:22:44-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/young-mother-shot-dead-in-trinidad-and-tobago/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Reanna-Gordon-trinidad-45x45.jpg" alt="Young mother shot dead in Trinidad and Tobago"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/young-mother-shot-dead-in-trinidad-and-tobago/" title="Permalink to Young mother shot dead in Trinidad and Tobago" rel="bookmark">Young mother shot dead in Trinidad and Tobago</a></h3><time class="rpwe-time published" datetime="2020-06-06T07:17:11-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/6-a-m-june-6-2020-saint-lucia-weather-update/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2017/06/weather-update-45x45.jpg" alt="6 a.m. June 6, 2020 Saint Lucia weather update"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/6-a-m-june-6-2020-saint-lucia-weather-update/" title="Permalink to 6 a.m. June 6, 2020 Saint Lucia weather update" rel="bookmark">6 a.m. June 6, 2020 Saint Lucia weather update</a></h3><time class="rpwe-time published" datetime="2020-06-06T06:31:45-04:00">June 6, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/6-a-m-june-5-2020-saint-lucia-weather-update/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2017/06/weather-update-45x45.jpg" alt="6 a.m. June 5, 2020 Saint Lucia weather update"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/6-a-m-june-5-2020-saint-lucia-weather-update/" title="Permalink to 6 a.m. June 5, 2020 Saint Lucia weather update" rel="bookmark">6 a.m. June 5, 2020 Saint Lucia weather update</a></h3><time class="rpwe-time published" datetime="2020-06-05T10:51:01-04:00">June 5, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/neuro-4-45x45.jpg" alt="St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/st-lucian-neurosurgeon-performs-complex-brain-surgery-at-okeu-hospital/" title="Permalink to St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital" rel="bookmark">St. Lucian neurosurgeon performs complex brain surgery at OKEU Hospital</a></h3><time class="rpwe-time published" datetime="2020-06-05T10:26:06-04:00">June 5, 2020</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.stlucianewsonline.com/integrity-commission-extends-declaration-filing-deadline-to-june-30/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/deadline-extended-45x45.jpg" alt="Integrity Commission extends declaration filing deadline to June 30"></a><h3 class="rpwe-title"><a href="https://www.stlucianewsonline.com/integrity-commission-extends-declaration-filing-deadline-to-june-30/" title="Permalink to Integrity Commission extends declaration filing deadline to June 30" rel="bookmark">Integrity Commission extends declaration filing deadline to June 30</a></h3><time class="rpwe-time published" datetime="2020-06-05T05:18:52-04:00">June 5, 2020</time></li></ul></div></div></div></aside>
<div class="clear"></div>

<div class="clear"></div>
</div>
</div>

<footer class="fade-in animated4">
<div id="footer-widget-area" class="footer-3c container">
<div id="footer-first" class="footer-widgets-box">
<div id="text-33" class="footer-widget widget_text"><div class="footer-widget-top"><h4>LEGAL INFO</h4></div>
<div class="footer-widget-container"> <div class="textwidget"><p>Copyright © 2012 &#8211; 2020<br />
StLuciaNewsOnline.com,<br />
Andrews Media Services Corporation.<br />
Gros Islet, Saint Lucia, West Indies</p>
<p>All rights reserved.</p>
</div>
</div></div> </div>
<div id="footer-second" class="footer-widgets-box">
<div id="nav_menu-3" class="footer-widget widget_nav_menu"><div class="footer-widget-top"><h4>Policies</h4></div>
<div class="footer-widget-container"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-191253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-191253"><a href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy</a></li>
<li id="menu-item-191251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191251"><a href="https://www.stlucianewsonline.com/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a></li>
<li id="menu-item-191252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191252"><a href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/">Comment Policy</a></li>
<li id="menu-item-191254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191254"><a href="https://www.stlucianewsonline.com/contact/">Contact</a></li>
</ul></div></div></div> </div>
<div id="footer-third" class="footer-widgets-box">
<div id="text-34" class="footer-widget widget_text"><div class="footer-widget-top"><h4>Contact Information</h4></div>
<div class="footer-widget-container"> <div class="textwidget"><p>Whatsapp messages and Whatsapp calls only: +592 645-8601</p>
<p>E-mail: <a href="/cdn-cgi/l/email-protection#fc9d92988e998b8f919998959d9f938e8cbc9b919d9590d29f9391"><span class="__cf_email__" data-cfemail="2d4c43495f485a5e404849444c4e425f5d6d4a404c4441034e4240">[email&#160;protected]</span></a></p>
<p>Gros Islet, Saint Lucia, West Indies</p>
<p>&nbsp;</p>
</div>
</div></div> </div>
</div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
<div class="footer-bottom fade-in animated4">
<div class="container">
<div class="social-icons icon_flat">
<a class="ttip" title="Rss" href="https://www.stlucianewsonline.com/feed/" target="_blank"><i class="tieicon-rss"></i></a> </div>
<div class="alignleft">
© Copyright 2020, All Rights Reserved. | Powered by <a href="https://www.wordpress.com">WordPress</a> | Designed by <a href="http://www.tielabs.com">Tielabs</a> </div>
</div>
</div>
</div>
<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
<div id="fb-root"></div>
<section id="check-also-box" class="post-listing fade-in animated3 check-also-right">
<a href="#" id="check-also-close">x</a>
<div class="block-head">
<h3>Check Also</h3>
</div>
<div class="check-also-post">
<div class="post-thumbnail">
<a href="https://www.stlucianewsonline.com/update-george-floyd-tested-positive-for-coronavirus-in-april-full-autopsy-reveals/">
<img width="915" height="610" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" srcset="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?w=915&amp;ssl=1 915w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/george-floyd-1.jpg?resize=768%2C512&amp;ssl=1 768w" sizes="(max-width: 915px) 100vw, 915px" /> <span class="fa overlay-icon"></span>
</a>
</div>
<h2 class="post-title"><a href="https://www.stlucianewsonline.com/update-george-floyd-tested-positive-for-coronavirus-in-april-full-autopsy-reveals/" rel="bookmark">UPDATE: George Floyd tested positive for coronavirus in April, full autopsy reveals</a></h2>
<p>(NEW YORK POST) &#8212; George Floyd had tested positive for the coronavirus ...</p>
</div>
</section>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<script type="text/javascript">
	var isProcessing = false; 
    function alter_ul_post_values(obj,post_id,ul_type){
	
		if (isProcessing)    
		return;  
		isProcessing = true;   
		
		jQuery(obj).find("span").html("..");
    	jQuery.ajax({
   		type: "POST",
   		url: "https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/ajax_counter.php",
   		data: "post_id="+post_id+"&up_type="+ul_type,
   		success: function(msg){
     		jQuery(obj).find("span").html(msg);
			isProcessing = false; 
   			}
 		});
	}
	</script>
 <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
<script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajaxurl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/resads/js/frontend.min.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/js/jquery.touchSwipe.min.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/js/imagesloaded.pkgd.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/inc/static/js/ditty-news-ticker.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var socialWarfare = {"addons":["pro"],"post_id":"262103","variables":{"emphasizeIcons":"0","powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/js/script.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/themes/jarida/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type="text/javascript"> var swp_nonce = "bcc92f7ee5";
function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://www.stlucianewsonline.com/joe-biden-formally-wins-democratic-nomination-to-take-on-trump/";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};var swpFloatBeforeContent = false; var swp_ajax_url = "https://www.stlucianewsonline.com/wp-admin/admin-ajax.php"; var swp_post_id = "262103";var swpClickTracking = false; swpPinIt={"enabled":false};</script><script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'42891802',post:'262103',tz:'-4',srv:'www.stlucianewsonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '42891802', '262103' ]);
</script>

<script type="text/javascript">
[].forEach.call(document.querySelectorAll('.adsbygoogle'), function(){
    (adsbygoogle = window.adsbygoogle || []).push({});
});
</script>
<style type="text/css">
	.single-post .entry .single_page_after_conttent h2 {
    display: block !important;
}

.single-post .entry .single_page_after_conttent ul li {
    list-style: none;
    width: 33%;
    float: left;
    height: 220px;
    margin: 0px;
}


.single-post .entry .single_page_after_conttent ul li a.post-title {
    font-size: 12px;
    color: #444;
    float: left;
    width: 83%;
}

				
.single-post .entry .single_page_after_conttent ul li p.post-date {
    width: 100%;
    line-height: 18px;
    font-style: italic;
    margin-bottom: 5px;
    color: #bbb;
    font-size: 11px;
    float: left;
}

</style>