<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.stlucianewsonline.com/xmlrpc.php" />

<meta property="og:description" content="By Isanella Patoir (NEWS ROOM GUYANA) -- Police in ‘A’ Division arrested 38-year-old Devon Anderson Thursday night, hours after he allegedly beat his mother to death and injured his four-year-old niece. Jennifer ‘Judith’ Anderson, 62, was found with numerous marks of violence inside the wardrobe of her Goed Intent, West Bank Demerara house around midday Thursday by a relative. The News Room understands that Devon, a drug addict, was arrested after ranks received a tip at about 18:00h. He was found with 12 bags of marijuana and two pieces of cocaine at John’s Hotel located on John Street, Georgetown. Reports">
<meta property="og:title" content="Guyana: Man arrested after killing mother, injuring niece">
<meta property="article_author" content="https://www.facebook.com/stlucianewsonline/">
<meta property="article_publisher" content="https://www.facebook.com/stlucianewsonline/">
<meta property="og:image" content="https://www.stlucianewsonline.com/wp-content/uploads/2020/11/jennifer-anderson.jpeg">
<meta property="fb:app_id" content="529576650555031">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/">
<meta property="og:site_name" content="St. Lucia News Online">
<meta property="article:published_time" content="2020-11-28T14:51:23-04:00">
<meta property="article:modified_time" content="2020-11-28T14:51:23-04:00">
<meta property="og:updated_time" content="2020-11-28T14:51:23-04:00">
<meta name="twitter:title" content="Guyana: Man arrested after killing mother, injuring niece">
<meta name="twitter:description" content="By Isanella Patoir (NEWS ROOM GUYANA) -- Police in ‘A’ Division arrested 38-year-old Devon Anderson Thursday night, hours after he allegedly beat his mother to death and injured his four-year-old niece. Jennifer ‘Judith’ Anderson, 62, was found with numerous marks of violence inside the wardrobe of her Goed Intent, West Bank Demerara house around midday Thursday by a relative. The News Room understands that Devon, a drug addict, was arrested after ranks received a tip at about 18:00h. He was found with 12 bags of marijuana and two pieces of cocaine at John’s Hotel located on John Street, Georgetown. Reports">
<meta name="twitter:image" content="https://www.stlucianewsonline.com/wp-content/uploads/2020/11/jennifer-anderson.jpeg">
<meta name="twitter:creator" content="@slunewsonline">
<meta name="twitter:card" content="summary_large_image">
<style>@font-face{font-family:"sw-icon-font";src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.1.0");src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.1.0#iefix") format("embedded-opentype"),url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.1.0") format("woff"),url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.1.0") format("truetype"),url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.1.0#1445203416") format("svg");font-weight:400;font-style:normal;font-display:block}</style>


<title>Guyana: Man arrested after killing mother, injuring niece</title>
<meta name="description" content="Police in ‘A’ Division arrested 38-year-old Devon Anderson Thursday night, hours after he allegedly beat his mother to death and injured his four-year-old niece." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Guyana: Man arrested after killing mother, injuring niece - St. Lucia News Online" />
<meta property="og:description" content="Police in ‘A’ Division arrested 38-year-old Devon Anderson Thursday night, hours after he allegedly beat his mother to death and injured his four-year-old niece." />
<meta property="og:url" content="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/" />
<meta property="og:site_name" content="St. Lucia News Online" />
<meta property="article:publisher" content="https://www.facebook.com/stlucianewsonline/" />
<meta property="article:author" content="https://www.facebook.com/stlucianewsonline/" />
<meta property="article:published_time" content="2020-11-28T18:51:23+00:00" />
<meta property="og:image" content="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/jennifer-anderson.jpeg?fit=1200%2C688&#038;ssl=1" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="688" />
<meta property="fb:app_id" content="529576650555031" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@https://twitter.com/slunewsonline" />
<meta name="twitter:site" content="@slunewsonline" />

<link rel="amphtml" href="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/amp/" /><meta name="generator" content="AMP for WP 1.0.68.1" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Feed" href="https://www.stlucianewsonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Comments Feed" href="https://www.stlucianewsonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="St. Lucia News Online &raquo; Guyana: Man arrested after killing mother, injuring niece Comments Feed" href="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.stlucianewsonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:0 0 !important;padding:0 !important}</style>

<link data-optimized="1" rel='stylesheet' id='wp-block-library-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/a412f.css?16f61' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style>
<link data-optimized="1" rel='stylesheet' id='ads-for-wp-front-css-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/d57a7.css?f9212' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='same-category-posts-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/69deb.css?0d924' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='stcr-font-awesome-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/3cf5e.css?29b78' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='wp-polls-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/afb76.css?80de9' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url('https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');border:1px solid #c8c8c8}</style>
<link data-optimized="1" rel='stylesheet' id='mc4wp-form-themes-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/3120a.css?713af' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='wp-pagenavi-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/75d5c.css?8b587' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='social_warfare-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/3edc3.css?f89e1' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/eaac6.css?05521' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='td-plugin-newsletter-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/26f3b.css?5fc67' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/67758.css?88bcf' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='google-fonts-style-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/4716c.css?c1aed' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='td-theme-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/9c8be.css?ada9b' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
<link data-optimized="1" rel='stylesheet' id='td-theme-child-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/0a7f7.css?6de6e' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/76ac0.css?cd414' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/02083.css?ace45' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='tdb_front_style-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/82dd0.css?de813' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='jetpack_css-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/83077.css?46b5f' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='like-dislike-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/540bd.css?0ad76' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/jquery/jquery.js' id='jquery-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":267156,"token":"9743ada7fc","lang":0,"debug":1}
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<link rel="https://api.w.org/" href="https://www.stlucianewsonline.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.stlucianewsonline.com/wp-json/wp/v2/posts/267156" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.stlucianewsonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.stlucianewsonline.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5" />
<link rel='shortlink' href='https://www.stlucianewsonline.com/?p=267156' />
<link rel="alternate" type="application/json+oembed" href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&#038;format=xml" />
<script type="text/javascript">              
              jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://www.stlucianewsonline.com/front.js");
                  }
              });
         </script>
<style type="text/css">.pcs-content,.pcs-excerpt{text-align:justify}.gws .pcs-sub,.igws .pcs-sub,.iws .pcs-sub,.ws .pcs-sub{border-bottom:1px solid #777}.pcs-body,.pcs-main,.pcs-pagination,.pcs-sub{overflow:hidden}.pcs-body,.pcs-img,.pcs-meta,.pcs-pagination ul li,.pcsmeta{float:left}.pcs-reset{line-height:1.7em;margin-bottom:3px}.pcs-main{padding:10px!important}.pcs-sub:first-child{margin-top:0}.pcs-sub{margin-top:15px;padding-right:10px;clear:both;display:block}.pcs-body,.pcs-img{display:block;vertical-align:top;box-sizing:border-box}.pcs-body{width:60%}.pcs-img{width:30%;margin:0 10px 10px 0!important}.pcs-title{font-size:15px;display:block;padding:0;margin:0 0 5px}.pcs-excerpt{font-size:13px;display:block}.pcs-content,.pcs-meta{display:block;font-size:12px}.pcs-rm,.pcsmeta{display:inline-block}.pcs-meta a{font-size:12px!important}.pcs-rm{font-size:15px;clear:both;text-align:left}.pcs-img img{max-width:100%;max-height:100%;margin:0 auto}.pcsmeta{padding-right:10px}.pcs-cust-field,.pcs-pagination{display:block;clear:both}.pcs-meta .glyphicon{margin-right:3px}.gws .pcs-title a,.ws .pcs-title a{color:#222}.gws .pcs-excerpt,.ws .pcs-excerpt{color:#333}.gws .pcs-content,.ws .pcs-content{color:#444}.gws .pcs-meta,.gws .pcs-meta a,.ws .pcs-meta,.ws .pcs-meta a{color:#555}.gws .pcs-rm,.ws .pcs-rm{color:#666}.gws a:hover,.ws a:hover{color:#000!important}.igws.pcs-main,.iws.pcs-main{background-color:#333}.igws .pcs-title a,.iws .pcs-title a{color:#eee}.igws .pcs-content,.igws .pcs-excerpt,.iws .pcs-content,.iws .pcs-excerpt{color:#ddd}.igws .pcs-meta,.igws .pcs-meta a,.iws .pcs-meta,.iws .pcs-meta a{color:#ccc}.igws .pcs-rm,.iws .pcs-rm{color:#eee!important}.igws a:hover,.iws a:hover{color:#fff!important}.gcore .pcs-body,.gcore .pcs-img,.gws .pcs-body,.gws .pcs-img,.igws .pcs-body,.igws .pcs-img{width:100%}.pcs-pagination ul{display:inline-block;padding:0;margin:10px 1px;border-radius:50%;list-style-type:none}.pcs-pagination ul li a,.pcs-pagination ul li span{float:left;padding:10px 15px;line-height:1.5;color:#0275d8;text-decoration:none;background-color:#fff;border:1px solid #ddd;display:block;margin-left:-1px}.pcs-pagination ul li a:hover,.pcs-pagination ul li span.current{background-color:#0275d8;color:#fff}</style>
<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
<style>.no-js img.lazyload{display:none}figure.wp-block-image img.lazyloading{min-width:150px}.lazyload,.lazyloading{opacity:0}.lazyloaded{opacity:1;transition:opacity .4s;transition-delay:0ms}</style>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"9743ada7fc","wpRestUrl":"https:\/\/www.stlucianewsonline.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/","wpRestNonce":"9743ada7fc","wpRestUrl":"https:\/\/www.stlucianewsonline.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>

<script>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</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-34917107-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-34917107-1');
</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.stlucianewsonline.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.stlucianewsonline.com/category/all-news/caribbean/",
                    "name": "Caribbean"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/",
                    "name": "Guyana News"                                
                }
            }
            ,{
                "@type": "ListItem",
                "position": 4,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/",
                    "name": "Guyana: Man arrested after killing mother, injuring niece"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/07/cropped-Logo_St.-Lucia_icon-1.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/07/cropped-Logo_St.-Lucia_icon-1.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/07/cropped-Logo_St.-Lucia_icon-1.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/07/cropped-Logo_St.-Lucia_icon-1.jpg?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">.td-post-header .td-post-featured-image{//display:none}.td-main-page-wrap .ldc-ul_cont{display:none}.td-main-page-wrap{padding-top:0}.td-main-page-wrap .tdc-column p{//margin-bottom:-40px;padding-top:5px}#covid_message{background-color:#ee2;padding-top:10px;padding-bottom:10px;text-align:center;font-weight:600;font-family:'Roboto',sans-serif;font-size:20px;color:#020202;margin-bottom:5px}#covid_message a:hover{text-decoration:underline}#banner_ad{width:100%;max-width:1068px;margin-left:auto !important;margin-right:auto !important}#banner_ad img{width:100%}#td-outer-wrap .tdc-header-wrap .td-header-wrap #added_header_elements #banner_ad img{height:100% !important}.td_module_17 .td-read-more a{display:none}.td_module_17 .td-module-image .td-left-meta{display:none}.td_module_17 .td-module-image .td-module-meta-holder{display:none}.td-opacity-read .td_module_17 .meta-info-container{margin-bottom:-20px}body.home .td-post-author-name{display:none}.td-main-page-wrap .td_block_7 .td-block-span12{border-bottom-width:1px;border-bottom-style:solid;border-bottom-color:#c4c4c4;margin-bottom:8px;padding-bottom:15px !important}.td-main-page-wrap .tdc-column .td_block_7{border-bottom-width:0 !important}#footer_column1{width:45% !important;padding-right:50px !important}#footer_column2{width:30% !important;padding-left:50px !important;border-left:1px solid #54595f !important}#footer_column3{width:24% !important}.td-a-rec-id-header_mob{margin-top:5px !important;margin-bottom:5px !important}@media (max-width:450px){.td_block_related_posts_mob{//display:none}#ad_row_970x250{display:none}}#elementor-popup-modal-263106 .mc4wp-form-fields p label{font-size:16px;font-family:'Open Sans',sans-serif;font-weight:600;text-align:center}#elementor-popup-modal-263106 #mc4wp-form-2 .mc4wp-form-fields p,#elementor-popup-modal-263106 .mc4wp-form-fields p{text-align:center}#elementor-popup-modal-263106 .mc4wp-form-fields p input[type=email]{margin-top:10px}#elementor-popup-modal-263106 #subscribe_btn{width:200px;background-color:#facf16 !important;border-color:#000;border-width:2px;color:#020202 !important;font-weight:500;text-decoration:none !important;text-transform:uppercase;font-size:16px}.td-main-page-wrap .tdc-column .mc4wp-form-fields p{margin-bottom:0}.post_ticker{//border:1px red solid}.post_ticker #td-outer-wrap .td-crumb-container .code-block{border-width:1px;border-color:#fff}#td-outer-wrap .post_ticker{border-style:solid;border-color:#ff0f0f;border-width:1px}@media (min-width:768px){#td-outer-wrap .post_ticker{margin-bottom:0;padding-right:5px;padding-left:5px;padding-top:5px;padding-bottom:5px}#td-outer-wrap .td-crumb-container{padding-top:0}}.post_ticker .td-trending-now-title{background-color:#d33}</style>

<style></style>
<style>.ai-viewports{--ai:1}.ai-viewport-3{display:none !important}.ai-viewport-2{display:none !important}.ai-viewport-1{display:inherit !important}.ai-viewport-0{display:none !important}@media (min-width:768px) and (max-width:979px){.ai-viewport-1{display:none !important}.ai-viewport-2{display:inherit !important}}@media (max-width:767px){.ai-viewport-1{display:none !important}.ai-viewport-3{display:inherit !important}}</style>
<style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-267156 single-format-standard td-standard-pack guyana-man-arrested-after-killing-mother-injuring-niece global-block-template-1 elementor-default td-animation-stack-type0 td-full-layout">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-125444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-125444"><a href="https://stlucianewsonline.com/">Home</a></li>
<li id="menu-item-184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-184"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a></li>
<li id="menu-item-164036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164036"><a href="https://www.stlucianewsonline.com/category/headlines/">Headlines</a></li>
<li id="menu-item-262390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-262390"><a href="#">Categories<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-262401" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-262401"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a></li>
<li id="menu-item-262402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262402"><a href="https://www.stlucianewsonline.com/category/headlines/">Headlines</a></li>
<li id="menu-item-262403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262403"><a href="https://www.stlucianewsonline.com/category/breaking-news/">BREAKING NEWS</a></li>
<li id="menu-item-92491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92491"><a href="https://www.stlucianewsonline.com/category/all-news/accidenttragedy/">Accident/Tragedy</a></li>
<li id="menu-item-262404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262404"><a href="https://www.stlucianewsonline.com/category/all-news/agriculture/">Agriculture</a></li>
<li id="menu-item-164608" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-164608"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/">Caribbean<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-202324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202324"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/antigua-and-barbuda-news/">Antigua and Barbuda News</a></li>
<li id="menu-item-202325" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202325"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/barbados-news/">Barbados News</a></li>
<li id="menu-item-202326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202326"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/dominica-news/">Dominica News</a></li>
<li id="menu-item-202327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202327"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/grenada-news/">Grenada News</a></li>
<li id="menu-item-202328" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-202328"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/">Guyana News</a></li>
<li id="menu-item-202329" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202329"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/jamaica-news/">Jamaica News</a></li>
<li id="menu-item-202330" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202330"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/martinique-news/">Martinique News</a></li>
<li id="menu-item-202331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202331"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/st-vincent-and-the-grenadines-news/">St. Vincent and the Grenadines News</a></li>
<li id="menu-item-204221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204221"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/trinidad-and-tobago-news/">Trinidad and Tobago News</a></li>
</ul>
</li>
<li id="menu-item-262405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262405"><a href="https://www.stlucianewsonline.com/category/covid-19-stories/">COVID-19/Coronavirus News</a></li>
<li id="menu-item-262406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262406"><a href="https://www.stlucianewsonline.com/category/all-news/court/">Court</a></li>
<li id="menu-item-92485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92485"><a href="https://www.stlucianewsonline.com/category/all-news/crimepolice/">Crime/Police</a></li>
<li id="menu-item-262407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262407"><a href="https://www.stlucianewsonline.com/category/all-news/culturehistory/">Culture/History</a></li>
<li id="menu-item-262408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262408"><a href="https://www.stlucianewsonline.com/category/all-news/development/">Development</a></li>
<li id="menu-item-92489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92489"><a href="https://www.stlucianewsonline.com/category/all-news/entertainment/">Entertainment</a></li>
<li id="menu-item-262409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262409"><a href="https://www.stlucianewsonline.com/category/all-news/environment/">Environment</a></li>
<li id="menu-item-92487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92487"><a href="https://www.stlucianewsonline.com/category/all-news/financebusiness/">Finance/Business</a></li>
<li id="menu-item-92494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92494"><a href="https://www.stlucianewsonline.com/category/all-news/general/">General</a></li>
<li id="menu-item-92493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92493"><a href="https://www.stlucianewsonline.com/category/all-news/gis-news/">GIS News</a></li>
<li id="menu-item-92495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92495"><a href="https://www.stlucianewsonline.com/category/all-news/health/">Health</a></li>
<li id="menu-item-92496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92496"><a href="https://www.stlucianewsonline.com/category/all-news/international-news/">International News</a></li>
<li id="menu-item-38108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38108"><a href="https://www.stlucianewsonline.com/category/all-news/obituary/">Obituaries</a></li>
<li id="menu-item-92490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92490"><a href="https://www.stlucianewsonline.com/category/all-news/politics/">Politics</a></li>
<li id="menu-item-262410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262410"><a href="https://www.stlucianewsonline.com/category/religion/">Religion</a></li>
<li id="menu-item-92486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92486"><a href="https://www.stlucianewsonline.com/category/all-news/sports/">Sports</a></li>
<li id="menu-item-92498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92498"><a href="https://www.stlucianewsonline.com/category/all-news/tourism/">Tourism</a></li>
<li id="menu-item-262411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262411"><a href="https://www.stlucianewsonline.com/category/technology/">Technology</a></li>
<li id="menu-item-92492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92492"><a href="https://www.stlucianewsonline.com/category/all-news/youtheducation/">Youth/Education</a></li>
<li id="menu-item-92499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-92499"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/">Weather/Natural Disaster<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-262412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262412"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/weather-updates/">Weather updates</a></li>
</ul>
</li>
<li id="menu-item-262413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-262413"><a href="https://www.stlucianewsonline.com/category/columns/">Columns<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-262414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262414"><a href="https://www.stlucianewsonline.com/category/columns/dear-willie/">Dear Willie</a></li>
<li id="menu-item-262415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262415"><a href="https://www.stlucianewsonline.com/category/columns/health-talk/">Health Talk</a></li>
<li id="menu-item-262416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262416"><a href="https://www.stlucianewsonline.com/category/basic-cents/">Basic Cents</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-185"><a href="https://www.stlucianewsonline.com/category/columns/">Features<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-262418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262418"><a href="https://www.stlucianewsonline.com/category/did-you-know/">Did You Know</a></li>
<li id="menu-item-164610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164610"><a href="https://www.stlucianewsonline.com/category/photo-of-the-day/">Photo of the Day</a></li>
<li id="menu-item-164609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164609"><a href="https://www.stlucianewsonline.com/category/beauty-of-the-day/">Beauty of the Day</a></li>
<li id="menu-item-262419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-262419"><a href="https://www.stlucianewsonline.com/category/fan-of-the-week/">Fan of the Week</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-262420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-262420"><a href="https://www.stlucianewsonline.com/category/interactive/">Interactive<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-191"><a href="https://www.stlucianewsonline.com/category/interactive/commentary/">Commentary</a></li>
<li id="menu-item-193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-193"><a href="https://www.stlucianewsonline.com/category/interactive/letters/">Letters</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-262396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-262396"><a href="https://www.stlucianewsonline.com/about/">About Us<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-262391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-262391"><a href="https://www.stlucianewsonline.com/contact/">Contact</a></li>
<li id="menu-item-262398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262398"><a href="/contact/">Advertise</a></li>
<li id="menu-item-262392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-262392"><a href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy</a></li>
<li id="menu-item-262393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-262393"><a href="https://www.stlucianewsonline.com/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a></li>
<li id="menu-item-262399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-262399"><a href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/">Comment Policy</a></li>
</ul>
</li>
<li id="menu-item-262400" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-262400"><a href="https://www.stlucianewsonline.com/covid-19-updates/">COVID-19 LIVE UPDATES</a></li>
<li id="menu-item-264450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-264450"><a href="/weather/">Live Weather/Updates<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-264455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264455"><a href="/weather/">Live Weather/Updates</a></li>
<li id="menu-item-264452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-264452"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a></li>
<li id="menu-item-264451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-264451"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/weather-updates/">Weather updates</a></li>
</ul>
</li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy &#8211; St. Lucia News Online</a></div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.stlucianewsonline.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-3 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-262250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-262250"><a href="https://www.stlucianewsonline.com/contact/">Contact Us</a></li>
<li id="menu-item-262253" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-262253"><a href="/contact/">Advertise</a></li>
<li id="menu-item-262251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-262251"><a href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy</a></li>
<li id="menu-item-262252" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262252"><a href="https://www.stlucianewsonline.com/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a></li>
<li id="menu-item-262389" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262389"><a href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/">Comment Policy</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
</div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy &#8211; St. Lucia News Online</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-container-wrap ">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.stlucianewsonline.com/">
<img data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" alt="" data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" class="td-retina-data lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png"  alt="" data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" class="td-retina-data lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="td-retina-data" data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" alt=""/></noscript></noscript>
<span class="td-visual-hidden">St. Lucia News Online</span>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_607 td_block_template_1 ">
<style>.tdi_1_607.td-a-rec{text-align:center}.tdi_1_607 .td-element-style{z-index:-1}.tdi_1_607.td-a-rec-img{text-align:left}.tdi_1_607.td-a-rec-img img{margin:0 auto 0 0}@media (max-width:767px){.tdi_1_607.td-a-rec-img{text-align:center}}</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="5611177577"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="5611177577"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="5611177577"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-3291456012722699" data-ad-slot="5611177577"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="https://www.stlucianewsonline.com/">
<img alt="" data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/MOBILE-LOGO2-300x68.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/MOBILE-LOGO2-300x68.png" alt=""/></noscript>
</a>
<a class="td-header-logo td-sticky-disable" href="https://www.stlucianewsonline.com/">
<img data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" alt="" data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" class="td-retina-data lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png"  alt="" data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" class="td-retina-data lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="td-retina-data" data-retina="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" src="https://www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_horizontal-300x136.png" alt=""/></noscript></noscript>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-125444"><a href="https://stlucianewsonline.com/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-184"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-164036"><a href="https://www.stlucianewsonline.com/category/headlines/">Headlines</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-262390"><a href="#">Categories</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor td-menu-item td-normal-menu menu-item-262401"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262402"><a href="https://www.stlucianewsonline.com/category/headlines/">Headlines</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262403"><a href="https://www.stlucianewsonline.com/category/breaking-news/">BREAKING NEWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92491"><a href="https://www.stlucianewsonline.com/category/all-news/accidenttragedy/">Accident/Tragedy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262404"><a href="https://www.stlucianewsonline.com/category/all-news/agriculture/">Agriculture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children td-menu-item td-normal-menu menu-item-164608"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/">Caribbean</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202324"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/antigua-and-barbuda-news/">Antigua and Barbuda News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202325"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/barbados-news/">Barbados News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202326"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/dominica-news/">Dominica News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202327"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/grenada-news/">Grenada News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-202328"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/">Guyana News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202329"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/jamaica-news/">Jamaica News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202330"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/martinique-news/">Martinique News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202331"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/st-vincent-and-the-grenadines-news/">St. Vincent and the Grenadines News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-204221"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/trinidad-and-tobago-news/">Trinidad and Tobago News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262405"><a href="https://www.stlucianewsonline.com/category/covid-19-stories/">COVID-19/Coronavirus News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262406"><a href="https://www.stlucianewsonline.com/category/all-news/court/">Court</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92485"><a href="https://www.stlucianewsonline.com/category/all-news/crimepolice/">Crime/Police</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262407"><a href="https://www.stlucianewsonline.com/category/all-news/culturehistory/">Culture/History</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262408"><a href="https://www.stlucianewsonline.com/category/all-news/development/">Development</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92489"><a href="https://www.stlucianewsonline.com/category/all-news/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262409"><a href="https://www.stlucianewsonline.com/category/all-news/environment/">Environment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92487"><a href="https://www.stlucianewsonline.com/category/all-news/financebusiness/">Finance/Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92494"><a href="https://www.stlucianewsonline.com/category/all-news/general/">General</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92493"><a href="https://www.stlucianewsonline.com/category/all-news/gis-news/">GIS News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92495"><a href="https://www.stlucianewsonline.com/category/all-news/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92496"><a href="https://www.stlucianewsonline.com/category/all-news/international-news/">International News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38108"><a href="https://www.stlucianewsonline.com/category/all-news/obituary/">Obituaries</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92490"><a href="https://www.stlucianewsonline.com/category/all-news/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262410"><a href="https://www.stlucianewsonline.com/category/religion/">Religion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92486"><a href="https://www.stlucianewsonline.com/category/all-news/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92498"><a href="https://www.stlucianewsonline.com/category/all-news/tourism/">Tourism</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262411"><a href="https://www.stlucianewsonline.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-92492"><a href="https://www.stlucianewsonline.com/category/all-news/youtheducation/">Youth/Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-92499"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262412"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/weather-updates/">Weather updates</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-262413"><a href="https://www.stlucianewsonline.com/category/columns/">Columns</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262414"><a href="https://www.stlucianewsonline.com/category/columns/dear-willie/">Dear Willie</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262415"><a href="https://www.stlucianewsonline.com/category/columns/health-talk/">Health Talk</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262416"><a href="https://www.stlucianewsonline.com/category/basic-cents/">Basic Cents</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-185"><a href="https://www.stlucianewsonline.com/category/columns/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262418"><a href="https://www.stlucianewsonline.com/category/did-you-know/">Did You Know</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-164610"><a href="https://www.stlucianewsonline.com/category/photo-of-the-day/">Photo of the Day</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-164609"><a href="https://www.stlucianewsonline.com/category/beauty-of-the-day/">Beauty of the Day</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-262419"><a href="https://www.stlucianewsonline.com/category/fan-of-the-week/">Fan of the Week</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-262420"><a href="https://www.stlucianewsonline.com/category/interactive/">Interactive</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-191"><a href="https://www.stlucianewsonline.com/category/interactive/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-193"><a href="https://www.stlucianewsonline.com/category/interactive/letters/">Letters</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-262396"><a href="https://www.stlucianewsonline.com/about/">About Us</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262391"><a href="https://www.stlucianewsonline.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-262398"><a href="/contact/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-262392"><a href="https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262393"><a href="https://www.stlucianewsonline.com/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262399"><a href="https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/">Comment Policy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-262400"><a href="https://www.stlucianewsonline.com/covid-19-updates/">COVID-19 LIVE UPDATES</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-264450"><a href="/weather/">Live Weather/Updates</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-264455"><a href="/weather/">Live Weather/Updates</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-264452"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-264451"><a href="https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/weather-updates/">Weather updates</a></li>
</ul>
</li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.stlucianewsonline.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
<div id="added_header_elements">
<div id="covid_message">
<span><a href="/covid-19-updates/">View Live COVID-19 updates</a></span>
</div>
<div id="banner_ad"></div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.stlucianewsonline.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Caribbean" class="entry-crumb" href="https://www.stlucianewsonline.com/category/all-news/caribbean/">Caribbean</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Guyana News" class="entry-crumb" href="https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/">Guyana News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Guyana: Man arrested after killing mother, injuring niece</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article class="post-267156 post type-post status-publish format-standard has-post-thumbnail category-guyana-news">
<div class="td-post-header">
<ul class="td-category">
<li class="entry-category"><a href="https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/">Guyana News</a></li>
</ul>
<header class="td-post-title">

<h3 class="entry-title td-module-title">
<a href="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/" rel="bookmark" title="Guyana: Man arrested after killing mother, injuring niece">
Guyana: Man arrested after killing mother, injuring niece </a>
</h3>
<div class="td-module-meta-info">

<div class="td-post-author-name">
<a href="https://www.stlucianewsonline.com/author/merrick/">St. Lucia News Online</a>
<div class="td-author-line"> - </div>
</div>

<span class="td-post-date">
<time class="entry-date updated td-module-date" datetime="2020-11-28T14:51:23+00:00">November 28, 2020</time>
</span>

<div class="td-post-comments">
<a href="https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/#respond">
<i class="td-icon-comments"></i>
0 </a>
</div>
</div>
</header>
<div class="td-post-content tagdiv-type">

<div class="td-post-featured-image">
<figure>
<img alt="Guyana: Man arrested after killing mother, injuring niece" title="Guyana: Man arrested after killing mother, injuring niece" data-src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/jennifer-anderson.jpeg?fit=696%2C399&#038;ssl=1" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="entry-thumb" src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/jennifer-anderson.jpeg?fit=696%2C399&#038;ssl=1" alt="Guyana: Man arrested after killing mother, injuring niece" title="Guyana: Man arrested after killing mother, injuring niece" /></noscript>
<figcaption class="wp-caption-text">Dead: Jennifer ‘Judith’ Anderson
</figcaption>
</figure>
</div>
<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="267156"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&via=slunewsonline" data-link="https://twitter.com/intent/tweet?text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&via=slunewsonline"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
							e.setAttribute('type','text/javascript');
							e.setAttribute('charset','UTF-8');
							e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
							document.body.appendChild(e);
						"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_email" data-network="email"><a class="nc_tweet noPop swp_share_link" rel="nofollow noreferrer noopener" href="/cdn-cgi/l/email-protection#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" target="_blank"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_email_icon"></i><span class="swp_share">Email</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_telegram" data-network="telegram"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece" data-link="https://telegram.me/share/url?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_telegram_icon"></i><span class="swp_share">Telegram</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_more" data-network="more"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="#" data-link="#"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_more_icon"></i><span class="swp_share">More</span></span></span></span></a></div></div><p><strong>By Isanella Patoir</strong></p>
<p><strong>(NEWS ROOM GUYANA)</strong> &#8212; Police in ‘A’ Division arrested 38-year-old Devon Anderson Thursday night, hours after he allegedly beat his mother to death and injured his four-year-old niece.</p><div class='code-block code-block-6' style='margin: 8px 0 8px auto; text-align: right; display: block; clear: both;'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle ads5" style="display:block" data-ad-client="ca-pub-3291456012722699" data-ad-slot="7750062236" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Jennifer ‘Judith’ Anderson, 62, was found with numerous marks of violence inside the wardrobe of her Goed Intent, West Bank Demerara house around midday Thursday by a relative.</p>
<p>The News Room understands that Devon, a drug addict, was arrested after ranks received a tip at about 18:00h. He was found with 12 bags of marijuana and two pieces of cocaine at John’s Hotel located on John Street, Georgetown. Reports indicate that he checked into the hotel at about 06:00h on Thursday.</p><div class='code-block code-block-7' style='margin: 8px 0 8px auto; text-align: right; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle ads6" style="display:block" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4577938132" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>According to Police Headquarters, Anderson was killed sometime between midnight Wednesday and midday Thursday.</p>
<p>Meanwhile, Regional Commander, Superintendent Errol Watts told the News Room that investigations so far revealed that Devon would constantly abuse his mother.</p>
<p>“When we interview her family members as part of the probe, they said he was always abusive to the mother and they knew about it and they never reported it to us,” the Commander said.</p>
<p>Commander Watts is urging the public to come forward with reports of domestic abuse, especially when the perpetrator is a drug user.</p><div class='code-block code-block-7' style='margin: 8px 0 8px auto; text-align: right; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle ads6" style="display:block" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4577938132" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>“When there is a domestic issue with drug addicts within a family circle, [it] is no longer a family matter.</p>
<p>“Those matters should be brought to our attention and we have systems in place to provide counselling services to these people. We are seeing this happening all the time where children are killing parents, especially the elderly,” the Commander said.</p>
<p>Devon was recently released from jail and has been in and out of the lockup over the last few years.</p>
<p>The News Room understands that Anderson was home alone with the four-year-old when Devon arrived home reportedly “high” on drugs and it is believed that he committed the act and escaped from the house.</p><div class='code-block code-block-7' style='margin: 8px 0 8px auto; text-align: right; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle ads6" style="display:block" data-ad-client="ca-pub-3291456012722699" data-ad-slot="4577938132" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>The four-year-old managed to leave the house and went to a neighbour, who then took her to the relative’s house nearby.</p>
<p>The relative then went back to the house with the child and found Anderson’s body. Neighbours claimed that they did not hear any noise emanating from the house.</p>
<div class="clearfix"><span class='ldc-ul_cont' onclick="alter_ul_post_values(this,'267156','like')"><img data-recalc-dims="1" data-src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/up.png?w=696&#038;ssl=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/up.png?w=696&#038;ssl=1" data-recalc-dims="1" /></noscript>(<span>0</span>)</span><span class='ldc-ul_cont' onclick="alter_ul_post_values(this,'267156','dislike')"><img data-recalc-dims="1" data-src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/down.png?w=696&#038;ssl=1" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/down.png?w=696&#038;ssl=1" data-recalc-dims="1" /></noscript>(<span>0</span>)</span></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="267156"><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&via=slunewsonline" data-link="https://twitter.com/intent/tweet?text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&via=slunewsonline"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
							e.setAttribute('type','text/javascript');
							e.setAttribute('charset','UTF-8');
							e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
							document.body.appendChild(e);
						"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_email" data-network="email"><a class="nc_tweet noPop swp_share_link" rel="nofollow noreferrer noopener" href="/cdn-cgi/l/email-protection#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" target="_blank"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_email_icon"></i><span class="swp_share">Email</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_telegram" data-network="telegram"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece" data-link="https://telegram.me/share/url?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fguyana-man-arrested-after-killing-mother-injuring-niece%2F&text=Guyana%3A+Man+arrested+after+killing+mother%2C+injuring+niece"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_telegram_icon"></i><span class="swp_share">Telegram</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_more" data-network="more"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="#" data-link="#"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_more_icon"></i><span class="swp_share">More</span></span></span></span></a></div></div><div class="swp-content-locator"></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
</div>
<footer>
<div class="td-block-row td-post-next-prev">
<div class="td-block-span6 td-post-prev-post">
<div class="td-post-next-prev-content">
<span>Previous article</span>
<a href="https://www.stlucianewsonline.com/jamaica-63-year-old-businesswoman-murdered/">Jamaica: 63-year-old businesswoman murdered</a>
</div>
</div>
<div class="td-next-prev-separator"></div>
<div class="td-block-span6 td-post-next-post">
<div class="td-post-next-prev-content">
<span>Next article</span>
<a href="https://www.stlucianewsonline.com/mayor-traffic-lights-reduce-traffic-congestion-in-castries/">Mayor: Traffic lights reduce traffic congestion in Castries</a>
</div>
</div>
</div>
</footer>
</div>
</article>
<div class="no-results td-pb-padding-side"><h2>No posts to display</h2></div> <div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/guyana-man-arrested-after-killing-mother-injuring-niece/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.stlucianewsonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:" type="text" value="" size="30" />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:" type="text" value="" size="30" />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p><label for='subscribe-reloaded'><input style='width:30px' type='checkbox' name='subscribe-reloaded' id='subscribe-reloaded' value='yes' /> Notify me of followup comments via e-mail. You can also <a href='https://www.stlucianewsonline.com/?page_id=99999&amp;srp=267156&amp;srk=95f3c54b0004b43a54977283c670e3be&amp;sra=s&amp;srsrc=f'>subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='267156' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b5c2a6ffda" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="200" /></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p> </div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="archives-4" class="td_block_template_1 widget archives-4 widget_archive"><h4 class="block-title"><span>ARCHIVES</span></h4> <label class="screen-reader-text" for="archives-dropdown-4">ARCHIVES</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.stlucianewsonline.com/2020/11/'> November 2020 &nbsp;(231)</option>
<option value='https://www.stlucianewsonline.com/2020/10/'> October 2020 &nbsp;(154)</option>
<option value='https://www.stlucianewsonline.com/2020/09/'> September 2020 &nbsp;(95)</option>
<option value='https://www.stlucianewsonline.com/2020/08/'> August 2020 &nbsp;(287)</option>
<option value='https://www.stlucianewsonline.com/2020/07/'> July 2020 &nbsp;(353)</option>
<option value='https://www.stlucianewsonline.com/2020/06/'> June 2020 &nbsp;(199)</option>
<option value='https://www.stlucianewsonline.com/2020/05/'> May 2020 &nbsp;(272)</option>
<option value='https://www.stlucianewsonline.com/2020/04/'> April 2020 &nbsp;(1322)</option>
<option value='https://www.stlucianewsonline.com/2020/03/'> March 2020 &nbsp;(1283)</option>
<option value='https://www.stlucianewsonline.com/2020/02/'> February 2020 &nbsp;(515)</option>
<option value='https://www.stlucianewsonline.com/2020/01/'> January 2020 &nbsp;(767)</option>
<option value='https://www.stlucianewsonline.com/2019/12/'> December 2019 &nbsp;(614)</option>
<option value='https://www.stlucianewsonline.com/2019/11/'> November 2019 &nbsp;(765)</option>
<option value='https://www.stlucianewsonline.com/2019/10/'> October 2019 &nbsp;(490)</option>
<option value='https://www.stlucianewsonline.com/2019/09/'> September 2019 &nbsp;(387)</option>
<option value='https://www.stlucianewsonline.com/2019/08/'> August 2019 &nbsp;(10)</option>
<option value='https://www.stlucianewsonline.com/2019/07/'> July 2019 &nbsp;(795)</option>
<option value='https://www.stlucianewsonline.com/2019/06/'> June 2019 &nbsp;(235)</option>
<option value='https://www.stlucianewsonline.com/2019/05/'> May 2019 &nbsp;(1056)</option>
<option value='https://www.stlucianewsonline.com/2019/04/'> April 2019 &nbsp;(491)</option>
<option value='https://www.stlucianewsonline.com/2019/03/'> March 2019 &nbsp;(722)</option>
<option value='https://www.stlucianewsonline.com/2019/02/'> February 2019 &nbsp;(1304)</option>
<option value='https://www.stlucianewsonline.com/2019/01/'> January 2019 &nbsp;(602)</option>
<option value='https://www.stlucianewsonline.com/2018/12/'> December 2018 &nbsp;(368)</option>
<option value='https://www.stlucianewsonline.com/2018/11/'> November 2018 &nbsp;(632)</option>
<option value='https://www.stlucianewsonline.com/2018/10/'> October 2018 &nbsp;(1527)</option>
<option value='https://www.stlucianewsonline.com/2018/09/'> September 2018 &nbsp;(1137)</option>
<option value='https://www.stlucianewsonline.com/2018/08/'> August 2018 &nbsp;(1206)</option>
<option value='https://www.stlucianewsonline.com/2018/07/'> July 2018 &nbsp;(1282)</option>
<option value='https://www.stlucianewsonline.com/2018/06/'> June 2018 &nbsp;(1053)</option>
<option value='https://www.stlucianewsonline.com/2018/05/'> May 2018 &nbsp;(756)</option>
<option value='https://www.stlucianewsonline.com/2018/04/'> April 2018 &nbsp;(839)</option>
<option value='https://www.stlucianewsonline.com/2018/03/'> March 2018 &nbsp;(918)</option>
<option value='https://www.stlucianewsonline.com/2018/02/'> February 2018 &nbsp;(669)</option>
<option value='https://www.stlucianewsonline.com/2018/01/'> January 2018 &nbsp;(793)</option>
<option value='https://www.stlucianewsonline.com/2017/12/'> December 2017 &nbsp;(664)</option>
<option value='https://www.stlucianewsonline.com/2017/11/'> November 2017 &nbsp;(983)</option>
<option value='https://www.stlucianewsonline.com/2017/10/'> October 2017 &nbsp;(355)</option>
<option value='https://www.stlucianewsonline.com/2017/09/'> September 2017 &nbsp;(459)</option>
<option value='https://www.stlucianewsonline.com/2017/08/'> August 2017 &nbsp;(523)</option>
<option value='https://www.stlucianewsonline.com/2017/07/'> July 2017 &nbsp;(442)</option>
<option value='https://www.stlucianewsonline.com/2017/06/'> June 2017 &nbsp;(744)</option>
<option value='https://www.stlucianewsonline.com/2017/05/'> May 2017 &nbsp;(649)</option>
<option value='https://www.stlucianewsonline.com/2017/04/'> April 2017 &nbsp;(521)</option>
<option value='https://www.stlucianewsonline.com/2017/03/'> March 2017 &nbsp;(582)</option>
<option value='https://www.stlucianewsonline.com/2017/02/'> February 2017 &nbsp;(368)</option>
<option value='https://www.stlucianewsonline.com/2017/01/'> January 2017 &nbsp;(553)</option>
<option value='https://www.stlucianewsonline.com/2016/12/'> December 2016 &nbsp;(447)</option>
<option value='https://www.stlucianewsonline.com/2016/11/'> November 2016 &nbsp;(459)</option>
<option value='https://www.stlucianewsonline.com/2016/10/'> October 2016 &nbsp;(502)</option>
<option value='https://www.stlucianewsonline.com/2016/09/'> September 2016 &nbsp;(556)</option>
<option value='https://www.stlucianewsonline.com/2016/08/'> August 2016 &nbsp;(529)</option>
<option value='https://www.stlucianewsonline.com/2016/07/'> July 2016 &nbsp;(568)</option>
<option value='https://www.stlucianewsonline.com/2016/06/'> June 2016 &nbsp;(557)</option>
<option value='https://www.stlucianewsonline.com/2016/05/'> May 2016 &nbsp;(606)</option>
<option value='https://www.stlucianewsonline.com/2016/04/'> April 2016 &nbsp;(640)</option>
<option value='https://www.stlucianewsonline.com/2016/03/'> March 2016 &nbsp;(663)</option>
<option value='https://www.stlucianewsonline.com/2016/02/'> February 2016 &nbsp;(585)</option>
<option value='https://www.stlucianewsonline.com/2016/01/'> January 2016 &nbsp;(575)</option>
<option value='https://www.stlucianewsonline.com/2015/12/'> December 2015 &nbsp;(666)</option>
<option value='https://www.stlucianewsonline.com/2015/11/'> November 2015 &nbsp;(748)</option>
<option value='https://www.stlucianewsonline.com/2015/10/'> October 2015 &nbsp;(676)</option>
<option value='https://www.stlucianewsonline.com/2015/09/'> September 2015 &nbsp;(669)</option>
<option value='https://www.stlucianewsonline.com/2015/08/'> August 2015 &nbsp;(588)</option>
<option value='https://www.stlucianewsonline.com/2015/07/'> July 2015 &nbsp;(712)</option>
<option value='https://www.stlucianewsonline.com/2015/06/'> June 2015 &nbsp;(705)</option>
<option value='https://www.stlucianewsonline.com/2015/05/'> May 2015 &nbsp;(626)</option>
<option value='https://www.stlucianewsonline.com/2015/04/'> April 2015 &nbsp;(609)</option>
<option value='https://www.stlucianewsonline.com/2015/03/'> March 2015 &nbsp;(550)</option>
<option value='https://www.stlucianewsonline.com/2015/02/'> February 2015 &nbsp;(476)</option>
<option value='https://www.stlucianewsonline.com/2015/01/'> January 2015 &nbsp;(463)</option>
<option value='https://www.stlucianewsonline.com/2014/12/'> December 2014 &nbsp;(472)</option>
<option value='https://www.stlucianewsonline.com/2014/11/'> November 2014 &nbsp;(463)</option>
<option value='https://www.stlucianewsonline.com/2014/10/'> October 2014 &nbsp;(527)</option>
<option value='https://www.stlucianewsonline.com/2014/09/'> September 2014 &nbsp;(448)</option>
<option value='https://www.stlucianewsonline.com/2014/08/'> August 2014 &nbsp;(413)</option>
<option value='https://www.stlucianewsonline.com/2014/07/'> July 2014 &nbsp;(389)</option>
<option value='https://www.stlucianewsonline.com/2014/06/'> June 2014 &nbsp;(188)</option>
<option value='https://www.stlucianewsonline.com/2014/05/'> May 2014 &nbsp;(398)</option>
<option value='https://www.stlucianewsonline.com/2014/04/'> April 2014 &nbsp;(399)</option>
<option value='https://www.stlucianewsonline.com/2014/03/'> March 2014 &nbsp;(367)</option>
<option value='https://www.stlucianewsonline.com/2014/02/'> February 2014 &nbsp;(356)</option>
<option value='https://www.stlucianewsonline.com/2014/01/'> January 2014 &nbsp;(304)</option>
<option value='https://www.stlucianewsonline.com/2013/12/'> December 2013 &nbsp;(251)</option>
<option value='https://www.stlucianewsonline.com/2013/11/'> November 2013 &nbsp;(290)</option>
<option value='https://www.stlucianewsonline.com/2013/10/'> October 2013 &nbsp;(280)</option>
<option value='https://www.stlucianewsonline.com/2013/09/'> September 2013 &nbsp;(230)</option>
<option value='https://www.stlucianewsonline.com/2013/08/'> August 2013 &nbsp;(272)</option>
<option value='https://www.stlucianewsonline.com/2013/07/'> July 2013 &nbsp;(247)</option>
<option value='https://www.stlucianewsonline.com/2013/06/'> June 2013 &nbsp;(232)</option>
<option value='https://www.stlucianewsonline.com/2013/05/'> May 2013 &nbsp;(216)</option>
<option value='https://www.stlucianewsonline.com/2013/04/'> April 2013 &nbsp;(278)</option>
<option value='https://www.stlucianewsonline.com/2013/03/'> March 2013 &nbsp;(246)</option>
<option value='https://www.stlucianewsonline.com/2013/02/'> February 2013 &nbsp;(159)</option>
<option value='https://www.stlucianewsonline.com/2013/01/'> January 2013 &nbsp;(155)</option>
<option value='https://www.stlucianewsonline.com/2012/12/'> December 2012 &nbsp;(177)</option>
<option value='https://www.stlucianewsonline.com/2012/11/'> November 2012 &nbsp;(259)</option>
<option value='https://www.stlucianewsonline.com/2012/10/'> October 2012 &nbsp;(291)</option>
<option value='https://www.stlucianewsonline.com/2012/09/'> September 2012 &nbsp;(137)</option>
<option value='https://www.stlucianewsonline.com/2012/08/'> August 2012 &nbsp;(61)</option>
<option value='https://www.stlucianewsonline.com/2012/07/'> July 2012 &nbsp;(31)</option>
<option value='https://www.stlucianewsonline.com/2012/06/'> June 2012 &nbsp;(19)</option>
</select>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</aside><aside id="ai_widget-3" class="td_block_template_1 widget ai_widget-3 ai_widget"><div class='code-block code-block-25' style='margin: 8px 0; clear: both;'>
<div id="polls-2" class="wp-polls">
<form id="polls_form_2" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_2_nonce" name="wp-polls-nonce" value="5145cc074f" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="2" /></p>
<p style="text-align: center;"><strong>Which party will you vote for in the next general elections in Saint Lucia?</strong></p><div id="polls-2-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-6" name="poll_2" value="6" /> <label for="poll-answer-6">Saint Lucia Labour Party (SLP)</label></li>
<li><input type="radio" id="poll-answer-7" name="poll_2" value="7" /> <label for="poll-answer-7">United Workers Party (UWP)</label></li>
<li><input type="radio" id="poll-answer-8" name="poll_2" value="8" /> <label for="poll-answer-8">None</label></li>
<li><input type="radio" id="poll-answer-9" name="poll_2" value="9" /> <label for="poll-answer-9">Undecided</label></li>
<li><input type="radio" id="poll-answer-10" name="poll_2" value="10" /> <label for="poll-answer-10">Saint Lucia National Party (SLP)</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(2);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(2); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-2-loading" class="wp-polls-loading"><img width="16" height="16" alt="Loading ..." title="Loading ..." data-src="https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/images/loading.gif" class="wp-polls-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" /></noscript>&nbsp;Loading ...</div>
<a href="https://bit.ly/38tw8ai"><img data-src="https://www.stlucianewsonline.com/wp-content/uploads/2020/11/St.-Lucia-News-Online-Headline-Banner-300-x-250.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://www.stlucianewsonline.com/wp-content/uploads/2020/11/St.-Lucia-News-Online-Headline-Banner-300-x-250.jpg"></noscript></a></div>
</aside><div class="td_block_wrap td_block_1 td_block_widget tdi_2_335 td-pb-border-top td_block_template_1 td-column-1" data-td-block-uid="tdi_2_335"><script>var block_tdi_2_335 = new tdBlock();
block_tdi_2_335.id = "tdi_2_335";
block_tdi_2_335.atts = '{"custom_title":"Popular Stories","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"8","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"jetpack_popular_2","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_2_335","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_2_335","tdc_css_class_style":"tdi_2_335_rand_style"}';
block_tdi_2_335.td_column_number = "1";
block_tdi_2_335.block_type = "td_block_1";
block_tdi_2_335.post_count = "5";
block_tdi_2_335.found_posts = "8";
block_tdi_2_335.header_color = "#";
block_tdi_2_335.ajax_pagination_infinite_stop = "";
block_tdi_2_335.max_num_pages = "2";
tdBlocksArray.push(block_tdi_2_335);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Popular Stories</span></h4></div><div id=tdi_2_335 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/st-lucia-govt-extend-protocols-to-curtail-covid-19-spread/" rel="bookmark" class="td-image-wrap " title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAADrAQMAAAArGX0KAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7pzbEXmAAAAAAAAAAAACQHSaOAAGSp1GBAAAAAElFTkSuQmCC" alt="" title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/covid-19-command-centre.jpg?resize=324%2C235&ssl=1" width="324" height="235" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/st-lucia-govt-extend-protocols-to-curtail-covid-19-spread/" rel="bookmark" title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread">St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://www.stlucianewsonline.com/author/merrick/">St. Lucia News Online</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T14:17:30-04:00">November 28, 2020</time></span> <span class="td-module-comments"><a href="https://www.stlucianewsonline.com/st-lucia-govt-extend-protocols-to-curtail-covid-19-spread/#respond">0</a></span> </div>
<div class="td-excerpt">
By Office of the Prime Minister
(PRESS RELEASE) -- Following recommendations from the COVID-19 Command Centre and a meeting of the National Emergency Management Advisory... </div>
</div>

</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/saint-lucia-records-cases-247-to-252-of-covid-19/" rel="bookmark" class="td-image-wrap " title="Saint Lucia records cases #247 to #252 of COVID-19"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Saint Lucia records cases #247 to #252 of COVID-19" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/04/COVID-3.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/saint-lucia-records-cases-247-to-252-of-covid-19/" rel="bookmark" title="Saint Lucia records cases #247 to #252 of COVID-19">Saint Lucia records cases #247 to #252 of COVID-19</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T17:13:05-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/jamaica-63-year-old-businesswoman-murdered/" rel="bookmark" class="td-image-wrap " title="Jamaica: 63-year-old businesswoman murdered"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Jamaica: 63-year-old businesswoman murdered" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/07/crime-scene.png?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/jamaica-63-year-old-businesswoman-murdered/" rel="bookmark" title="Jamaica: 63-year-old businesswoman murdered">Jamaica: 63-year-old businesswoman murdered</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T14:24:30-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/court-tells-trump-calling-vote-unfair-doesnt-make-it-so/" rel="bookmark" class="td-image-wrap " title="Court tells Trump: &#8216;Calling vote unfair doesn&#8217;t make it so&#8217;"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Court tells Trump: &#8216;Calling vote unfair doesn&#8217;t make it so&#8217;" data-type="image_tag" data-img-url="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/04/donald-trump-14.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/court-tells-trump-calling-vote-unfair-doesnt-make-it-so/" rel="bookmark" title="Court tells Trump: &#8216;Calling vote unfair doesn&#8217;t make it so&#8217;">Court tells Trump: &#8216;Calling vote unfair doesn&#8217;t make it so&#8217;</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T13:59:52-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/jamaican-government-to-call-out-national-reserve/" rel="bookmark" class="td-image-wrap " title="Jamaican government to call out National Reserve"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Jamaican government to call out National Reserve" data-type="image_tag" data-img-url="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/jamaican-national-reserve-soldiers.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/jamaican-government-to-call-out-national-reserve/" rel="bookmark" title="Jamaican government to call out National Reserve">Jamaican government to call out National Reserve</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T14:06:58-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> </div></div> <div class="td_block_wrap td_block_2 td_block_widget tdi_3_dff td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="tdi_3_dff"><script>var block_tdi_3_dff = new tdBlock();
block_tdi_3_dff.id = "tdi_3_dff";
block_tdi_3_dff.atts = '{"custom_title":"Latest Headlines","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m2_tl":"","m2_el":"","m6_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"57","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_3_dff","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m2f_title_font_header":"","m2f_title_font_title":"Article title","m2f_title_font_settings":"","m2f_title_font_family":"","m2f_title_font_size":"","m2f_title_font_line_height":"","m2f_title_font_style":"","m2f_title_font_weight":"","m2f_title_font_transform":"","m2f_title_font_spacing":"","m2f_title_":"","m2f_cat_font_title":"Article category tag","m2f_cat_font_settings":"","m2f_cat_font_family":"","m2f_cat_font_size":"","m2f_cat_font_line_height":"","m2f_cat_font_style":"","m2f_cat_font_weight":"","m2f_cat_font_transform":"","m2f_cat_font_spacing":"","m2f_cat_":"","m2f_meta_font_title":"Article meta info","m2f_meta_font_settings":"","m2f_meta_font_family":"","m2f_meta_font_size":"","m2f_meta_font_line_height":"","m2f_meta_font_style":"","m2f_meta_font_weight":"","m2f_meta_font_transform":"","m2f_meta_font_spacing":"","m2f_meta_":"","m2f_ex_font_title":"Article excerpt","m2f_ex_font_settings":"","m2f_ex_font_family":"","m2f_ex_font_size":"","m2f_ex_font_line_height":"","m2f_ex_font_style":"","m2f_ex_font_weight":"","m2f_ex_font_transform":"","m2f_ex_font_spacing":"","m2f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"tdi_3_dff","tdc_css_class_style":"tdi_3_dff_rand_style"}';
block_tdi_3_dff.td_column_number = "1";
block_tdi_3_dff.block_type = "td_block_2";
block_tdi_3_dff.post_count = "5";
block_tdi_3_dff.found_posts = "7762";
block_tdi_3_dff.header_color = "#";
block_tdi_3_dff.ajax_pagination_infinite_stop = "";
block_tdi_3_dff.max_num_pages = "1553";
tdBlocksArray.push(block_tdi_3_dff);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Latest Headlines</span></h4></div><div id=tdi_3_dff class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_2 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/saint-lucia-records-cases-247-to-252-of-covid-19/" rel="bookmark" class="td-image-wrap " title="Saint Lucia records cases #247 to #252 of COVID-19"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC" alt="" title="Saint Lucia records cases #247 to #252 of COVID-19" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/04/COVID-3.jpg?resize=324%2C160&ssl=1" width="324" height="160" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/saint-lucia-records-cases-247-to-252-of-covid-19/" rel="bookmark" title="Saint Lucia records cases #247 to #252 of COVID-19">Saint Lucia records cases #247 to #252 of COVID-19</a></h3>
<div class="td-module-meta-info">
<span class="td-post-author-name"><a href="https://www.stlucianewsonline.com/author/merrick/">St. Lucia News Online</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T17:13:05-04:00">November 28, 2020</time></span> <span class="td-module-comments"><a href="https://www.stlucianewsonline.com/saint-lucia-records-cases-247-to-252-of-covid-19/#respond">0</a></span> </div>
<div class="td-excerpt">
By Ministry of Health
(PRESS RELEASE) -- The Ministry of Health today Saturday, November 28, 2020, received confirmation of six new cases of COVID-19.
Two of... </div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/mayor-traffic-lights-reduce-traffic-congestion-in-castries/" rel="bookmark" class="td-image-wrap " title="Mayor: Traffic lights reduce traffic congestion in Castries"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Mayor: Traffic lights reduce traffic congestion in Castries" data-type="image_tag" data-img-url="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/mayor-peterson-francis-with-hon.-stephenson-king-pic-taken-before-covid-19-.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/mayor-traffic-lights-reduce-traffic-congestion-in-castries/" rel="bookmark" title="Mayor: Traffic lights reduce traffic congestion in Castries">Mayor: Traffic lights reduce traffic congestion in Castries</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T15:06:22-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/st-lucia-govt-extend-protocols-to-curtail-covid-19-spread/" rel="bookmark" class="td-image-wrap " title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/covid-19-command-centre.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/st-lucia-govt-extend-protocols-to-curtail-covid-19-spread/" rel="bookmark" title="St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread">St. Lucia gov&#8217;t extend protocols to curtail COVID-19 spread</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-28T14:17:30-04:00">November 28, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/breaking-news-dominica-adds-st-lucia-to-high-risk-covid-19-countries/" rel="bookmark" class="td-image-wrap " title="BREAKING NEWS: Dominica adds St. Lucia to high risk COVID-19 countries"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="BREAKING NEWS: Dominica adds St. Lucia to high risk COVID-19 countries" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/03/Coronavirus-breaking-news.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/breaking-news-dominica-adds-st-lucia-to-high-risk-covid-19-countries/" rel="bookmark" title="BREAKING NEWS: Dominica adds St. Lucia to high risk COVID-19 countries">BREAKING NEWS: Dominica adds St. Lucia to high risk COVID-19 countries</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-20T10:43:21-04:00">November 20, 2020</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.stlucianewsonline.com/20-new-covid-19-cases-confirmed-in-saint-lucia/" rel="bookmark" class="td-image-wrap " title="20 new COVID-19 cases confirmed in Saint Lucia"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="20 new COVID-19 cases confirmed in Saint Lucia" data-type="image_tag" data-img-url="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/11/breaking-news-corona.jpg?resize=100%2C70&ssl=1" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.stlucianewsonline.com/20-new-covid-19-cases-confirmed-in-saint-lucia/" rel="bookmark" title="20 new COVID-19 cases confirmed in Saint Lucia">20 new COVID-19 cases confirmed in Saint Lucia</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-11-19T13:33:35-04:00">November 19, 2020</time></span> </div>
</div>
</div>
</div> </div></div> <aside id="text-40" class="td_block_template_1 widget text-40 widget_text"> <div class="textwidget"><div id="188661078">
<script type="text/javascript">
        try {
            window._mNHandle.queue.push(function (){
                window._mNDetails.loadTag("188661078", "300x250", "188661078");
            });
        }
        catch (error) {}
    </script>
</div>
</div>
</aside><aside id="mc4wp_form_widget-2" class="td_block_template_1 widget mc4wp_form_widget-2 widget_mc4wp_form_widget"><h4 class="block-title"><span>Subscribe to our Newsletter</span></h4><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-263098 mc4wp-form-theme mc4wp-form-theme-dark" method="post" data-id="263098" data-name="Subscription Form"><div class="mc4wp-form-fields"><p>
<label>Email address:
<input type="email" name="EMAIL" placeholder="Your email address" required />
</label>
</p>
<p>
<input id="subscribe_btn" type="submit" value="Subscribe" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1606605626" /><input type="hidden" name="_mc4wp_form_id" value="263098" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside><aside id="custom_html-6" class="widget_text td_block_template_1 widget custom_html-6 widget_custom_html"><h4 class="block-title"><span>STAY CONNECTED</span></h4><div class="textwidget custom-html-widget"> <div data-elementor-type="section" data-elementor-id="264420" class="elementor elementor-264420" data-elementor-settings="[]">
<div class="elementor-inner">
<div class="elementor-section-wrap">
<section class="elementor-section elementor-top-section elementor-element elementor-element-829ea2b elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="829ea2b" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-c620a49" data-id="c620a49" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<section class="elementor-section elementor-inner-section elementor-element elementor-element-f1c2bad elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="f1c2bad" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-385ad99" data-id="385ad99" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-219c3c9 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="219c3c9" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-facebook elementor-repeater-item-b3ea00c" href="https://www.facebook.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Facebook</span>
<i class="fab fa-facebook"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-2573f01" data-id="2573f01" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-d1f64b0 elementor-widget elementor-widget-heading" data-id="d1f64b0" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">191,000 + Fans</span> </div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-04f88e0" data-id="04f88e0" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-1c72892 elementor-widget elementor-widget-heading" data-id="1c72892" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default"><a href="https://www.facebook.com/stlucianewsonline/">Like</a></span> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-section elementor-inner-section elementor-element elementor-element-36354ee elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="36354ee" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-34872cc" data-id="34872cc" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-578f291 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="578f291" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-twitter elementor-repeater-item-243b5c5" href="https://twitter.com/slunewsonline" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Twitter</span>
<i class="fab fa-twitter"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-14d7364" data-id="14d7364" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-ac63cb7 elementor-widget elementor-widget-heading" data-id="ac63cb7" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">4,400 + Followers</span> </div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-715a3f9" data-id="715a3f9" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-94535c9 elementor-widget elementor-widget-heading" data-id="94535c9" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default"><a href="https://twitter.com/slunewsonline">Follow</a></span> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-section elementor-inner-section elementor-element elementor-element-92f7869 elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="92f7869" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-412211e" data-id="412211e" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-bca9f69 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="bca9f69" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-youtube elementor-repeater-item-02bc972" href="https://www.youtube.com/channel/UCcoYNsAsNzw8Nr69B0QTiKQ" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Youtube</span>
<i class="fab fa-youtube"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-1175002" data-id="1175002" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-73ebe44 elementor-widget elementor-widget-heading" data-id="73ebe44" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">100 + Subscribers</span> </div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-b62e79a" data-id="b62e79a" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-1a1759b elementor-widget elementor-widget-heading" data-id="1a1759b" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default"><a href="https://www.youtube.com/channel/UCcoYNsAsNzw8Nr69B0QTiKQ">Subscribe</a></span> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-section elementor-inner-section elementor-element elementor-element-f82085b elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="f82085b" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-f918c6a" data-id="f918c6a" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-215c044 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="215c044" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-instagram elementor-repeater-item-02bc972" href="https://www.instagram.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Instagram</span>
<i class="fab fa-instagram"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-a04680f" data-id="a04680f" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-a3d2b4b elementor-widget elementor-widget-heading" data-id="a3d2b4b" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">4,400 + Followers</span> </div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-ef1fc73" data-id="ef1fc73" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-66c0ddb elementor-widget elementor-widget-heading" data-id="66c0ddb" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default"><a href="https://www.instagram.com/stlucianewsonline/">Follow</a></span> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div></aside> </div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
 </div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<aside class="td_block_template_1 widget widget_text"> <div class="textwidget"> <div data-elementor-type="footer" data-elementor-id="262434" class="elementor elementor-262434" data-elementor-settings="[]">
<div class="elementor-inner">
<div class="elementor-section-wrap">
<section class="elementor-section elementor-top-section elementor-element elementor-element-bb3fbdc elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="bb3fbdc" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-100 elementor-top-column elementor-element elementor-element-3bc30b5" data-id="3bc30b5" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<section class="elementor-section elementor-inner-section elementor-element elementor-element-48bfda3 elementor-hidden-tablet elementor-hidden-phone elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="48bfda3" data-element_type="section" id="footer_content">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-196fb39" data-id="196fb39" data-element_type="column" id="footer_column1">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-d8da4ba elementor-widget elementor-widget-heading" data-id="d8da4ba" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">ABOUT US</span> </div>
</div>
<div class="elementor-element elementor-element-e64e08a elementor-widget elementor-widget-text-editor" data-id="e64e08a" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><img alt="" width="133" height="165" data-recalc-dims="1" data-src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_icon.png?resize=133%2C165" class="alignleft wp-image-262160 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="alignleft wp-image-262160" src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_icon.png?resize=133%2C165" alt="" width="133" height="165" data-recalc-dims="1" /></noscript>The aim of St. Lucia News Online is to bring accurate, professional, reliable and entertaining daily and up-to-the-minute news, photos, videos, audio and commentary, from St. Lucia and around the world, to people in St. Lucia and the St. Lucian Diaspora.</p></div>
</div>
</div>
<div class="elementor-element elementor-element-a5b39a8 elementor-widget elementor-widget-heading" data-id="a5b39a8" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">CONTACT US</span> </div>
</div>
<div class="elementor-element elementor-element-a57a5e8 elementor-widget elementor-widget-text-editor" data-id="a57a5e8" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Send us an e-mail here or call us at +592-616-1878<br />(Whatsapp messages and Whatsapp calls only)</p></div>
</div>
</div>
<div class="elementor-element elementor-element-7b7e68e elementor-widget elementor-widget-heading" data-id="7b7e68e" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">FOLLOW US</span> </div>
</div>
<div class="elementor-element elementor-element-f322ac8 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="f322ac8" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-facebook elementor-repeater-item-0302027" href="https://www.facebook.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Facebook</span>
<i class="fab fa-facebook"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-instagram elementor-repeater-item-e9d6547" href="https://www.instagram.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Instagram</span>
<i class="fab fa-instagram"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-twitter elementor-repeater-item-f7b7400" href="https://twitter.com/slunewsonline" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Twitter</span>
<i class="fab fa-twitter"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-youtube elementor-repeater-item-ed978c3" href="https://www.youtube.com/channel/UCcoYNsAsNzw8Nr69B0QTiKQ" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Youtube</span>
<i class="fab fa-youtube"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-envelope elementor-repeater-item-0fd7a9b" href="/cdn-cgi/l/email-protection#84f7e8f1eae1f3f7ebeae8edeae1c4e3e9e5ede8aae7ebe9" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Envelope</span>
<i class="fas fa-envelope"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-89ef26a" data-id="89ef26a" data-element_type="column" id="footer_column2">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-c9fd2e6 elementor-widget elementor-widget-heading" data-id="c9fd2e6" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">CATEGORIES</span> </div>
</div>
<div class="elementor-element elementor-element-2895266 elementor-widget elementor-widget-text-editor" data-id="2895266" data-element_type="widget" id="footer_cat" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><a href="/category/headlines/">Headlines</a><br /><a href="/category/all-news/accidenttragedy/">Accident/Tragedy</a><br /><a href="/category/all-news/caribbean/">Caribbean</a><br /><a href="/category/all-news/crimepolice/">Crime</a><br /><a href="/category/all-news/financebusiness/">Finance/Business</a><br /><a href="/category/all-news/politics/">Politics</a><br /><a href="/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a><br /><a href="/category/covid-19-stories/">COVID-19/Coronavirus News</a><br /><a href="/covid-19-updates/">COVID-19 live map</a><br /><a href="/category/all-news/">All News</a></p></div>
</div>
</div>
<div class="elementor-element elementor-element-67555f1 elementor-widget elementor-widget-wp-widget-archives" data-id="67555f1" data-element_type="widget" id="archive_footer" data-widget_type="wp-widget-archives.default">
<div class="elementor-widget-container">
<h5>Archives</h5> <label class="screen-reader-text" for="archives-dropdown-REPLACE_TO_ID">Archives</label>
<select id="archives-dropdown-REPLACE_TO_ID" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.stlucianewsonline.com/2020/11/'> November 2020 &nbsp;(231)</option>
<option value='https://www.stlucianewsonline.com/2020/10/'> October 2020 &nbsp;(154)</option>
<option value='https://www.stlucianewsonline.com/2020/09/'> September 2020 &nbsp;(95)</option>
<option value='https://www.stlucianewsonline.com/2020/08/'> August 2020 &nbsp;(287)</option>
<option value='https://www.stlucianewsonline.com/2020/07/'> July 2020 &nbsp;(353)</option>
<option value='https://www.stlucianewsonline.com/2020/06/'> June 2020 &nbsp;(199)</option>
<option value='https://www.stlucianewsonline.com/2020/05/'> May 2020 &nbsp;(272)</option>
<option value='https://www.stlucianewsonline.com/2020/04/'> April 2020 &nbsp;(1322)</option>
<option value='https://www.stlucianewsonline.com/2020/03/'> March 2020 &nbsp;(1283)</option>
<option value='https://www.stlucianewsonline.com/2020/02/'> February 2020 &nbsp;(515)</option>
<option value='https://www.stlucianewsonline.com/2020/01/'> January 2020 &nbsp;(767)</option>
<option value='https://www.stlucianewsonline.com/2019/12/'> December 2019 &nbsp;(614)</option>
<option value='https://www.stlucianewsonline.com/2019/11/'> November 2019 &nbsp;(765)</option>
<option value='https://www.stlucianewsonline.com/2019/10/'> October 2019 &nbsp;(490)</option>
<option value='https://www.stlucianewsonline.com/2019/09/'> September 2019 &nbsp;(387)</option>
<option value='https://www.stlucianewsonline.com/2019/08/'> August 2019 &nbsp;(10)</option>
<option value='https://www.stlucianewsonline.com/2019/07/'> July 2019 &nbsp;(795)</option>
<option value='https://www.stlucianewsonline.com/2019/06/'> June 2019 &nbsp;(235)</option>
<option value='https://www.stlucianewsonline.com/2019/05/'> May 2019 &nbsp;(1056)</option>
<option value='https://www.stlucianewsonline.com/2019/04/'> April 2019 &nbsp;(491)</option>
<option value='https://www.stlucianewsonline.com/2019/03/'> March 2019 &nbsp;(722)</option>
<option value='https://www.stlucianewsonline.com/2019/02/'> February 2019 &nbsp;(1304)</option>
<option value='https://www.stlucianewsonline.com/2019/01/'> January 2019 &nbsp;(602)</option>
<option value='https://www.stlucianewsonline.com/2018/12/'> December 2018 &nbsp;(368)</option>
<option value='https://www.stlucianewsonline.com/2018/11/'> November 2018 &nbsp;(632)</option>
<option value='https://www.stlucianewsonline.com/2018/10/'> October 2018 &nbsp;(1527)</option>
<option value='https://www.stlucianewsonline.com/2018/09/'> September 2018 &nbsp;(1137)</option>
<option value='https://www.stlucianewsonline.com/2018/08/'> August 2018 &nbsp;(1206)</option>
<option value='https://www.stlucianewsonline.com/2018/07/'> July 2018 &nbsp;(1282)</option>
<option value='https://www.stlucianewsonline.com/2018/06/'> June 2018 &nbsp;(1053)</option>
<option value='https://www.stlucianewsonline.com/2018/05/'> May 2018 &nbsp;(756)</option>
<option value='https://www.stlucianewsonline.com/2018/04/'> April 2018 &nbsp;(839)</option>
<option value='https://www.stlucianewsonline.com/2018/03/'> March 2018 &nbsp;(918)</option>
<option value='https://www.stlucianewsonline.com/2018/02/'> February 2018 &nbsp;(669)</option>
<option value='https://www.stlucianewsonline.com/2018/01/'> January 2018 &nbsp;(793)</option>
<option value='https://www.stlucianewsonline.com/2017/12/'> December 2017 &nbsp;(664)</option>
<option value='https://www.stlucianewsonline.com/2017/11/'> November 2017 &nbsp;(983)</option>
<option value='https://www.stlucianewsonline.com/2017/10/'> October 2017 &nbsp;(355)</option>
<option value='https://www.stlucianewsonline.com/2017/09/'> September 2017 &nbsp;(459)</option>
<option value='https://www.stlucianewsonline.com/2017/08/'> August 2017 &nbsp;(523)</option>
<option value='https://www.stlucianewsonline.com/2017/07/'> July 2017 &nbsp;(442)</option>
<option value='https://www.stlucianewsonline.com/2017/06/'> June 2017 &nbsp;(744)</option>
<option value='https://www.stlucianewsonline.com/2017/05/'> May 2017 &nbsp;(649)</option>
<option value='https://www.stlucianewsonline.com/2017/04/'> April 2017 &nbsp;(521)</option>
<option value='https://www.stlucianewsonline.com/2017/03/'> March 2017 &nbsp;(582)</option>
<option value='https://www.stlucianewsonline.com/2017/02/'> February 2017 &nbsp;(368)</option>
<option value='https://www.stlucianewsonline.com/2017/01/'> January 2017 &nbsp;(553)</option>
<option value='https://www.stlucianewsonline.com/2016/12/'> December 2016 &nbsp;(447)</option>
<option value='https://www.stlucianewsonline.com/2016/11/'> November 2016 &nbsp;(459)</option>
<option value='https://www.stlucianewsonline.com/2016/10/'> October 2016 &nbsp;(502)</option>
<option value='https://www.stlucianewsonline.com/2016/09/'> September 2016 &nbsp;(556)</option>
<option value='https://www.stlucianewsonline.com/2016/08/'> August 2016 &nbsp;(529)</option>
<option value='https://www.stlucianewsonline.com/2016/07/'> July 2016 &nbsp;(568)</option>
<option value='https://www.stlucianewsonline.com/2016/06/'> June 2016 &nbsp;(557)</option>
<option value='https://www.stlucianewsonline.com/2016/05/'> May 2016 &nbsp;(606)</option>
<option value='https://www.stlucianewsonline.com/2016/04/'> April 2016 &nbsp;(640)</option>
<option value='https://www.stlucianewsonline.com/2016/03/'> March 2016 &nbsp;(663)</option>
<option value='https://www.stlucianewsonline.com/2016/02/'> February 2016 &nbsp;(585)</option>
<option value='https://www.stlucianewsonline.com/2016/01/'> January 2016 &nbsp;(575)</option>
<option value='https://www.stlucianewsonline.com/2015/12/'> December 2015 &nbsp;(666)</option>
<option value='https://www.stlucianewsonline.com/2015/11/'> November 2015 &nbsp;(748)</option>
<option value='https://www.stlucianewsonline.com/2015/10/'> October 2015 &nbsp;(676)</option>
<option value='https://www.stlucianewsonline.com/2015/09/'> September 2015 &nbsp;(669)</option>
<option value='https://www.stlucianewsonline.com/2015/08/'> August 2015 &nbsp;(588)</option>
<option value='https://www.stlucianewsonline.com/2015/07/'> July 2015 &nbsp;(712)</option>
<option value='https://www.stlucianewsonline.com/2015/06/'> June 2015 &nbsp;(705)</option>
<option value='https://www.stlucianewsonline.com/2015/05/'> May 2015 &nbsp;(626)</option>
<option value='https://www.stlucianewsonline.com/2015/04/'> April 2015 &nbsp;(609)</option>
<option value='https://www.stlucianewsonline.com/2015/03/'> March 2015 &nbsp;(550)</option>
<option value='https://www.stlucianewsonline.com/2015/02/'> February 2015 &nbsp;(476)</option>
<option value='https://www.stlucianewsonline.com/2015/01/'> January 2015 &nbsp;(463)</option>
<option value='https://www.stlucianewsonline.com/2014/12/'> December 2014 &nbsp;(472)</option>
<option value='https://www.stlucianewsonline.com/2014/11/'> November 2014 &nbsp;(463)</option>
<option value='https://www.stlucianewsonline.com/2014/10/'> October 2014 &nbsp;(527)</option>
<option value='https://www.stlucianewsonline.com/2014/09/'> September 2014 &nbsp;(448)</option>
<option value='https://www.stlucianewsonline.com/2014/08/'> August 2014 &nbsp;(413)</option>
<option value='https://www.stlucianewsonline.com/2014/07/'> July 2014 &nbsp;(389)</option>
<option value='https://www.stlucianewsonline.com/2014/06/'> June 2014 &nbsp;(188)</option>
<option value='https://www.stlucianewsonline.com/2014/05/'> May 2014 &nbsp;(398)</option>
<option value='https://www.stlucianewsonline.com/2014/04/'> April 2014 &nbsp;(399)</option>
<option value='https://www.stlucianewsonline.com/2014/03/'> March 2014 &nbsp;(367)</option>
<option value='https://www.stlucianewsonline.com/2014/02/'> February 2014 &nbsp;(356)</option>
<option value='https://www.stlucianewsonline.com/2014/01/'> January 2014 &nbsp;(304)</option>
<option value='https://www.stlucianewsonline.com/2013/12/'> December 2013 &nbsp;(251)</option>
<option value='https://www.stlucianewsonline.com/2013/11/'> November 2013 &nbsp;(290)</option>
<option value='https://www.stlucianewsonline.com/2013/10/'> October 2013 &nbsp;(280)</option>
<option value='https://www.stlucianewsonline.com/2013/09/'> September 2013 &nbsp;(230)</option>
<option value='https://www.stlucianewsonline.com/2013/08/'> August 2013 &nbsp;(272)</option>
<option value='https://www.stlucianewsonline.com/2013/07/'> July 2013 &nbsp;(247)</option>
<option value='https://www.stlucianewsonline.com/2013/06/'> June 2013 &nbsp;(232)</option>
<option value='https://www.stlucianewsonline.com/2013/05/'> May 2013 &nbsp;(216)</option>
<option value='https://www.stlucianewsonline.com/2013/04/'> April 2013 &nbsp;(278)</option>
<option value='https://www.stlucianewsonline.com/2013/03/'> March 2013 &nbsp;(246)</option>
<option value='https://www.stlucianewsonline.com/2013/02/'> February 2013 &nbsp;(159)</option>
<option value='https://www.stlucianewsonline.com/2013/01/'> January 2013 &nbsp;(155)</option>
<option value='https://www.stlucianewsonline.com/2012/12/'> December 2012 &nbsp;(177)</option>
<option value='https://www.stlucianewsonline.com/2012/11/'> November 2012 &nbsp;(259)</option>
<option value='https://www.stlucianewsonline.com/2012/10/'> October 2012 &nbsp;(291)</option>
<option value='https://www.stlucianewsonline.com/2012/09/'> September 2012 &nbsp;(137)</option>
<option value='https://www.stlucianewsonline.com/2012/08/'> August 2012 &nbsp;(61)</option>
<option value='https://www.stlucianewsonline.com/2012/07/'> July 2012 &nbsp;(31)</option>
<option value='https://www.stlucianewsonline.com/2012/06/'> June 2012 &nbsp;(19)</option>
</select>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-REPLACE_TO_ID" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-33 elementor-inner-column elementor-element elementor-element-c1ef9f2" data-id="c1ef9f2" data-element_type="column" id="footer_column3">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-77af00c elementor-widget elementor-widget-heading" data-id="77af00c" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">INFORMATION</span> </div>
</div>
<div class="elementor-element elementor-element-ba957ba elementor-widget elementor-widget-text-editor" data-id="ba957ba" data-element_type="widget" id="footer_inf" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><a href="/about/">About Us</a><br /><a href="/contact/">Contact Us</a><br /><a href="/about/#">Advertise With Us</a><br /><a href="/privacy-policy-stlucianewsonline-com/">Privacy Policy</a><br /><a href="/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a><br /><a href="/comment-policy-stlucianewsonline-com/">Comment Policy</a></p></div>
</div>
</div>
<div class="elementor-element elementor-element-210c61a elementor-widget elementor-widget-heading" data-id="210c61a" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">LEGAL INFO</span> </div>
</div>
<div class="elementor-element elementor-element-b649d9d elementor-widget elementor-widget-text-editor" data-id="b649d9d" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Copyright © 2012 – 2020<br />StLuciaNewsOnline.com,<br />Andrews Media Services Corporation.<br />Gros Islet, Saint Lucia, West Indies</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<div class="elementor-element elementor-element-2e84e41 elementor-hidden-desktop elementor-hidden-tablet elementor-widget elementor-widget-heading" data-id="2e84e41" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">ABOUT US</span> </div>
</div>
<section class="elementor-section elementor-inner-section elementor-element elementor-element-0efe0e0 elementor-hidden-desktop elementor-hidden-tablet elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="0efe0e0" data-element_type="section">
<div class="elementor-container elementor-column-gap-no">
<div class="elementor-row">
<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-2f5a5f3" data-id="2f5a5f3" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-8375b1c elementor-widget elementor-widget-text-editor" data-id="8375b1c" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><img alt="" width="133" height="165" data-recalc-dims="1" data-src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_icon.png?resize=133%2C165" class="wp-image-262160 alignnone lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="wp-image-262160 alignnone" src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2020/06/Logo_St.-Lucia_icon.png?resize=133%2C165" alt="" width="133" height="165" data-recalc-dims="1" /></noscript></p></div>
</div>
</div>
<div class="elementor-element elementor-element-c2e1018 elementor-shape-square elementor-grid-0 elementor-widget elementor-widget-social-icons" data-id="c2e1018" data-element_type="widget" data-widget_type="social-icons.default">
<div class="elementor-widget-container">
<div class="elementor-social-icons-wrapper elementor-grid">
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-facebook elementor-repeater-item-0302027" href="https://www.facebook.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Facebook</span>
<i class="fab fa-facebook"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-instagram elementor-repeater-item-e9d6547" href="https://www.instagram.com/stlucianewsonline/" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Instagram</span>
<i class="fab fa-instagram"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-twitter elementor-repeater-item-f7b7400" href="https://twitter.com/slunewsonline" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Twitter</span>
<i class="fab fa-twitter"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-youtube elementor-repeater-item-ed978c3" href="https://www.youtube.com/channel/UCcoYNsAsNzw8Nr69B0QTiKQ" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Youtube</span>
<i class="fab fa-youtube"></i> </a>
</div>
<div class="elementor-grid-item">
<a class="elementor-icon elementor-social-icon elementor-social-icon-envelope elementor-repeater-item-0fd7a9b" href="/cdn-cgi/l/email-protection#047768716a6173776b6a686d6a61446369656d682a676b69" target="_blank" rel="noopener noreferrer">
<span class="elementor-screen-only">Envelope</span>
<i class="fas fa-envelope"></i> </a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-5e718cf" data-id="5e718cf" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-d88a80f elementor-widget elementor-widget-text-editor" data-id="d88a80f" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>The aim of St. Lucia News Online is to bring accurate, professional, reliable and entertaining daily and up-to-the-minute news, photos, videos, audio and commentary, from St. Lucia and around the world, to people in St. Lucia and the St. Lucian Diaspora.</p></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
<section class="elementor-section elementor-inner-section elementor-element elementor-element-5212697 elementor-hidden-desktop elementor-hidden-tablet elementor-section-boxed elementor-section-height-default elementor-section-height-default" data-id="5212697" data-element_type="section">
<div class="elementor-container elementor-column-gap-default">
<div class="elementor-row">
<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-9eef49d" data-id="9eef49d" data-element_type="column">
<div class="elementor-column-wrap elementor-element-populated">
<div class="elementor-widget-wrap">
<div class="elementor-element elementor-element-5c627e1 elementor-widget elementor-widget-heading" data-id="5c627e1" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">CATEGORIES</span> </div>
</div>
<div class="elementor-element elementor-element-b7a8445 footer_cat elementor-widget elementor-widget-text-editor" data-id="b7a8445" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><a href="/category/headlines/">Headlines</a><br /><a href="/category/all-news/accidenttragedy/">Accident/Tragedy</a><br /><a href="/category/all-news/caribbean/">Caribbean</a><br /><a href="/category/all-news/crimepolice/">Crime</a><br /><a href="/category/all-news/financebusiness/">Finance/Business</a><br /><a href="/category/all-news/politics/">Politics</a><br /><a href="/category/all-news/weathernatural-disaster/">Weather/Natural Disaster</a><br /><a href="/category/covid-19-stories/">COVID-19/Coronavirus News</a><br /><a href="/covid-19-updates/">COVID-19 live map</a><br /><a href="/category/all-news/">All News</a></p></div>
</div>
</div>
<div class="elementor-element elementor-element-ea435d7 elementor-widget elementor-widget-heading" data-id="ea435d7" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">INFORMATION</span> </div>
</div>
<div class="elementor-element elementor-element-14b3687 footer_inf elementor-widget elementor-widget-text-editor" data-id="14b3687" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p><a href="/about/">About Us</a><br /><a href="/contact/">Contact Us</a><br /><a href="/about/#">Advertise With Us</a><br /><a href="/privacy-policy-stlucianewsonline-com/">Privacy Policy</a><br /><a href="/disclaimer-copyright-policy-stlucianewsonline-com/">Disclaimer/Copyright Policy</a><br /><a href="/comment-policy-stlucianewsonline-com/">Comment Policy</a></p></div>
</div>
</div>
<div class="elementor-element elementor-element-1d1f94e elementor-widget elementor-widget-heading" data-id="1d1f94e" data-element_type="widget" data-widget_type="heading.default">
<div class="elementor-widget-container">
<span class="elementor-heading-title elementor-size-default">LEGAL INFO</span> </div>
</div>
<div class="elementor-element elementor-element-65354a0 elementor-widget elementor-widget-text-editor" data-id="65354a0" data-element_type="widget" data-widget_type="text-editor.default">
<div class="elementor-widget-container">
<div class="elementor-text-editor elementor-clearfix"><p>Copyright © 2012 – 2020<br />StLuciaNewsOnline.com,<br />Andrews Media Services Corporation.<br />Gros Islet, Saint Lucia, West Indies</p></div>
</div>
</div>
</div>
</div>
</div>
<div class="elementor-column elementor-col-50 elementor-inner-column elementor-element elementor-element-5b2aab2" data-id="5b2aab2" data-element_type="column">
<div class="elementor-column-wrap">
<div class="elementor-widget-wrap">
</div>
</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div>
</div>
</section>
</div>
</div>
</div>
</div>
</aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; </div>
</div>
</div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	var isProcessing = false; 
    function alter_ul_post_values(obj,post_id,ul_type){
	
		if (isProcessing)    
		return;  
		isProcessing = true;   
		
		jQuery(obj).find("span").html("..");
    	jQuery.ajax({
   		type: "POST",
   		url: "https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/ajax_counter.php",
   		data: "post_id="+post_id+"&up_type="+ul_type,
   		success: function(msg){
     		jQuery(obj).find("span").html(msg);
			isProcessing = false; 
   			}
 		});
	}
	</script>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<script nitro-exclude>
    if (!window.NITROPACK_STATE || window.NITROPACK_STATE != 'FRESH') {
        var proxyPurgeOnly = 0;
        if (typeof navigator.sendBeacon !== 'undefined') {
            var nitroData = new FormData(); nitroData.append('nitroBeaconUrl', 'aHR0cHM6Ly93d3cuc3RsdWNpYW5ld3NvbmxpbmUuY29tL2d1eWFuYS1tYW4tYXJyZXN0ZWQtYWZ0ZXIta2lsbGluZy1tb3RoZXItaW5qdXJpbmctbmllY2Uv'); nitroData.append('nitroBeaconCookies', 'W10='); nitroData.append('nitroBeaconHash', '250a960764ce4cc6d46d920d22795a5ed01a62d8ab4b6da2a160cb1a60dc10d6e23ca7d3e6b9d51005bfca16e6c74f150dec9c4ac590eaf5bcc7362804b5efdb'); nitroData.append('proxyPurgeOnly', ''); navigator.sendBeacon(location.href, nitroData);
        } else {
            var xhr = new XMLHttpRequest(); xhr.open('POST', location.href, true); xhr.setRequestHeader('Content-Type', 'application/x-www-form-urlencoded'); xhr.send('nitroBeaconUrl=aHR0cHM6Ly93d3cuc3RsdWNpYW5ld3NvbmxpbmUuY29tL2d1eWFuYS1tYW4tYXJyZXN0ZWQtYWZ0ZXIta2lsbGluZy1tb3RoZXItaW5qdXJpbmctbmllY2Uv&nitroBeaconCookies=W10=&nitroBeaconHash=250a960764ce4cc6d46d920d22795a5ed01a62d8ab4b6da2a160cb1a60dc10d6e23ca7d3e6b9d51005bfca16e6c74f150dec9c4ac590eaf5bcc7362804b5efdb&proxyPurgeOnly=');
        }
    }
</script><link data-optimized="1" rel='stylesheet' id='elementor-frontend-legacy-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/58792.css?e472d' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-frontend-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/219c3.css?025c0' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-post-264420-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/e298b.css?0236c' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-post-262434-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/b9f3d.css?19681' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-icons-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/790fe.css?6f99d' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-animations-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/56985.css?daa94' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-post-262438-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/c8b7c.css?43841' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-pro-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/b36c4.css?bd7e5' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='google-fonts-1-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/bb4eb.css?bdd2a' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-icons-shared-0-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/9153c.css?d6b37' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-icons-fa-brands-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/99c9f.css?23299' type='text/css' media='all' />
<link data-optimized="1" rel='stylesheet' id='elementor-icons-fa-solid-css' href='https://www.stlucianewsonline.com/wp-content/litespeed/cssjs/61018.css?eede3' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='adsforwp-ads-front-js-js-extra'>
/* <![CDATA[ */
var adsforwp_obj = {"ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"20235a225c"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ads-for-wp/public/assets/js/ads-front.min.js?ver=1.9.16.1' id='adsforwp-ads-front-js-js'></script>
<script type='text/javascript' id='adsforwp-ads-frontend-js-js-extra'>
/* <![CDATA[ */
var adsforwp_browser_obj = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/ads-for-wp/public/assets/js/ads-frontend.min.js?ver=1.9.16.1' id='adsforwp-ads-frontend-js-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5' id='wp-polls-js'></script>
<script type='text/javascript' id='social_warfare_script-js-extra'>
/* <![CDATA[ */
var socialWarfare = {"addons":["pro"],"post_id":"267156","variables":{"emphasizeIcons":"2","powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=4.1.0' id='social_warfare_script-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.7.2' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=b609d31b17f396913344a17574b6a2f5' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.5' id='td-site-min-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b609d31b17f396913344a17574b6a2f5' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js?ver=4.8.1' id='mc4wp-forms-api-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.0.5' id='elementor-frontend-modules-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor-pro/assets/lib/sticky/jquery.sticky.min.js?ver=2.10.2' id='elementor-sticky-js'></script>
<script type='text/javascript' id='elementor-pro-frontend-js-before'>
var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","nonce":"b97db1cc4e","i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"delicious":{"title":"Delicious"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/www.stlucianewsonline.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=2.10.2' id='elementor-pro-frontend-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/jquery/ui/position.min.js' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js?ver=4.8.1' id='elementor-dialog-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js?ver=4.0.2' id='elementor-waypoints-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js?ver=5.3.6' id='swiper-js'></script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js?ver=3.0.5' id='share-link-js'></script>
<script type='text/javascript' id='elementor-frontend-js-before'>
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","download":"Download","downloadImage":"Download image","fullscreen":"Fullscreen","zoom":"Zoom","share":"Share","playVideo":"Play Video","previous":"Previous","next":"Next","close":"Close"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"version":"3.0.5","is_static":false,"legacyMode":{"elementWrappers":true},"urls":{"assets":"https:\/\/www.stlucianewsonline.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"editorPreferences":[]},"kit":{"global_image_lightbox":"yes","lightbox_enable_counter":"yes","lightbox_enable_fullscreen":"yes","lightbox_enable_zoom":"yes","lightbox_enable_share":"yes","lightbox_title_src":"title","lightbox_description_src":"description"},"post":{"id":267156,"title":"Guyana%3A%20Man%20arrested%20after%20killing%20mother%2C%20injuring%20niece","excerpt":"","featuredImage":"https:\/\/www.stlucianewsonline.com\/wp-content\/uploads\/2020\/11\/jennifer-anderson.jpeg"}};
</script>
<script type='text/javascript' src='https://www.stlucianewsonline.com/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.0.5' id='elementor-frontend-js'></script>
<script type="text/javascript"> var swp_nonce = "7126619ab3";function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://www.stlucianewsonline.com/guyana-man-arrested-after-killing-mother-injuring-niece/";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};var swpFloatBeforeContent = false; var swp_ajax_url = "https://www.stlucianewsonline.com/wp-admin/admin-ajax.php"; var swp_post_id = "267156";var swpClickTracking = false; swpPinIt={"enabled":false};</script>

<script>
    
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202048.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9',blog:'42891802',post:'267156',tz:'-4',srv:'www.stlucianewsonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '42891802', '267156' ]);
</script>
<script>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</script>
</body>
</html>
