<!DOCTYPE html><html lang=en-US prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#"><head> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3291456012722699",
    enable_page_level_ads: true
  });</script> <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1"><meta charset=UTF-8><link rel=profile href="https://gmpg.org/xfn/11"><link rel=pingback href=https://www.stlucianewsonline.com/xmlrpc.php><title>Chewbacca actor Peter Mayhew dies aged 74 - St. Lucia News Online</title><style>@font-face {font-family: "sw-icon-font";src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=3.5.4");src:url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=3.5.4#iefix") format("embedded-opentype"),url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=3.5.4") format("woff"),
	url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=3.5.4") format("truetype"),url("https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=3.5.4#1445203416") format("svg");font-weight: normal;font-style: normal;}</style><meta name=description content=-><link rel=canonical href=https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Chewbacca actor Peter Mayhew dies aged 74 - St. Lucia News Online"><meta property=og:description content=-><meta property=og:url content=https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/><meta property=og:site_name content="St. Lucia News Online"><meta property=article:publisher content=https://www.facebook.com/stlucianewsonline/><meta property=article:section content="International News"><meta property=article:published_time content=2019-05-03T01:15:41+00:00><meta property=fb:app_id content=249337255435947><meta property=og:image content=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106775094_5a92457a-cdbb-4ef6-a76e-e0db1fab4386.jpg><meta property=og:image:secure_url content=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106775094_5a92457a-cdbb-4ef6-a76e-e0db1fab4386.jpg><meta property=og:image:width content=624><meta property=og:image:height content=351> <script type=application/ld+json class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.stlucianewsonline.com/#website","url":"https://www.stlucianewsonline.com/","name":"St. Lucia News Online","publisher":{"@id":"https://www.stlucianewsonline.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.stlucianewsonline.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#webpage","url":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/","inLanguage":"en-US","name":"Chewbacca actor Peter Mayhew dies aged 74 - St. Lucia News Online","isPartOf":{"@id":"https://www.stlucianewsonline.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#primaryimage","url":"https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106775094_5a92457a-cdbb-4ef6-a76e-e0db1fab4386.jpg","caption":"Peter Mayhew plays Chewbacca (L) alongside Harrison Ford in Star Wars Episode IV. * LUCASFILM\n\n"},"primaryImageOfPage":{"@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#primaryimage"},"datePublished":"2019-05-03T01:15:41+00:00","dateModified":"2019-05-03T01:15:41+00:00","description":"-"},{"@type":"Article","@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#article","isPartOf":{"@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#webpage"},"author":{"@id":"https://www.stlucianewsonline.com/author/merrick/#author","name":"Admin"},"publisher":{"@id":"https://www.stlucianewsonline.com/#organization"},"headline":"Chewbacca actor Peter Mayhew dies aged 74","datePublished":"2019-05-03T01:15:41+00:00","dateModified":"2019-05-03T01:15:41+00:00","commentCount":0,"mainEntityOfPage":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#webpage","image":{"@id":"https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#primaryimage"},"articleSection":"International News"},{"@type":"Person","@id":"https://www.stlucianewsonline.com/author/merrick/#author","name":"Admin","image":{"@type":"ImageObject","@id":"https://www.stlucianewsonline.com/#personlogo","url":"https://secure.gravatar.com/avatar/00a90281981a31a7a648fb987aaea560?s=96&d=mm&r=g","caption":"Admin"},"sameAs":[]}]}</script> <link rel=dns-prefetch href=//s0.wp.com><link rel=dns-prefetch href=//secure.gravatar.com><link rel=dns-prefetch href=//fonts.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="St. Lucia News Online &raquo; Feed" href=https://www.stlucianewsonline.com/feed/><link rel=alternate type=application/rss+xml title="St. Lucia News Online &raquo; Comments Feed" href=https://www.stlucianewsonline.com/comments/feed/><link rel=alternate type=application/rss+xml title="St. Lucia News Online &raquo; Chewbacca actor Peter Mayhew dies aged 74 Comments Feed" href=https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/feed/> <script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.stlucianewsonline.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel=stylesheet id=validate-engine-css-css href=https://www.stlucianewsonline.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css type=text/css media=all><link rel=stylesheet id=resads-main-css href=https://www.stlucianewsonline.com/wp-content/plugins/resads/css/main.min.css type=text/css media=all><link rel=stylesheet id=social-warfare-block-css-css href=https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/js/post-editor/dist/blocks.style.build.css type=text/css media=all><link rel=stylesheet id=wp-block-library-css href=https://www.stlucianewsonline.com/wp-includes/css/dist/block-library/style.min.css type=text/css media=all><link rel=stylesheet id=ditty-news-ticker-font-css href=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/libs/fontastic/styles.css type=text/css media=all><link rel=stylesheet id=ditty-news-ticker-css href=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/css/style.css type=text/css media=all><link rel=stylesheet id=page-list-style-css href=https://www.stlucianewsonline.com/wp-content/plugins/sitemap/css/page-list.css type=text/css media=all><link rel=stylesheet id=wp-polls-css href=https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/polls-css.css type=text/css media=all><style id=wp-polls-inline-css>.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}</style><link rel=stylesheet id=wpfront-notification-bar-css href=https://www.stlucianewsonline.com/wp-content/plugins/wpfront-notification-bar/css/wpfront-notification-bar.css type=text/css media=all><link rel=stylesheet id=wp-pagenavi-css href=https://www.stlucianewsonline.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css type=text/css media=all><link rel=stylesheet id=social_warfare-css href=https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/css/style.min.css type=text/css media=all><link rel=stylesheet id=tie-style-css href=https://www.stlucianewsonline.com/wp-content/themes/jarida/style.css type=text/css media=all><link crossorigin=anonymous rel=stylesheet id=Oswald-css href='https://fonts.googleapis.com/css?family=Oswald%3Aregular%2C700' type=text/css media=all><link rel=stylesheet id=awpcp-frontend-style-css href=https://www.stlucianewsonline.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css type=text/css media=all>
<!--[if lte IE 6]><link
rel=stylesheet id=awpcp-frontend-style-ie-6-css  href=https://www.stlucianewsonline.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css type=text/css media=all>
<![endif]-->
<!--[if lte IE 7]><link
rel=stylesheet id=awpcp-frontend-style-lte-ie-7-css  href=https://www.stlucianewsonline.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css type=text/css media=all>
<![endif]--><link rel=stylesheet id=social-logos-css href=https://www.stlucianewsonline.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css type=text/css media=all><link rel=stylesheet id=jetpack_css-css href=https://www.stlucianewsonline.com/wp-content/plugins/jetpack/css/jetpack.css type=text/css media=all><link rel=stylesheet id=like-dislike-css href=https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/css/ldc-lite.css type=text/css media=all><link rel=stylesheet id=sociable3-css href=https://www.stlucianewsonline.com/wp-content/plugins/sociable-30/sociable.css type=text/css media=all> <script src=https://www.stlucianewsonline.com/wp-includes/js/jquery/jquery.js></script> <script src=https://www.stlucianewsonline.com/wp-includes/js/jquery/jquery-migrate.min.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/wp-newsticker/scripts/jquery.newsticker.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/wpfront-notification-bar/jquery-plugins/jquery.c.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/wpfront-notification-bar/js/wpfront-notification-bar.js></script> <link rel=https://api.w.org/ href=https://www.stlucianewsonline.com/wp-json/><link rel=EditURI type=application/rsd+xml title=RSD href=https://www.stlucianewsonline.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://www.stlucianewsonline.com/wp-includes/wlwmanifest.xml><meta name=generator content="WordPress 5.1.1"><link rel=shortlink href=https://wp.me/p2TY7g-VEp><link rel=alternate type=application/json+oembed href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><link rel=alternate type=text/xml+oembed href="https://www.stlucianewsonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F&#038;format=xml"><style></style><style>.pcs-content,.pcs-excerpt{text-align:justify}.gws .pcs-sub,.igws .pcs-sub,.iws .pcs-sub,.ws .pcs-sub{border-bottom:1px solid #777}.pcs-body,.pcs-main,.pcs-pagination,.pcs-sub{overflow:hidden}.pcs-body,.pcs-img,.pcs-meta,.pcs-pagination ul li,.pcsmeta{float:left}.pcs-reset{line-height:1.7em;margin-bottom:3px}.pcs-main{padding:10px!important}.pcs-sub:first-child{margin-top:0}.pcs-sub{margin-top:15px;padding-right:10px;clear:both;display:block}.pcs-body,.pcs-img{display:block;vertical-align:top;box-sizing:border-box}.pcs-body{width:60%}.pcs-img{width:30%;margin:0 10px 10px 0!important}.pcs-title{font-size:15px;display:block;padding:0;margin:0 0 5px}.pcs-excerpt{font-size:13px;display:block}.pcs-content,.pcs-meta{display:block;font-size:12px}.pcs-rm,.pcsmeta{display:inline-block}.pcs-meta a{font-size:12px!important}.pcs-rm{font-size:15px;clear:both;text-align:left}.pcs-img img{max-width:100%;max-height:100%;margin:0 auto}.pcsmeta{padding-right:10px}.pcs-cust-field,.pcs-pagination{display:block;clear:both}.pcs-meta .glyphicon{margin-right:3px}.gws .pcs-title a,.ws .pcs-title a{color:#222}.gws .pcs-excerpt,.ws .pcs-excerpt{color:#333}.gws .pcs-content,.ws .pcs-content{color:#444}.gws .pcs-meta,.gws .pcs-meta a,.ws .pcs-meta,.ws .pcs-meta a{color:#555}.gws .pcs-rm,.ws .pcs-rm{color:#666}.gws a:hover,.ws a:hover{color:#000!important}.igws.pcs-main,.iws.pcs-main{background-color:#333}.igws .pcs-title a,.iws .pcs-title a{color:#eee}.igws .pcs-content,.igws .pcs-excerpt,.iws .pcs-content,.iws .pcs-excerpt{color:#ddd}.igws .pcs-meta,.igws .pcs-meta a,.iws .pcs-meta,.iws .pcs-meta a{color:#ccc}.igws .pcs-rm,.iws .pcs-rm{color:#eee!important}.igws a:hover,.iws a:hover{color:#fff!important}.gcore .pcs-body,.gcore .pcs-img,.gws .pcs-body,.gws .pcs-img,.igws .pcs-body,.igws .pcs-img{width:100%}.pcs-pagination ul{display:inline-block;padding:0;margin:10px 1px;border-radius:50%;list-style-type:none}.pcs-pagination ul li a,.pcs-pagination ul li span{float:left;padding:10px 15px;line-height:1.5;color:#0275d8;text-decoration:none;background-color:#fff;border:1px solid #ddd;display:block;margin-left:-1px}.pcs-pagination ul li a:hover,.pcs-pagination ul li span.current{background-color:#0275d8;color:#fff}</style> <script>window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.stlucianewsonline.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '221613';
	window._wp_rp_num_rel_posts = '6';
	window._wp_rp_thumbnails = false;
	window._wp_rp_post_title = 'Chewbacca+actor+Peter+Mayhew+dies+aged+74';
	window._wp_rp_post_tags = ['international+news', 'warrior', 'film', 'alt', 'home', 'famili', 'frame', 'relationship', 'ford', 'texa', 'war', 'angi', 'peter', 'harrison', 'mayhew', 'star'];
	window._wp_rp_promoted_content = true;</script> <link rel=dns-prefetch href=//v0.wordpress.com><link rel="shortcut icon" href="https://www.stlucianewsonline.com/wp-content/uploads/2016/10/b52fd3a5ff2ec82d5321ebe65f5cb805.ico.png" title=Favicon><!--[if IE]> <script>jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script> <![endif]-->
<!--[if lt IE 9]> <script src=https://www.stlucianewsonline.com/wp-content/themes/jarida/js/html5.js></script> <script src=https://www.stlucianewsonline.com/wp-content/themes/jarida/js/selectivizr-min.js></script> <![endif]-->
<!--[if IE 8]><link
rel=stylesheet type=text/css media=all href=https://www.stlucianewsonline.com/wp-content/themes/jarida/css/ie8.css>
<![endif]--><meta http-equiv=X-UA-Compatible content="IE=edge,chrome=1"><meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no"><style media=screen></style><meta name=onesignal content=wordpress-plugin><link rel=manifest href="https://www.stlucianewsonline.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="> <script src=https://cdn.onesignal.com/sdks/OneSignalSDK.js async></script> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.stlucianewsonline.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '184d14e5-faaa-4b10-8537-ce997bde8aab';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.stlucianewsonline.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1a908d8f-b1c2-454b-a8c2-6bb9d82d2555";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['siteName'] = 'ttp://www.stlucianewsonline.com';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel=amphtml href=https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/amp/> <script>window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/stlucianewsonline-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}</script> </head><body id=top class="post-template-default single single-post postid-221613 single-format-standard"><div id=fb-root></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=1381483658763791";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <div align class="top-site-advert2"><div style="width:1040px;margin:0 auto;max-width: 100%;text-align:center;"><div class="resads-adspot resads-adspot-34" adspot=34></div></div></div><div class="resads-adspot resads-adspot-8" adspot=8></div><div class="wrapper full-site layout-2c"><div class="top-nav fade-in animated1 head_brnews container"><div class=container><div class=search-block><form method=get id=searchform action=https://www.stlucianewsonline.com/>
<button class=search-button type=submit value=Search></button>
<input type=text id=s name=s value=Search... onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"></form></div><div class="social-icons icon_flat">
<a class=tooldown title=Rss href=https://www.stlucianewsonline.com/feed/ target=_blank><i class=tieicon-rss></i></a><a class=tooldown title=Facebook href=https://www.facebook.com/stlucianewsonline/ target=_blank><i class=tieicon-facebook></i></a></div><div class=breaking-news>
<span>Don't Miss</span><ul><li><a href=https://www.stlucianewsonline.com/saint-lucia-providing-100-doses-of-measles-vaccine-free-of-cost-to-quarantined-cruise-ship/ title="VIDEO: Saint Lucia providing 100 doses of measles vaccine free of cost to quarantined cruise ship">VIDEO: Saint Lucia providing 100 doses of measles vaccine free of cost to quarantined cruise ship</a></li><li><a href=https://www.stlucianewsonline.com/breaking-news-one-injured-one-arrested-firearm-recovered-after-gros-islet-shooting/ title="BREAKING NEWS: One injured, one arrested, firearm recovered after Gros Islet shooting">BREAKING NEWS: One injured, one arrested, firearm recovered after Gros Islet shooting</a></li><li><a href=https://www.stlucianewsonline.com/police-update-on-homicide-in-micoud/ title="Police update on homicide in Micoud">Police update on homicide in Micoud</a></li><li><a href=https://www.stlucianewsonline.com/update-dominican-national-killed-in-micoud-saint-lucia-identified/ title="UPDATE: Bullet-riddled body found in Micoud identified as that of Dominican national">UPDATE: Bullet-riddled body found in Micoud identified as that of Dominican national</a></li><li><a href=https://www.stlucianewsonline.com/breaking-news-body-of-foreign-national-found-in-micoud/ title="BREAKING NEWS: Body of foreign national found in Micoud">BREAKING NEWS: Body of foreign national found in Micoud</a></li></ul> <script>jQuery(document).ready(function(){
								jQuery('.breaking-news ul').innerfade({animationtype: 'slide', speed: 200 , timeout: 3500});
							});</script> </div></div></div><div class=marginAdLeft><div class="resads-adspot resads-adspot-40" adspot=40></div></div><div class=marginAdRight></div><div class=marginAdRight><div class="resads-adspot resads-adspot-41" adspot=41></div></div><div class=container><header id=theme-header><div class="header-content fade-in animated1"><div class=logo><h2> <a title="St. Lucia News Online" href=https://www.stlucianewsonline.com/>
<img src=https://www.stlucianewsonline.com/wp-content/uploads/2016/10/logo2.jpeg alt="St. Lucia News Online"><strong>St. Lucia News Online The aim of St.Lucia News Online is to bring breaking news, professional and reliable daily news, photos, videos , audio and commentary to every St. Lucian.</strong>
</a></h2></div><div class="grid8 headerAd"><div style class=header-ad><div class="resads-adspot resads-adspot-33" adspot=33></div></div></div><div class=clear></div><div style=width:3px id=mtphr-dnt-7756 class="mtphr-dnt mtphr-dnt-7756 mtphr-dnt-default mtphr-dnt-scroll mtphr-dnt-scroll-left"><div class="mtphr-dnt-wrapper mtphr-dnt-clearfix"><div class=mtphr-dnt-tick-container><div class=mtphr-dnt-tick-contents><div class="mtphr-dnt-tick mtphr-dnt-default-tick mtphr-dnt-clearfix "><font>Add us on Whatsapp, +1758 712 6700<font></div></div></div></div></div><div class=clear></div></div><nav id=main-nav class="fade-in animated2 fixed-enabled"><div class=container><div class=main-menu><ul id=menu-main-menu class=menu><li id=menu-item-125444 class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href=http://stlucianewsonline.com/>Home</a></li><li id=menu-item-2748 class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href=https://www.stlucianewsonline.com/about/>About</a></li><li id=menu-item-184 class="menu-item  menu-item-type-custom  menu-item-object-custom  menu-item-has-children"><a href="https://www.stlucianewsonline.com/category/all-news/">All News</a><ul class=sub-menu><li id=menu-item-92491 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/accidenttragedy/>Accident/Tragedy</a></li><li id=menu-item-164608 class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/>Caribbean</a><ul class=sub-menu><li id=menu-item-202324 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/antigua-and-barbuda-news/>Antigua and Barbuda News</a></li><li id=menu-item-202325 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/barbados-news/>Barbados News</a></li><li id=menu-item-202326 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/dominica-news/>Dominica News</a></li><li id=menu-item-202327 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/grenada-news/>Grenada News</a></li><li id=menu-item-202328 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/guyana-news/>Guyana News</a></li><li id=menu-item-202329 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/jamaica-news/>Jamaica News</a></li><li id=menu-item-202330 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/martinique-news/>Martinique News</a></li><li id=menu-item-202331 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/st-vincent-and-the-grenadines-news/>St. Vincent and the Grenadines News</a></li><li id=menu-item-204221 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/caribbean/trinidad-and-tobago-news/>Trinidad and Tobago News</a></li></ul></li><li id=menu-item-92485 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/crimepolice/>Crime/Police</a></li><li id=menu-item-92489 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/entertainment/>Entertainment</a></li><li id=menu-item-92487 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/financebusiness/>Finance/Business</a></li><li id=menu-item-92494 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/general/>General</a></li><li id=menu-item-92493 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/gis-news/>GIS News</a></li><li id=menu-item-92495 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/health/>Health</a></li><li id=menu-item-92496 class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent"><a href=https://www.stlucianewsonline.com/category/all-news/international-news/>International News</a></li><li id=menu-item-38108 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/obituary/>Obituaries</a></li><li id=menu-item-92490 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/politics/>Politics</a></li><li id=menu-item-92486 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/sports/>Sports</a></li><li id=menu-item-92498 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/tourism/>Tourism</a></li><li id=menu-item-92499 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/weathernatural-disaster/>Weather/Natural Disaster</a></li><li id=menu-item-92492 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/all-news/youtheducation/>Youth/Education</a></li></ul></li><li id=menu-item-164036 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/headlines/>Headlines</a></li><li id=menu-item-185 class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href=https://www.stlucianewsonline.com/category/columns/>Features</a><ul class=sub-menu><li id=menu-item-164609 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/beauty-of-the-day/>Beauty of the Day</a></li><li id=menu-item-164610 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/photo-of-the-day/>Photo of the Day</a></li></ul></li><li id=menu-item-189 class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href=https://www.stlucianewsonline.com/category/interactive/>Opinion</a><ul class=sub-menu><li id=menu-item-191 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/interactive/commentary/>Commentary</a></li><li id=menu-item-193 class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href=https://www.stlucianewsonline.com/category/interactive/letters/>Letters</a></li></ul></li><li id=menu-item-45047 class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href=https://www.stlucianewsonline.com/weather/>Live Weather</a></li><li id=menu-item-186206 class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href=https://www.stlucianewsonline.com/classifieds/>Classifieds</a></li><li id=menu-item-2747 class="menu-item  menu-item-type-post_type  menu-item-object-page"><a href=https://www.stlucianewsonline.com/contact/>Contact</a></li></ul></div></div></nav></header><div id=main-content class="container fade-in animated3"><div id=floating class=floating><div class="resads-adspot resads-adspot-61" adspot=61></div></div><div class=content-wrap><div class=content><div class=top-site-show style=width:100%><center> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-3291456012722699 data-ad-slot=2473754360 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </center><div class="resads-adspot resads-adspot-36" adspot=36></div></div><div class=atop-site-show><div class="resads-adspot resads-adspot-55" adspot=55></div></div><article id=the-post class="post-listing post-221613 post type-post status-publish format-standard has-post-thumbnail hentry category-international-news"><div class=post-inner><h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop=name>Chewbacca actor Peter Mayhew dies aged 74</span></h1>
By BBC<div class=story-date>May 2, 2019</div><div class=entry><h4>&nbsp;Share This On:</h4><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width=1100 data-float-color=#ffffff data-float=bottom data-float-mobile=bottom data-transition=slide><div class="nc_tweetContainer swp_share_button swp_twitter" data-network=twitter><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://twitter.com/intent/tweet?text=Chewbacca+actor+Peter+Mayhew+dies+aged+74&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://twitter.com/intent/tweet?text=Chewbacca+actor+Peter+Mayhew+dies+aged+74&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_twitter_icon"></i><span class=swp_share>Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network=pinterest><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
e.setAttribute('type','text/javascript');
e.setAttribute('charset','UTF-8');
e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
document.body.appendChild(e);
"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_pinterest_icon"></i><span class=swp_share>Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network=facebook><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_facebook_icon"></i><span class=swp_share>Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_google_plus" data-network=google_plus><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://plus.google.com/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_google_plus_icon"></i><span class=swp_share>+1</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt"><span class="swp_count ">0 <span class=swp_label>Shares</span></span></div></div><div id=attachment_221614 style="width: 634px" class="wp-caption aligncenter"><img aria-describedby=caption-attachment-221614 class="size-full wp-image-221614" src="https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106775094_5a92457a-cdbb-4ef6-a76e-e0db1fab4386.jpg" alt width=624 height=351><p id=caption-attachment-221614 class=wp-caption-text>Peter Mayhew plays Chewbacca (L) alongside Harrison Ford in Star Wars Episode IV. * LUCASFILM</p></div><p><strong>(BBC)</strong> &#8212; Peter Mayhew, the actor who played Chewbacca in the Star Wars films, has died aged 74, his family says.</p><p>He passed away at his home in Texas on 30 April with his family by his side, a statement said.<div class=in-article style=text-align:center;><div class=in-article-wrapper style="margin:0em auto 1em;clear:both;"> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-3291456012722699 data-ad-slot=7293639387 data-ad-format=rectangle data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></p><p>The British-American actor played giant Wookiee warrior Chewbacca in the original trilogy beginning in 1977 as well as later films.</p><p>&#8220;He put his heart and soul into the role of Chewbacca and it showed in every frame,&#8221; his family said.</p><p>They said that &#8220;the Star Wars family meant so much more to him than a role in a film&#8221;.</p><div id=attachment_221615 style="width: 670px" class="wp-caption aligncenter"><img aria-describedby=caption-attachment-221615 class="size-full wp-image-221615" src="https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106774680_2a0ce802-1205-46b4-b3e9-a8dc64632ab2.jpg" alt width=660 height=371><p id=caption-attachment-221615 class=wp-caption-text>Peter Mayhew</p></div><p>&#8220;The relationships that began then grew into the friends and family that he would love for decades to come.&#8221;<div class=in-article style=text-align:center;><div class=in-article-wrapper style="margin:0em auto 1em;clear:both;"> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-3291456012722699 data-ad-slot=7293639387 data-ad-format=rectangle data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></p><p>Mayhew&#8217;s family did not says what the cause of his death was.</p><p>The actor, who was 7ft 2in (2.18m) tall, is survived by his wife Angie and three children.</p><div class=clearfix><span class=ldc-ul_cont onclick="alter_ul_post_values(this,'221613','like')"><img src=https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/up.png>(<span>0</span>)</span><span class=ldc-ul_cont onclick="alter_ul_post_values(this,'221613','dislike')"><img src=https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/images/down.png>(<span>0</span>)</span></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share This On:</h3><div class=sd-content><ul><li class=share-facebook><a rel="nofollow noopener noreferrer" data-shared=sharing-facebook-221613 class="share-facebook sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=facebook" target=_blank title="Click to share on Facebook"><span></span><span class=sharing-screen-reader-text>Click to share on Facebook (Opens in new window)</span></a></li><li class=share-twitter><a rel="nofollow noopener noreferrer" data-shared=sharing-twitter-221613 class="share-twitter sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=twitter" target=_blank title="Click to share on Twitter"><span></span><span class=sharing-screen-reader-text>Click to share on Twitter (Opens in new window)</span></a></li><li class=share-jetpack-whatsapp><a rel="nofollow noopener noreferrer" data-shared class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=jetpack-whatsapp" target=_blank title="Click to share on WhatsApp"><span></span><span class=sharing-screen-reader-text>Click to share on WhatsApp (Opens in new window)</span></a></li><li class=share-email><a rel="nofollow noopener noreferrer" data-shared class="share-email sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=email" target=_blank title="Click to email this to a friend"><span></span><span class=sharing-screen-reader-text>Click to email this to a friend (Opens in new window)</span></a></li><li class=share-pocket><a rel="nofollow noopener noreferrer" data-shared class="share-pocket sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=pocket" target=_blank title="Click to share on Pocket"><span></span><span class=sharing-screen-reader-text>Click to share on Pocket (Opens in new window)</span></a></li><li><a href=# class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class=share-end></li></ul><div class=sharing-hidden><div class=inner style="display: none;"><ul><li class=share-tumblr><a rel="nofollow noopener noreferrer" data-shared class="share-tumblr sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=tumblr" target=_blank title="Click to share on Tumblr"><span></span><span class=sharing-screen-reader-text>Click to share on Tumblr (Opens in new window)</span></a></li><li class=share-reddit><a rel="nofollow noopener noreferrer" data-shared class="share-reddit sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=reddit" target=_blank title="Click to share on Reddit"><span></span><span class=sharing-screen-reader-text>Click to share on Reddit (Opens in new window)</span></a></li><li class=share-end></li><li class=share-pinterest><a rel="nofollow noopener noreferrer" data-shared=sharing-pinterest-221613 class="share-pinterest sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=pinterest" target=_blank title="Click to share on Pinterest"><span></span><span class=sharing-screen-reader-text>Click to share on Pinterest (Opens in new window)</span></a></li><li class=share-telegram><a rel="nofollow noopener noreferrer" data-shared class="share-telegram sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=telegram" target=_blank title="Click to share on Telegram"><span></span><span class=sharing-screen-reader-text>Click to share on Telegram (Opens in new window)</span></a></li><li class=share-end></li><li class=share-linkedin><a rel="nofollow noopener noreferrer" data-shared=sharing-linkedin-221613 class="share-linkedin sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=linkedin" target=_blank title="Click to share on LinkedIn"><span></span><span class=sharing-screen-reader-text>Click to share on LinkedIn (Opens in new window)</span></a></li><li class=share-print><a rel="nofollow noopener noreferrer" data-shared class="share-print sd-button share-icon no-text" href=https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/#print target=_blank title="Click to print"><span></span><span class=sharing-screen-reader-text>Click to print (Opens in new window)</span></a></li><li class=share-end></li><li class=share-skype><a rel="nofollow noopener noreferrer" data-shared=sharing-skype-221613 class="share-skype sd-button share-icon no-text" href="https://www.stlucianewsonline.com/chewbacca-actor-peter-mayhew-dies-aged-74/?share=skype" target=_blank title="Click to share on Skype"><span></span><span class=sharing-screen-reader-text>Click to share on Skype (Opens in new window)</span></a></li><li class=share-end></li></ul></div></div></div></div></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width=1100 data-float-color=#ffffff data-float=bottom data-float-mobile=bottom data-transition=slide><div class="nc_tweetContainer swp_share_button swp_twitter" data-network=twitter><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://twitter.com/intent/tweet?text=Chewbacca+actor+Peter+Mayhew+dies+aged+74&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://twitter.com/intent/tweet?text=Chewbacca+actor+Peter+Mayhew+dies+aged+74&url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_twitter_icon"></i><span class=swp_share>Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network=pinterest><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
e.setAttribute('type','text/javascript');
e.setAttribute('charset','UTF-8');
e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
document.body.appendChild(e);
"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_pinterest_icon"></i><span class=swp_share>Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network=facebook><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_facebook_icon"></i><span class=swp_share>Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_google_plus" data-network=google_plus><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target=_blank href="https://plus.google.com/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fwww.stlucianewsonline.com%2Fchewbacca-actor-peter-mayhew-dies-aged-74%2F"><span class="swp_count swp_hide"><span class=iconFiller><span class=spaceManWilly><i class="sw swp_google_plus_icon"></i><span class=swp_share>+1</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt"><span class="swp_count ">0 <span class=swp_label>Shares</span></span></div></div><div class=swp-content-locator></div><div class=ads-bottom><div class="resads-adspot resads-adspot-71" adspot=71></div></div><div class="resads-adspot resads-adspot-38" adspot=38></div><div class="resads-adspot resads-adspot-39" adspot=39></div><div id=taboola-below-article-thumbnails></div> <script>window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });</script> </div><div class=disclaimer-ad>This article was posted in its entirety as received by stlucianewsonline.com.
This media house does not correct any spelling or grammatical error within press releases and commentaries.
The views expressed therein are not necessarily those of stlucianewsonline.com, its sponsors or advertisers.</div><div class=article-bottom> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-3291456012722699 data-ad-slot=8637489142 data-ad-format=rectangle,vertical data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div>
<span style=display:none class=updated>2019-05-02</span><div style=display:none class="vcard author" itemprop=author itemscope itemtype=http://schema.org/Person><strong class=fn itemprop=name><a href=https://www.stlucianewsonline.com/author/merrick/ title="Posts by Admin" rel=author>Admin</a></strong></div></div></article><div id=comments><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel=nofollow id=cancel-comment-reply-link href=/chewbacca-actor-peter-mayhew-dies-aged-74/#respond style=display:none;>Cancel reply</a></small></h3><form action=https://www.stlucianewsonline.com/wp-comments-post.php method=post id=commentform class=comment-form><p class=comment-notes>Your email address will not be published.</p><p class=comment-form-comment><label for=comment>Comment</label><textarea id=comment name=comment cols=45 rows=8 maxlength=65525 required=required></textarea></p><p class=comment-form-author><label for=author>Name</label> <input id=author name=author type=text value size=30></p><p class=comment-form-email><label for=email>Email</label> <input id=email name=email type=text value size=30></p><p class=comment-form-url><label for=url>Website</label><input id=url name=url type=text value size=30></p><p><label for=subscribe-reloaded><input style=width:30px type=checkbox name=subscribe-reloaded id=subscribe-reloaded value=yes> Notify me of followup comments via e-mail. You can also <a href='https://www.stlucianewsonline.com/?page_id=99999&amp;srp=221613&amp;srk=&amp;sra=s&amp;srsrc=f'>subscribe</a> without commenting.</label></p><p class=form-submit><input name=submit type=submit id=submit class=submit value="Post Comment"> <input type=hidden name=comment_post_ID value=221613 id=comment_post_ID>
<input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=3ce8c075ce></p><p class=wysija-after-comment><label for=wysija-box-after-comment><input type=checkbox id=wysija-box-after-comment value=1 name=wysija[comment_subscribe]>Yes, add me to your mailing list.</label></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=233></p></form></div><p class=akismet_comment_form_privacy_notice>This site uses Akismet to reduce spam. <a href=https://akismet.com/privacy/ target=_blank rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div></div><aside class=sidebar><div id=execphp-9 class="widget widget_execphp"><div class=widget-top><h4></h4><div class=stripe-line></div></div><div class=widget-container><div class=execphpwidget><div id=otherPostInfo class=grid4><div class="top-site-show art-page"></div><div class="top-site-show art-page"><div class=right-advert><div class="resads-adspot resads-adspot-26" adspot=26></div></div><div class=right-advert><div class="resads-adspot resads-adspot-27" adspot=27></div></div></div><div ="relatedPosts" class="first grid4"><div class="first grid4 sidebarBox"><ul></ul></div><div class="top-site-show art-page"><div class=right-advert><div class="resads-adspot resads-adspot-28" adspot=28></div></div></div><div class="top-site-show art-page"><div class=right-advert>'<div class="resads-adspot resads-adspot-29" adspot=29></div></div></div><div class="top-site-show art-page"><div class=right-advert><div class="resads-adspot resads-adspot-30" adspot=30></div></div></div><div class="top-site-show art-page art-right-6"><div class=right-advert><div class="resads-adspot resads-adspot-64" adspot=64></div></div><div class=right-advert><div class="resads-adspot resads-adspot-31" adspot=31></div></div></div><div class="top-site-show art-page"></div><div class="top-site-show art-page"></div><div class="top-site-show art-page"></div><div class="top-site-show art-page"><div class="resads-adspot resads-adspot-70" adspot=70></div></div></div></div></div></div><div id=top-posts-3 class="widget widget_top-posts"><div class=widget-top><h4>Trending News</h4><div class=stripe-line></div></div><div class=widget-container><ul class='widgets-list-layout no-grav'><li>
<a href=https://www.stlucianewsonline.com/update-dominican-national-killed-in-micoud-saint-lucia-identified/ title="UPDATE: Bullet-riddled body found in Micoud identified as that of Dominican national" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/chris-charles.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="UPDATE: Bullet-riddled body found in Micoud identified as that of Dominican national" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/update-dominican-national-killed-in-micoud-saint-lucia-identified/ class=bump-view data-bump-view=tp>
UPDATE: Bullet-riddled body found in Micoud identified as that of Dominican national	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/saint-lucian-being-rescued-at-sea-captured-on-video-two-others-reported-missing-see-videos/ title="Saint Lucian being rescued at sea captured on video; two others reported missing (see videos)" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/saint-lucian-rescued-sea.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="Saint Lucian being rescued at sea captured on video; two others reported missing (see videos)" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/saint-lucian-being-rescued-at-sea-captured-on-video-two-others-reported-missing-see-videos/ class=bump-view data-bump-view=tp>
Saint Lucian being rescued at sea captured on video; two others reported missing (see videos)	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/breaking-news-body-of-foreign-national-found-in-micoud/ title="BREAKING NEWS: Body of foreign national found in Micoud" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/capture-20190501-154408.png?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="BREAKING NEWS: Body of foreign national found in Micoud" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/breaking-news-body-of-foreign-national-found-in-micoud/ class=bump-view data-bump-view=tp>
BREAKING NEWS: Body of foreign national found in Micoud	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/video-dominican-killed-in-micoud-was-a-former-gangster-ex-convict-who-turned-his-life-around/ title="VIDEO: Dominican killed in Micoud was a former gangster, ex-convict who turned his life around" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/chris-e-charles-saint-lucia-dominica.png?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="VIDEO: Dominican killed in Micoud was a former gangster, ex-convict who turned his life around" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/video-dominican-killed-in-micoud-was-a-former-gangster-ex-convict-who-turned-his-life-around/ class=bump-view data-bump-view=tp>
VIDEO: Dominican killed in Micoud was a former gangster, ex-convict who turned his life around	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/church-of-scientology-cruise-ship-quarantined-for-measles-scheduled-to-leave-st-lucia-thursday/ title="Church of Scientology cruise ship quarantined for measles scheduled to leave St. Lucia Thursday" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2016/07/measles16.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="Church of Scientology cruise ship quarantined for measles scheduled to leave St. Lucia Thursday" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/church-of-scientology-cruise-ship-quarantined-for-measles-scheduled-to-leave-st-lucia-thursday/ class=bump-view data-bump-view=tp>
Church of Scientology cruise ship quarantined for measles scheduled to leave St. Lucia Thursday	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/video-saint-lucia-quarantines-cruise-ship-due-to-measles-report/ title="VIDEO: Saint Lucia quarantines cruise ship due to measles report" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i2.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/01/Cruise-Ship-Inaugural-Berthing-2nd-Jan-2019-Set2-25.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="VIDEO: Saint Lucia quarantines cruise ship due to measles report" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/video-saint-lucia-quarantines-cruise-ship-due-to-measles-report/ class=bump-view data-bump-view=tp>
VIDEO: Saint Lucia quarantines cruise ship due to measles report	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/nic-to-launch-low-to-moderate-income-housing/ title="NIC to launch low-income housing project" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2017/05/affordable-housing3.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="NIC to launch low-income housing project" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/nic-to-launch-low-to-moderate-income-housing/ class=bump-view data-bump-view=tp>
NIC to launch low-income housing project	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/police-update-on-homicide-in-micoud/ title="Police update on homicide in Micoud" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i0.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/chris-charles-1.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="Police update on homicide in Micoud" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/police-update-on-homicide-in-micoud/ class=bump-view data-bump-view=tp>
Police update on homicide in Micoud	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/breaking-news-one-injured-one-arrested-firearm-recovered-after-gros-islet-shooting/ title="BREAKING NEWS: One injured, one arrested, firearm recovered after Gros Islet shooting" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/10.jpg?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="BREAKING NEWS: One injured, one arrested, firearm recovered after Gros Islet shooting" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/breaking-news-one-injured-one-arrested-firearm-recovered-after-gros-islet-shooting/ class=bump-view data-bump-view=tp>
BREAKING NEWS: One injured, one arrested, firearm recovered after Gros Islet shooting	</a></div></li><li>
<a href=https://www.stlucianewsonline.com/ccj-orders-barbados-man-to-serve-at-least-25-years-for-fire-that-killed-six-women/ title="CCJ orders Barbados man to serve at least 25 years for robbery-fire that killed six women" class=bump-view data-bump-view=tp>
<img width=40 height=40 src="https://i1.wp.com/www.stlucianewsonline.com/wp-content/uploads/2019/05/renaldo-alleyne-1206185023-450x303.gif?resize=40%2C40&#038;ssl=1" class=widgets-list-layout-blavatar alt="CCJ orders Barbados man to serve at least 25 years for robbery-fire that killed six women" data-pin-nopin=true>
</a><div class=widgets-list-layout-links>
<a href=https://www.stlucianewsonline.com/ccj-orders-barbados-man-to-serve-at-least-25-years-for-fire-that-killed-six-women/ class=bump-view data-bump-view=tp>
CCJ orders Barbados man to serve at least 25 years for robbery-fire that killed six women	</a></div></li></ul></div></div><style>.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}</style><div id=rpwe_widget-7 class="widget rpwe_widget recent-posts-extended"><div class=widget-top><h4>Recent Posts</h4><div class=stripe-line></div></div><div class=widget-container><div class="rpwe-block "><ul class=rpwe-ul><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/oecs-benefits-from-agricultural-workers-programme/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/farming-tools5-30x30.jpg alt="OECS benefits from agricultural workers programme"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/oecs-benefits-from-agricultural-workers-programme/ title="Permalink to OECS benefits from agricultural workers programme" rel=bookmark>OECS benefits from agricultural workers programme</a></h3><time class="rpwe-time published" datetime=2019-05-02T22:33:45-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/frc-vivan-groovysocalypso-fundraiser-is-launched/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/FRC-Groovy-tabloid-poster-30x30.jpg alt="FRC Vivan Groovysocalypso fundraiser is launched"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/frc-vivan-groovysocalypso-fundraiser-is-launched/ title="Permalink to FRC Vivan Groovysocalypso fundraiser is launched" rel=bookmark>FRC Vivan Groovysocalypso fundraiser is launched</a></h3><time class="rpwe-time published" datetime=2019-05-02T22:27:15-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/saint-lucian-reggae-artiste-natty-conqueror-releases-new-album/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/IMG_20190430_134637_571-30x30.jpg alt="Saint Lucia-based reggae artiste Natty Conqueror releases new album"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/saint-lucian-reggae-artiste-natty-conqueror-releases-new-album/ title="Permalink to Saint Lucia-based reggae artiste Natty Conqueror releases new album" rel=bookmark>Saint Lucia-based reggae artiste Natty Conqueror releases new album</a></h3><time class="rpwe-time published" datetime=2019-05-02T22:04:11-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/fans-urge-caster-semenya-not-to-quit-after-athletes-cryptic-tweet/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106762116_castorsemenya-30x30.jpg alt="Fans urge Caster Semenya not to quit after athlete&#8217;s cryptic tweet"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/fans-urge-caster-semenya-not-to-quit-after-athletes-cryptic-tweet/ title="Permalink to Fans urge Caster Semenya not to quit after athlete&#8217;s cryptic tweet" rel=bookmark>Fans urge Caster Semenya not to quit after athlete&#8217;s cryptic tweet</a></h3><time class="rpwe-time published" datetime=2019-05-02T21:41:33-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/speaker-nancy-pelosi-accuses-attorney-general-william-barr-of-lying-to-congress/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106772822_befunky-collage-30x30.jpg alt="Speaker Nancy Pelosi accuses Attorney General William Barr of lying to Congress"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/speaker-nancy-pelosi-accuses-attorney-general-william-barr-of-lying-to-congress/ title="Permalink to Speaker Nancy Pelosi accuses Attorney General William Barr of lying to Congress" rel=bookmark>Speaker Nancy Pelosi accuses Attorney General William Barr of lying to Congress</a></h3><time class="rpwe-time published" datetime=2019-05-02T21:29:49-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/shares-in-vegan-firm-beyond-meat-soar-163-on-first-day/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/Beyond-Meat-30x30.png alt="Shares in vegan firm Beyond Meat soar 163% on first day"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/shares-in-vegan-firm-beyond-meat-soar-163-on-first-day/ title="Permalink to Shares in vegan firm Beyond Meat soar 163% on first day" rel=bookmark>Shares in vegan firm Beyond Meat soar 163% on first day</a></h3><time class="rpwe-time published" datetime=2019-05-02T21:24:53-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/first-catalyst-leadership-development-workshop-in-the-bvi-deemed-a-success/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/DPP_3702-30x30.jpg alt="First ‘Catalyst’ leadership development workshop in the BVI deemed a success"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/first-catalyst-leadership-development-workshop-in-the-bvi-deemed-a-success/ title="Permalink to First ‘Catalyst’ leadership development workshop in the BVI deemed a success" rel=bookmark>First ‘Catalyst’ leadership development workshop in the BVI deemed a success</a></h3><time class="rpwe-time published" datetime=2019-05-02T20:56:32-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/life-saving-kidney-delivered-by-drone/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/capture-20190502-195746-30x30.png alt="Life-saving kidney delivered by drone"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/life-saving-kidney-delivered-by-drone/ title="Permalink to Life-saving kidney delivered by drone" rel=bookmark>Life-saving kidney delivered by drone</a></h3><time class="rpwe-time published" datetime=2019-05-02T19:58:40-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/hither-green-stabbed-burglar-henry-vincent-lawfully-killed/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/106765681_mediaitem106765680-30x30.jpg alt="Hither Green stabbed burglar Henry Vincent lawfully killed"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/hither-green-stabbed-burglar-henry-vincent-lawfully-killed/ title="Permalink to Hither Green stabbed burglar Henry Vincent lawfully killed" rel=bookmark>Hither Green stabbed burglar Henry Vincent lawfully killed</a></h3><time class="rpwe-time published" datetime=2019-05-02T19:55:39-04:00>May 2, 2019</time></li><li class="rpwe-li rpwe-clearfix"><a class=rpwe-img href=https://www.stlucianewsonline.com/six-reasons-to-attend-the-4th-caribbean-poshgirl-power-brunch/ rel=bookmark><img class="rpwe-alignleft rpwe-thumb" src=https://www.stlucianewsonline.com/wp-content/uploads/2019/05/speakers-30x30.jpg alt="Six reasons to attend the 4th Caribbean POSHgirl Power Brunch"></a><h3 class="rpwe-title"><a href=https://www.stlucianewsonline.com/six-reasons-to-attend-the-4th-caribbean-poshgirl-power-brunch/ title="Permalink to Six reasons to attend the 4th Caribbean POSHgirl Power Brunch" rel=bookmark>Six reasons to attend the 4th Caribbean POSHgirl Power Brunch</a></h3><time class="rpwe-time published" datetime=2019-05-02T19:49:25-04:00>May 2, 2019</time></li></ul></div></div></div><div id=wp_related_posts_widget class="widget widget_wp_related_posts"><div class="wp_rp_wrap  wp_rp_vertical_m" id=wp_rp_first><div class=wp_rp_content><div class=widget-top><h4>Related Stories</h4><div class=stripe-line></div></div><div class=widget-container><ul class="related_post wp_rp"><li data-position=0 data-poid=in-221578 data-post-type=none><a href=https://www.stlucianewsonline.com/star-wars-chewbacca-actor-peter-mayhew-dies-at-74/ class=wp_rp_title>Star Wars Chewbacca actor Peter Mayhew dies at 74</a><small class=wp_rp_comments_count> (0)</small><br></li><li data-position=1 data-poid=in-193301 data-post-type=none><a href=https://www.stlucianewsonline.com/blade-runner-star-wanted-after-stealing-laptops/ class=wp_rp_title>Blade Runner star wanted after &#8216;stealing laptops&#8217;</a><small class=wp_rp_comments_count> (0)</small><br></li><li data-position=2 data-poid=in-171089 data-post-type=none><a href=https://www.stlucianewsonline.com/woman-says-boyfriend-beat-raped-her-in-months-long-ordeal/ class=wp_rp_title>Woman says boyfriend beat, raped her in months-long ordeal</a><small class=wp_rp_comments_count> (3)</small><br></li><li data-position=3 data-poid=in-178737 data-post-type=none><a href=https://www.stlucianewsonline.com/henry-and-baloo-dog-and-cat-travel-companions-gain-cult-following/ class=wp_rp_title>Henry and Baloo: Dog and cat travel companions gain cult following</a><small class=wp_rp_comments_count> (1)</small><br></li><li data-position=4 data-poid=in-188649 data-post-type=none><a href=https://www.stlucianewsonline.com/george-clooney-injured-in-italian-motorbike-crash/ class=wp_rp_title>George Clooney injured in Italian motorbike crash</a><small class=wp_rp_comments_count> (0)</small><br></li><li data-position=5 data-poid=in-166482 data-post-type=none><a href=https://www.stlucianewsonline.com/indian-mp-offers-1-6m-to-behead-actress/ class=wp_rp_title>Indian MP offers $1.6M to behead actress</a><small class=wp_rp_comments_count> (1)</small><br></li></ul></div></div></div></div><div id=execphp-14 class="widget widget_execphp"><div class=widget-top><h4>Recommended for you</h4><div class=stripe-line></div></div><div class=widget-container><div class=execphpwidget><script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-3291456012722699 data-ad-slot=5361672625></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></aside><div class=clear></div><div class=clear></div></div></div><footer class="fade-in animated4"><div id=footer-widget-area class="footer-3c container"><div id=footer-first class=footer-widgets-box><div id=nav_menu-3 class="footer-widget widget_nav_menu"><div class=footer-widget-top><h4>Policies</h4></div><div class=footer-widget-container><div class=menu-footer-menu-container><ul id=menu-footer-menu class=menu><li id=menu-item-191253 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191253"><a href=https://www.stlucianewsonline.com/privacy-policy-stlucianewsonline-com/>Privacy Policy</a></li><li id=menu-item-191251 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191251"><a href=https://www.stlucianewsonline.com/disclaimer-copyright-policy-stlucianewsonline-com/>Disclaimer/Copyright Policy</a></li><li id=menu-item-191252 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191252"><a href=https://www.stlucianewsonline.com/comment-policy-stlucianewsonline-com/>Comment Policy</a></li><li id=menu-item-191254 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-191254"><a href=https://www.stlucianewsonline.com/contact/>Contact</a></li></ul></div></div></div></div><div id=footer-second class=footer-widgets-box><div id=text-34 class="footer-widget widget_text"><div class=footer-widget-top><h4>Contact Information</h4></div><div class=footer-widget-container><div class=textwidget><p>Call: +1-758-712-6700</p><p>E-mail: <a href="/cdn-cgi/l/email-protection#ccada2a8bea9bbbfa1a9a8a5adafa3bebc8caba1ada5a0e2afa3a1"><span class="__cf_email__" data-cfemail="5b3a353f293e2c28363e3f323a3834292b1b3c363a323775383436">[email&#160;protected]</span></a></p><p>Mail: Gros Islet Post Office, Gros Islet, Saint Lucia, West Indies</p><p>&nbsp;</p></div></div></div></div><div id=footer-third class=footer-widgets-box><div id=text-33 class="footer-widget widget_text"><div class=footer-widget-top><h4>LEGAL INFO</h4></div><div class=footer-widget-container><div class=textwidget><p>Copyright © 2012 &#8211; 2018 &#8211; StLuciaNewsOnline.com,<br>
Andrews Media Services Corporation.<br>
Gros Islet, Saint Lucia, West Indies</p><p>All rights reserved.</p></div></div></div></div></div><div class=clear></div></footer><div class=clear></div><div class="footer-bottom fade-in animated4"><div class=container><div class=alignleft></div></div></div></div><div id=fb-root></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>window._taboola = window._taboola || [];
  _taboola.push({flush: true});</script> <script>var isProcessing = false; 
    function alter_ul_post_values(obj,post_id,ul_type){
	
		if (isProcessing)    
		return;  
		isProcessing = true;   
		
		jQuery(obj).find("span").html("..");
    	jQuery.ajax({
   		type: "POST",
   		url: "https://www.stlucianewsonline.com/wp-content/plugins/like-dislike-counter-for-posts-pages-and-comments/ajax_counter.php",
   		data: "post_id="+post_id+"&up_type="+ul_type,
   		success: function(msg){
     		jQuery(obj).find("span").html(msg);
			isProcessing = false; 
   			}
 		});
	}</script> <script>divScroller("scroll-h", "h", 40, 6000);</script> <div style=display:none></div><style>#wpfront-notification-bar 
    {
        background: #ff0000;
        background: -moz-linear-gradient(top, #ff0000 0%, #000000 100%);
        background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#ff0000), color-stop(100%,#000000));
        background: -webkit-linear-gradient(top, #ff0000 0%,#000000 100%);
        background: -o-linear-gradient(top, #ff0000 0%,#000000 100%);
        background: -ms-linear-gradient(top, #ff0000 0%,#000000 100%);
        background: linear-gradient(to bottom, #ff0000 0%, #000000 100%);
        filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ff0000', endColorstr='#000000',GradientType=0 );
    }

    #wpfront-notification-bar div.wpfront-message
    {
        color: #ffffff;
    }

    #wpfront-notification-bar a.wpfront-button
    {
        background: #00b7ea;
        background: -moz-linear-gradient(top, #00b7ea 0%, #009ec3 100%);
        background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#00b7ea), color-stop(100%,#009ec3));
        background: -webkit-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: -o-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: -ms-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: linear-gradient(to bottom, #00b7ea 0%, #009ec3 100%);
        filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#00b7ea', endColorstr='#009ec3',GradientType=0 );

        color: #ffffff;
    }

    #wpfront-notification-bar-open-button
    {
        background-color: #00b7ea;
    }

    #wpfront-notification-bar  div.wpfront-close 
    {
        border: 1px solid #555555;
        background-color: #555555;
        color: #000000;
    }

    #wpfront-notification-bar  div.wpfront-close:hover 
    {
        border: 1px solid #aaaaaa;
        background-color: #aaaaaa;
    }</style><div id=wpfront-notification-bar-spacer style="display: none;"><div id=wpfront-notification-bar-open-button class="top wpfront-bottom-shadow"></div><div id=wpfront-notification-bar class="wpfront-fixed "><div class=wpfront-close>X</div><table border=0 cellspacing=0 cellpadding=0><tr><td><div class=wpfront-message>
<b>One injured in Gros Islet shooting</b></div><div>
<a class=wpfront-button href=https://www.stlucianewsonline.com/breaking-news-one-injured-one-arrested-firearm-recovered-after-gros-islet-shooting/ target=_blank>Read more</a></div></td></tr></table></div></div><style></style> <script>if(typeof wpfront_notification_bar == "function") wpfront_notification_bar({"position":1,"height":40,"fixed_position":"on","animate_delay":0.5,"close_button":true,"button_action_close_bar":false,"auto_close_after":0,"display_after":1,"is_admin_bar_showing":false,"display_open_button":"on","keep_closed":false,"keep_closed_for":0,"position_offset":0,"display_scroll":false,"display_scroll_offset":100});</script> <script>window.WPCOM_sharing_counts = {"https:\/\/www.stlucianewsonline.com\/chewbacca-actor-peter-mayhew-dies-aged-74\/":221613};</script> <div id=sharing_email style="display: none;"><form action=/chewbacca-actor-peter-mayhew-dies-aged-74/ method=post>
<label for=target_email>Send to Email Address</label>
<input type=email name=target_email id=target_email value>
<label for=source_name>Your Name</label>
<input type=text name=source_name id=source_name value><label for=source_email>Your Email Address</label>
<input type=email name=source_email id=source_email value><input type=text id=jetpack-source_f_name name=source_f_name class=input value size=25 autocomplete=off title="This field is for validation and should not be changed">
<img style="float: right; display: none" class=loading src=https://www.stlucianewsonline.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif alt=loading width=16 height=16>
<input type=submit value="Send Email" class=sharing_send>
<a rel=nofollow href=#cancel class=sharing_cancel role=button>Cancel</a><div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses!</div><div class="errors errors-2" style="display: none;">
Email check failed, please try again</div><div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email.</div></form></div> <script>var ajax_object = {"ajaxurl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php"};
var is_cache_plugin_activate = {"is_active":"1"};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/resads/js/frontend.min.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.touchSwipe.min.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/jquery.easing.js></script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/imagesloaded.pkgd.min.js></script> <script>var mtphr_dnt_vars = {"is_rtl":""};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/ditty-news-ticker/legacy/static/js/ditty-news-ticker.min.js></script> <script src=https://s0.wp.com/wp-content/js/devicepx-jetpack.js></script> <script>var pollsL10n = {"ajax_url":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/wp-polls/polls-js.js></script> <script>var socialWarfare = {"addons":[],"post_id":"221613","floatBeforeContent":""};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/social-warfare/assets/js/script.min.js></script> <script src=https://secure.gravatar.com/js/gprofiles.js></script> <script>var WPGroHo = {"my_hash":""};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/jetpack/modules/wpgroho.js></script> <script>var tie = {"go_to":"Go to...","ajaxurl":"https:\/\/www.stlucianewsonline.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","is_singular":"1","reading_indicator":""};</script> <script src=https://www.stlucianewsonline.com/wp-content/themes/jarida/js/tie-scripts.js></script> <script src=https://www.stlucianewsonline.com/wp-includes/js/comment-reply.min.js></script> <script src=https://www.stlucianewsonline.com/wp-includes/js/wp-embed.min.js></script> <script async=async src=https://www.stlucianewsonline.com/wp-content/plugins/akismet/_inc/form.js></script> <script>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script src=https://www.stlucianewsonline.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js></script> <script>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});</script> <script>jQuery( document ).ready( function($) {
							$( '#mtphr-dnt-7756' ).ditty_news_ticker({
					id : '7756',
					type : 'scroll',
					scroll_direction : 'left',
					scroll_speed : 8,
					scroll_pause : 1,
					scroll_spacing : 40,
					scroll_init : 0,
					rotate_type : 'fade',
					auto_rotate : 0,
					rotate_delay : 7,
					rotate_pause : 0,
					rotate_speed : 3,
					rotate_ease : 'linear',
					nav_reverse : 0,
					disable_touchswipe : 0,
					offset : 20,
					after_load : function( $ticker ) {
											},
					before_change : function( $ticker ) {
											},
					after_change : function( $ticker ) {
											}
				});
			 			});</script> <script>var swp_nonce = "b243f50ad1";var swpFloatBeforeContent = false;var swpClickTracking = false;</script><script src=https://stats.wp.com/e-201918.js async=async defer=defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.2.1',blog:'42891802',post:'221613',tz:'-4',srv:'www.stlucianewsonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '42891802', '221613' ]);</script> <script>var _gaq = _gaq || [];

  _gaq.push(['_setAccount', 'UA-34917107-1']);

  _gaq.push(['_trackPageview']);



  (function() {

    var ga = document.createElement('script'); ga.type =

'text/javascript'; ga.async = true;

    ga.src = ('https:' == document.location.protocol ? 'https://ssl' :

'http://www') + '.google-analytics.com/ga.js';

    var s = document.getElementsByTagName('script')[0];

s.parentNode.insertBefore(ga, s);

  })();</script> 